NetBSD Problem Report #25673

Received: (qmail 3872 invoked by uid 605); 22 May 2004 17:33:05 -0000
Message-Id: <13760-1085247185@rainier.reedmedia.net>
Date: Sat, 22 May 2004 10:33:05 -0700
From: reed@reedmedia.net
Sender: gnats-bugs-owner@NetBSD.org
Reply-To: reed@reedmedia.net
To: gnats-bugs@gnats.netbsd.org
Subject: various psmisc issues
X-Send-Pr-Version: 3.95

>Number:         25673
>Category:       pkg
>Synopsis:       various psmisc issues
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    reed
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sat May 22 17:34:00 +0000 2004
>Closed-Date:    
>Last-Modified:  Sun Feb 13 03:24:00 +0000 2005
>Originator:     
>Release:        NetBSD 1.6.2_STABLE
>Organization:
http://bsd.reedmedia.net/
>Environment:


System: NetBSD rainier.reedmedia.net 1.6.2_STABLE NetBSD 1.6.2_STABLE (MYKERNEL) #0: Mon May 10 10:10:04 PDT 2004 reed@rainier.reedmedia.net:/usr/src/sys/arch/i386/compile/MYKERNEL i386
Architecture: i386
Machine: i386
>Description:
psmisc installs pidof and pidof manpage. But so does wip/sysvinit package.
On a Debian system, these are from the sysvinit package and psmisc
only provides killall, pstree (and pstree.x11) and fuser.
Maybe a pkgsrc preference can choose which package provides pidof?

Also allow fuser to be installed on systems like Linux.

And MESSAGE is operating system specific.
>How-To-Repeat:

>Fix:
Maybe a pkgsrc preference can choose which package provides pidof?

Allow fuser to be installed on systems like Linux. And fix DESCR.

Fix MESSAGE to not be operating system specific.
>Release-Note:
>Audit-Trail:

From: Thomas Klausner <wiz@NetBSD.org>
To: reed@reedmedia.net
Cc: gnats-bugs@gnats.netbsd.org
Subject: Re: pkg/25673: various psmisc issues
Date: Mon, 24 May 2004 02:35:06 +0200

 On Sat, May 22, 2004 at 10:33:05AM -0700, reed@reedmedia.net wrote:
 > >Number:         25673
 > >Category:       pkg
 > >Synopsis:       various psmisc issues
 [...]
 > >Description:
 > psmisc installs pidof and pidof manpage. But so does wip/sysvinit package.
 > On a Debian system, these are from the sysvinit package and psmisc
 > only provides killall, pstree (and pstree.x11) and fuser.
 > Maybe a pkgsrc preference can choose which package provides pidof?

 How about a package that only provides pidof and on which both
 packages can depend? Any working version should be fine, if one
 is clearly better than the other, choose that.

 > Also allow fuser to be installed on systems like Linux.
 > 
 > And MESSAGE is operating system specific.

 Could you please fix the PR yourself?

 Thanks,
  Thomas
Responsible-Changed-From-To: pkg-manager->reed
Responsible-Changed-By: reed@netbsd.org
Responsible-Changed-When: Sun, 13 Feb 2005 03:24:00 +0000
Responsible-Changed-Why:
I will handle this myself.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.