NetBSD Problem Report #31420

From www@netbsd.org  Thu Sep 29 22:56:26 2005
Return-Path: <www@netbsd.org>
Received: by narn.netbsd.org (Postfix, from userid 31301)
	id 51F7663B8C8; Thu, 29 Sep 2005 22:56:26 +0000 (UTC)
Message-Id: <20050929225626.51F7663B8C8@narn.netbsd.org>
Date: Thu, 29 Sep 2005 22:56:26 +0000 (UTC)
From: tmdraney@cox.net
Reply-To: tmdraney@cox.net
To: gnats-bugs@netbsd.org
Subject: macppc install using 2.0.2 fails to boot when ufs2 is used
X-Send-Pr-Version: www-1.0

>Number:         31420
>Category:       port-macppc
>Synopsis:       macppc install using 2.0.2 fails to boot when ufs2 is used
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-macppc-maintainer
>State:          closed
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Sep 29 22:57:00 +0000 2005
>Closed-Date:    Mon Sep 17 17:58:35 +0000 2012
>Last-Modified:  Mon Sep 17 17:58:35 +0000 2012
>Originator:     Merritt
>Release:        2.0.2
>Organization:
N/A
>Environment:
NetBSD kernel...net 2.0.2 NetBSD 2.0.2 (Generic) #0: Tue Mar 22 16:19:08
UTC 2005 jmc@faith.netbsd.org:/home/builds/ab/netbsd-2-0-2-Release/macppc/2000503220140Z-obj/home/builds/ab/netbsd-2-0-2-Release/src/sys/arch/macppc/compile/Generic macppc
>Description:
I installed NetBSD on my new powerbook using the install directions.  The only differences were that I also added a /usr and /home partition and used a different file system ufs2.  I did a newfs -O2 /dev/wd0? command to create the filesystems.  I did it on all partitions.  It seemed to install alright but it failed to boot from open firmware using the command

boot hd:,ofwboot.xcf hd:4,/netbsd

I had previously copied the ofwboot.xcf onto my first hfs partition containing osx.  I messed around with every command I could think of and could get nothing to work.  I then reinstalled netbsd again but reformated each partition with regular ffs and walla the above command had me booting into netbsd and all was well.  I again reinstalled it with ufs2 and it again failed.  I am now running netbsd under regular ffs and it is running well.  My guess would be there is a problem with Netbsds ofwboot.xcf on 2.0.2.
>How-To-Repeat:
Install netbsd on a AL powerbook 15" 1.65 ghz with newfs -O2 /dev/.. for all the partitions and install and try to boot into netbsd.  
>Fix:
Unknown

>Release-Note:

>Audit-Trail:

State-Changed-From-To: open->closed
State-Changed-By: jnemeth@NetBSD.org
State-Changed-When: Mon, 17 Sep 2012 17:58:35 +0000
State-Changed-Why:
NetBSD 2.0.2 is long past end of life.  If this problem shows up with a
supported version of NetBSD, the PR can be re-opened or a new one sent.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.