NetBSD Problem Report #33652

From smb@cs.columbia.edu  Tue Jun  6 00:25:24 2006
Return-Path: <smb@cs.columbia.edu>
Received: from mail.netbsd.org (mail.netbsd.org [204.152.190.11])
	by narn.NetBSD.org (Postfix) with ESMTP id 27C2063BACE
	for <gnats-bugs@gnats.NetBSD.org>; Tue,  6 Jun 2006 00:25:24 +0000 (UTC)
Message-Id: <20060606002517.33309B1607A@gg1.cs.columbia.edu>
Date: Mon,  5 Jun 2006 20:25:17 -0400 (EDT)
From: smb@cs.columbia.edu
Reply-To: smb@cs.columbia.edu
To: gnats-bugs@NetBSD.org
Subject: missing dependencies
X-Send-Pr-Version: 3.95

>Number:         33652
>Category:       pkg
>Synopsis:       several packages are missing dependencies
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          analyzed
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 06 00:30:00 +0000 2006
>Closed-Date:    
>Last-Modified:  Sat Jun 10 08:02:18 +0000 2006
>Originator:     Steven M. Bellovin
>Release:        NetBSD 3.99.20
>Organization:

>Environment:


System: NetBSD gg1.cs.columbia.edu 3.99.20 NetBSD 3.99.20 (GG1) #0: Sat May 27 20:19:03 EDT 2006 smb@gg1.cs.columbia.edu:/usr/BUILD/obj/sys/arch/i386/compile/GG1 i386
Architecture: i386
Machine: i386
>Description:
	Using pkgsrc HEAD (current as of an hour or two ago), some
	packages were missing dependencies.  This cause Gnome not to build.
	I had to manually build x11/py-gnome2-extras in order to get
	misc/deskbar-applet to build.  I had to manually build py-gtk2
	to make x11/py-gnome2 build.
>How-To-Repeat:
	See above
>Fix:
	Build manually

>Release-Note:

>Audit-Trail:

State-Changed-From-To: open->feedback
State-Changed-By: jlam@netbsd.org
State-Changed-When: Tue, 06 Jun 2006 14:21:24 +0000
State-Changed-Why:
Please let me know if revision 1.2 of pkgsrc/mk/flavor/pkg/reduce-depends.awk
on pkgsrc HEAD fixes the problem you are seeing.  Thanks!


From: "Steven M. Bellovin" <smb@cs.columbia.edu>
To: gnats-bugs@NetBSD.org
Cc: jlam@NetBSD.org, pkg-manager@NetBSD.org, pkgsrc-bugs@NetBSD.org,
	gnats-admin@NetBSD.org
Subject: Re: pkg/33652 (several packages are missing dependencies)
Date: Tue, 6 Jun 2006 12:55:04 -0400

 On Tue,  6 Jun 2006 14:21:25 +0000 (UTC), jlam@NetBSD.org wrote:

 > Synopsis: several packages are missing dependencies
 > 
 > State-Changed-From-To: open->feedback
 > State-Changed-By: jlam@netbsd.org
 > State-Changed-When: Tue, 06 Jun 2006 14:21:24 +0000
 > State-Changed-Why:
 > Please let me know if revision 1.2 of pkgsrc/mk/flavor/pkg/reduce-depends.awk
 > on pkgsrc HEAD fixes the problem you are seeing.  Thanks!
 > 
 > 
 Things seem better but not, I think, perfect -- here's what I just got
 after deleting gnome-2.14.0 py23-gnome2-2.12.4nb1 py23-gnome2-extras-2.12.0nb7 py23-gtk2-2.8.6 deskbar-applet-2.14.0.1nb1:

 ===> Returning to build of py23-gnome2-2.12.4nb1
 ===> Required installed package py23-gtk2>=2.8.4: py23-gtk2-2.8.6 found
 ===> Required installed package py24-gtk2>=2.8.5nb1: NOT found
 ===> Verifying package for ../../x11/py-gtk2
 ===> Checking for vulnerabilities in py24-gtk2-2.8.6
 => Checksum SHA1 OK for pygtk-2.8.6.tar.bz2.
 => Checksum RMD160 OK for pygtk-2.8.6.tar.bz2.
 ===> Overriding tools for py24-gtk2-2.8.6
 ERROR: [depends.mk] A package matching ``py24-gtk2>=2.8.5nb1'' should
 ERROR:     be installed, but one cannot be found.  Perhaps there is a
 ERROR:     stale work directory for ../../x11/py-gtk2?
 *** Error code 1

 Stop.
 make: stopped in /usr/pkgsrc/x11/py-gnome2
 *** Error code 1

 Stop.
 make: stopped in /usr/pkgsrc/x11/py-gnome2-extras
 *** Error code 1

 Stop.
 make: stopped in /usr/pkgsrc/misc/deskbar-applet
 *** Error code 1

 Stop.
 make: stopped in /usr/pkgsrc/meta-pkgs/gnome


 		--Steven M. Bellovin, http://www.cs.columbia.edu/~smb

From: "Johnny C. Lam" <jlam@brightdiamond.com>
To: "Steven M. Bellovin" <smb@cs.columbia.edu>
Cc: gnats-bugs@NetBSD.org
Subject: Re: pkg/33652 (several packages are missing dependencies)
Date: Tue, 06 Jun 2006 18:31:43 -0400

 Steven M. Bellovin wrote:
 > Things seem better but not, I think, perfect -- here's what I just got
 > after deleting gnome-2.14.0 py23-gnome2-2.12.4nb1 py23-gnome2-extras-2.12.0nb7 py23-gtk2-2.8.6 deskbar-applet-2.14.0.1nb1:
 > 
 > ===> Returning to build of py23-gnome2-2.12.4nb1
 > ===> Required installed package py23-gtk2>=2.8.4: py23-gtk2-2.8.6 found
 > ===> Required installed package py24-gtk2>=2.8.5nb1: NOT found
 > ===> Verifying package for ../../x11/py-gtk2
 > ===> Checking for vulnerabilities in py24-gtk2-2.8.6
 > => Checksum SHA1 OK for pygtk-2.8.6.tar.bz2.
 > => Checksum RMD160 OK for pygtk-2.8.6.tar.bz2.
 > ===> Overriding tools for py24-gtk2-2.8.6
 > ERROR: [depends.mk] A package matching ``py24-gtk2>=2.8.5nb1'' should
 > ERROR:     be installed, but one cannot be found.  Perhaps there is a
 > ERROR:     stale work directory for ../../x11/py-gtk2?
 > *** Error code 1
 > 
 > Stop.

 I've investigated some more.  The reason for the failure is that 
 deskbar-applet package directly and indirectly depends on two different 
 versions of py-gtk2, namely py23-gtk2 and py24-gtk2.  The problem is 
 that they are built from the same x11/py-gtk2 directory, so if, e.g. 
 py23-gtk2 is installed and the work directory is not removed, than any 
 subsequent build in x11/py-gtk2 will automatically return as a success 
 because of the presence of the "install cookie" from the previous 
 installation.

 I think you could get a successful build by removing the work directory 
 for x11/py-gtk2 manually.  Longer term, I think it would be best if you 
 directly set PYTHON_VERSION_DEFAULT to "24" in /etc/mk.conf to force 
 python-2.4.x to be installed to satisfy Python dependencies. 
 Unfortunately, you would need to "pkg_delete -r python23" to remove the 
 old Python and all packages that depended on it would have to be rebuilt.

 I really don't have a good solution to this problem.

 	Cheers,

 	-- Johnny Lam <jlam@pkgsrc.org>

From: "Steven M. Bellovin" <smb@cs.columbia.edu>
To: gnats-bugs@NetBSD.org
Cc: jlam@brightdiamond.com
Subject: Re: pkg/33652 (several packages are missing dependencies)
Date: Tue, 6 Jun 2006 20:12:15 -0400

 On Tue, 06 Jun 2006 18:31:43 -0400, "Johnny C. Lam"
 <jlam@brightdiamond.com> wrote:

 > Steven M. Bellovin wrote:
 > > Things seem better but not, I think, perfect -- here's what I just got
 > > after deleting gnome-2.14.0 py23-gnome2-2.12.4nb1 py23-gnome2-extras-2.12.0nb7 py23-gtk2-2.8.6 deskbar-applet-2.14.0.1nb1:
 > > 
 > > ===> Returning to build of py23-gnome2-2.12.4nb1
 > > ===> Required installed package py23-gtk2>=2.8.4: py23-gtk2-2.8.6 found
 > > ===> Required installed package py24-gtk2>=2.8.5nb1: NOT found
 > > ===> Verifying package for ../../x11/py-gtk2
 > > ===> Checking for vulnerabilities in py24-gtk2-2.8.6
 > > => Checksum SHA1 OK for pygtk-2.8.6.tar.bz2.
 > > => Checksum RMD160 OK for pygtk-2.8.6.tar.bz2.
 > > ===> Overriding tools for py24-gtk2-2.8.6
 > > ERROR: [depends.mk] A package matching ``py24-gtk2>=2.8.5nb1'' should
 > > ERROR:     be installed, but one cannot be found.  Perhaps there is a
 > > ERROR:     stale work directory for ../../x11/py-gtk2?
 > > *** Error code 1
 > > 
 > > Stop.
 > 
 > I've investigated some more.  The reason for the failure is that 
 > deskbar-applet package directly and indirectly depends on two different 
 > versions of py-gtk2, namely py23-gtk2 and py24-gtk2.  The problem is 
 > that they are built from the same x11/py-gtk2 directory, so if, e.g. 
 > py23-gtk2 is installed and the work directory is not removed, than any 
 > subsequent build in x11/py-gtk2 will automatically return as a success 
 > because of the presence of the "install cookie" from the previous 
 > installation.
 > 
 > I think you could get a successful build by removing the work directory 
 > for x11/py-gtk2 manually.  Longer term, I think it would be best if you 
 > directly set PYTHON_VERSION_DEFAULT to "24" in /etc/mk.conf to force 
 > python-2.4.x to be installed to satisfy Python dependencies. 
 > Unfortunately, you would need to "pkg_delete -r python23" to remove the 
 > old Python and all packages that depended on it would have to be rebuilt.
 > 
 In fact, I want to have only Python 2.4; I'll happily do that.  It worked,
 so I have no immediate problems.

 I wonder if there's some solution involing package options, perhaps
 specifying the version of python to use if there's no default set.


 		--Steven M. Bellovin, http://www.cs.columbia.edu/~smb

State-Changed-From-To: feedback->analyzed
State-Changed-By: wiz@netbsd.org
State-Changed-When: Sat, 10 Jun 2006 08:02:18 +0000
State-Changed-Why:
Feedback provided.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.