NetBSD Problem Report #35289

From www@NetBSD.org  Wed Dec 20 09:19:51 2006
Return-Path: <www@NetBSD.org>
Received: by narn.NetBSD.org (Postfix, from userid 31301)
	id 5A13263BA73; Wed, 20 Dec 2006 09:19:51 +0000 (UTC)
Message-Id: <20061220091951.5A13263BA73@narn.NetBSD.org>
Date: Wed, 20 Dec 2006 09:19:51 +0000 (UTC)
From: fanch@kekpar.net
Reply-To: fanch@kekpar.net
To: gnats-bugs@NetBSD.org
Subject: Build of graphics/xpm fails on Irix with MIPSPro
X-Send-Pr-Version: www-1.0

>Number:         35289
>Category:       pkg
>Synopsis:       Build of graphics/xpm fails on Irix with MIPSPro
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    irix-pkg-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Dec 20 09:20:00 +0000 2006
>Closed-Date:    
>Last-Modified:  Fri Feb 12 06:56:26 +0000 2010
>Originator:     Francois Brunel
>Release:        pkgsrc-2006Q3
>Organization:
>Environment:
IP30
Irix 6.5.30
MIPSPro 7.4.1m
ABI=32
>Description:
The build of graphics/xpm fails with system includes not found.
Tracked down the problem to xpkgwedge sgi.cf, so I will fill another PR.

The install fails with invalid PLIST: problems with the
revision number in package Imakefile, and symbolic links in pkgsrc
Makefile

Also, builtin.mk depends on awk non-portable features.

>How-To-Repeat:

>Fix:
--- builtin.mk.orig	2006-12-20 07:12:53.045269600 +0100
+++ builtin.mk
@@ -40,7 +40,7 @@ MAKEVARS+=	IS_BUILTIN.xpm
     !empty(IS_BUILTIN.xpm:M[yY][eE][sS]) && \
     empty(H_XPM:M__nonexistent__)
 BUILTIN_VERSION.xpm!=							\
-	${AWK} 'BEGIN { split("abcdefghijklmnopqrstuvwxyz", alpha, "");	\
+	${AWK} 'BEGIN { split("a b c d e f g h i j k l m n o p q r s t u v w x y z", alpha, " ");	\
 			p = ".0" }					\
 		/\#define[ 	]*XpmFormat/ { M = $$3 }		\
 		/\#define[ 	]*XpmVersion/ { m = "."$$3 }		\


--- Makefile.orig	2006-12-20 07:12:52.846540800 +0100
+++ Makefile
@@ -16,11 +16,13 @@ USE_IMAKE=	yes

 .include "../../mk/bsd.prefs.mk"

-.if ${OPSYS} == "SunOS"
+.if (${OPSYS} == "SunOS") || (${OPSYS} == "IRIX") 
 post-install:
 	cd ${PREFIX}/lib && \
+	${RM} -f libXpm.so && \
 	${RM} -f libXpm.so.4 && \
-	${LN} -f libXpm.so.4.11 libXpm.so.4
+	${LN} -s libXpm.so.4.11 libXpm.so && \
+	${LN} -s libXpm.so.4.11 libXpm.so.4
 .endif

 .if !empty(LOWER_OPSYS:Mirix5*)


-----------------
patches/patch-ac
-----------------

--- lib/Imakefile.orig	1998-03-19 20:50:59.000000000 +0100
+++ lib/Imakefile
@@ -34,7 +34,7 @@ XCOMM default locations
 #define XpmLibDir $(USRLIBDIR)
 #endif
 #ifndef XpmIncDir
-#define XpmIncDir $(INCDIR)
+#define XpmIncDir $(PROJECTROOT)/include
 #endif

 XCOMM If not already set in top dir,
@@ -55,7 +55,7 @@ REQUIREDLIBS = $(XLIB)
 #endif

 XCOMM on Dec Alpha we need to define the following to build the shared library
-#ifdef AlphaArchitecture
+#if defined(AlphaArchitecture) && defined(ModernOSF1)
 REQUIREDLIBS = $(LDPRELIB) $(XLIB)
 SO_REQLIBS = -lX11 -lc
 #endif
@@ -97,20 +97,22 @@ XPMINCDIR = XpmIncDir
 XCOMM get the version numbers from the xpm include file
 #define XPM_NUMBERS
 #include "xpm.h"
-SOXPMLIBREV = XpmVersion./**/XpmRevision
+SOXPMLIBREV = .XpmVersion./**/XpmRevision

 HEADERS = xpm.h
   SRCS = data.c create.c misc.c rgb.c scan.c parse.c hashtab.c \
 	 CrBufFrI.c CrDatFrP.c CrPFrBuf.c RdFToI.c WrFFrI.c \
 	 CrBufFrP.c CrIFrBuf.c CrPFrDat.c RdFToP.c WrFFrP.c \
 	 CrDatFrI.c CrIFrDat.c RdFToDat.c WrFFrDat.c \
-	 Attrib.c CrIFrP.c CrPFrI.c Image.c Info.c RdFToBuf.c WrFFrBuf.c
+	 Attrib.c CrIFrP.c CrPFrI.c Image.c Info.c RdFToBuf.c WrFFrBuf.c \
+	 s_popen.c

   OBJS = data.o create.o misc.o rgb.o scan.o parse.o hashtab.o \
 	 CrBufFrI.o CrDatFrP.o CrPFrBuf.o RdFToI.o WrFFrI.o \
 	 CrBufFrP.o CrIFrBuf.o CrPFrDat.o RdFToP.o WrFFrP.o \
 	 CrDatFrI.o CrIFrDat.o RdFToDat.o WrFFrDat.o \
-	 Attrib.o CrIFrP.o CrPFrI.o Image.o Info.o RdFToBuf.o WrFFrBuf.o
+	 Attrib.o CrIFrP.o CrPFrI.o Image.o Info.o RdFToBuf.o WrFFrBuf.o \
+	 s_popen.o

        INCLUDES = -I.
        LINTLIBS = $(LINTXTOLL) $(LINTXLIB) 

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->irix-pkg-people
Responsible-Changed-By: snj@netbsd.org
Responsible-Changed-When: Thu, 21 Dec 2006 06:44:40 +0000
Responsible-Changed-Why:
Irix-specific problem.


From: Joerg Sonnenberger <joerg@britannica.bec.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/35289: Build of graphics/xpm fails on Irix with MIPSPro
Date: Thu, 21 Dec 2006 15:51:19 +0100

 On Wed, Dec 20, 2006 at 09:20:00AM +0000, fanch@kekpar.net wrote:
 > Also, builtin.mk depends on awk non-portable features.

 This part is rejected as pkgsrc now requires a proper awk and installs
 it as part of the bootstrap.

 Joerg

From: Fanch <fanch@kekpar.net>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/35289: Build of graphics/xpm fails on Irix with MIPSPro
Date: Thu, 21 Dec 2006 17:04:20 +0100

 Joerg Sonnenberger wrote :
 >  > Also, builtin.mk depends on awk non-portable features.
 >  
 >  This part is rejected as pkgsrc now requires a proper awk and installs
 >  it as part of the bootstrap.
 >   
 To me, it doesn't seem using this proper version.

 cube$ su - root -c ksh
 # export PATH=/usr/pkg/bin:/usr/pkg/sbin:$PATH
 # echo $PATH
 /usr/pkg/bin:/usr/pkg/sbin:/usr/sbin:/usr/bsd:/sbin:/usr/bin:/etc:/usr/etc:/usr/bin/X11
 # cd /usr/pkg/src/editors/vim-motif
 # bmake show-var VARNAME=AWK
 /usr/bin/nawk
 # ls /usr/pkg/bin/nawk
 /usr/pkg/bin/nawk
 # bmake show-var VARNAME=BUILTIN_VERSION.xpm
 3.4
 #

 BUILTIN_VERSION.xpm should be 3.4f

 I have a similar problem with grep, native version being used in
 fontconfig, version which doesn't handle -w. To workaround, I
 added the following to fontconfig Makefile:

 USE_TOOLS+=             grep:pkgsrc
 _TOOLS_USE_PKGSRC.grep= yes

 The second line is not the right thing to do, but if TOOLS_PLATFORM.grep
 is set, it is used inconditionnaly in mk/tools/replace.mk
 But maybe I miss something?

 Fanch


 -- 



From: Joerg Sonnenberger <joerg@britannica.bec.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/35289: Build of graphics/xpm fails on Irix with MIPSPro
Date: Thu, 21 Dec 2006 17:17:12 +0100

 On Thu, Dec 21, 2006 at 04:05:03PM +0000, Fanch wrote:
 >  >  This part is rejected as pkgsrc now requires a proper awk and installs
 >  >  it as part of the bootstrap.
 >  >   
 >  To me, it doesn't seem using this proper version.

 IIRC bootstrap is supposed to create a mk.conf pointing to ${PREFIX} for
 known unsupported tools. Does that happen for you? If not, please
 provide the uname so that we can add it to the OS list :-)

 >  The second line is not the right thing to do, but if TOOLS_PLATFORM.grep

 mk.conf is to provide that.

 Joerg

From: Fanch <fanch@kekpar.net>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/35289: Build of graphics/xpm fails on Irix with MIPSPro
Date: Thu, 21 Dec 2006 17:49:52 +0100

 Joerg Sonnenberger wrote:
 >  >  To me, it doesn't seem using this proper version.
 >  
 >  IIRC bootstrap is supposed to create a mk.conf pointing to ${PREFIX} for
 >  known unsupported tools. Does that happen for you? If not, please
 >  provide the uname so that we can add it to the OS list :-)
 >   
 Oops, sorry, my fault.
 I've done a mix of a recent NetBSD and old Irix (2 years old)
 mk.conf, with only a quick glimpse at the generated mk.conf.example

 >  >  The second line is not the right thing to do, but if TOOLS_PLATFORM.grep
 >  
 >  mk.conf is to provide that. 
 >   
 Humm, having "USE_TOOLS+= grep:pkgsrc" (with OPSYS conditionnal)
 in the package Makefile could be a good solution (build dependency).
 But I don't understand why it doesn't work; I must miss
 something, one more time :-)


 -- 



State-Changed-From-To: open->feedback
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Wed, 10 Feb 2010 07:11:58 +0000
State-Changed-Why:
Is this still a problem with recent pkgsrc, libXpm, and builtin logic?


From: Fanch <fanch@kekpar.net>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/35289 (Build of graphics/xpm fails on Irix with MIPSPro)
Date: Wed, 10 Feb 2010 09:16:23 +0100

 Sorry, I have no MIPS hardware anymore.


State-Changed-From-To: feedback->open
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Fri, 12 Feb 2010 06:56:26 +0000
State-Changed-Why:
Submitter can't test any more. Anyone with Irix want to check?


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.