NetBSD Problem Report #37529

From  Thu Dec 13 07:01:32 2007
Return-Path: <>
Received: from ( [])
	by (Postfix) with ESMTP id A5CBD63B935
	for <>; Thu, 13 Dec 2007 07:01:32 +0000 (UTC)
Message-Id: <>
Date: Wed, 12 Dec 2007 23:01:29 -0800
From: bharder <>
Subject: graphviz/tcl Tcldot libraries
X-Send-Pr-Version: 3.95

>Number:         37529
>Category:       pkg
>Synopsis:       tcl libs aren't loadable
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Dec 13 07:05:00 +0000 2007
>Last-Modified:  Sat Mar 08 08:50:01 +0000 2008
>Originator:     bharder <>
>Release:        NetBSD 4.0_RC5
	Method Digital Logic (
System: NetBSD manchester 4.0_RC5 NetBSD 4.0_RC5 (manchester) #14: Wed Nov 28 05:02:28 PST 2007 root@manchester:/usr/obj/sys/arch/i386/compile/manchester i386
Architecture: i386
Machine: i386
	in Tcl: "package require Tcldot" doesn't load the graphviz libraries.

	I'm not a libtool expert, but the libs that are being produced are not
shared. There are complaints in the build process of not being able to
find library "tclstub84" (though there is a .a of it in /usr/pkg/lib)
repeatedly, and how libtool will not be able to build a shared lib
-- the path (-L/usr/pkg/lib) is there, but something is still amiss
(could the issue be with the pkgsrc/lang/tcl build?). In any event,
the .../lib/graphviz/pkgIndex.tcl has erroneous entries (for .so shared
objects), and there appears to be nothing built, loadable in Tcl. This
wasn't always the case.

	package require Tcldot ;# <---- watch failure here

From: David Holland <>
Subject: Re: pkg/37529: tcl libs aren't loadable
Date: Sat, 8 Mar 2008 06:03:52 +0000

 An additional comment on this PR is found in pkg/37530.

From: OBATA Akio <>
Subject: Re: pkg/37529: tcl libs aren't loadable
Date: Sat, 08 Mar 2008 17:30:51 +0900

 Transcript from PR 37530.

  Not mentioned in the previous PR is that there is no reference
  to needing pkgsrc/lang/tcl, yet there is a requirement (bl3)
  for pkgsrc/x11/tk. Tk itself requires Tcl, graphviz requires
  Tcl (in it's current build configuration), and dependencies
  don't "chain" as I understand, so a:
  .include "../../lang/tcl/" is in order.



NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD:,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.