NetBSD Problem Report #39672

From www@NetBSD.org  Thu Oct  2 13:00:18 2008
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [204.152.190.11])
	by narn.NetBSD.org (Postfix) with ESMTP id 0CACB63BD02
	for <gnats-bugs@gnats.netbsd.org>; Thu,  2 Oct 2008 13:00:18 +0000 (UTC)
Message-Id: <20081002130017.D236D63BD01@narn.NetBSD.org>
Date: Thu,  2 Oct 2008 13:00:17 +0000 (UTC)
From: kordex@gmail.com
Reply-To: kordex@gmail.com
To: gnats-bugs@NetBSD.org
Subject: www/opera broken on freebsd
X-Send-Pr-Version: www-1.0

>Number:         39672
>Category:       pkg
>Synopsis:       www/opera broken on freebsd
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-pkg-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Oct 02 13:05:00 +0000 2008
>Last-Modified:  Mon Jan 12 07:59:16 +0000 2009
>Originator:     Mikko Kortelainen
>Release:        None.
>Organization:
-
>Environment:
FreeBSD lilian.xnet.kx 7.0-RELEASE FreeBSD 7.0-RELEASE #3: Sat Sep 27 20:36:01 UTC 2008     root@lilian.xnet.kx:/usr/obj/usr/src/sys/LILIAN_KERN  i386

>Description:
lilian# cd /usr/pkgsrc/www/opera
lilian# bmake
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Bootstrap dependency tnftp-[0-9]*: found tnftp-20070806
===> Skipping vulnerability checks.
WARNING: No /usr/pkgdb/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/pkg/sbin/download-vulnerability-list'.
===> Building for opera-9.52
=> Substituting "opera" in man/opera.1
cd: can't cd to /usr/pkgsrc/www/opera/work/opera-9.52-2091.freebsd5-static-qt3.i386-en-660
*** Error code 2

Stop.
bmake: stopped in /usr/pkgsrc/www/opera
*** Error code 1

Stop.
bmake: stopped in /usr/pkgsrc/www/opera
lilian# 

>How-To-Repeat:
lilian# cd /usr/pkgsrc/www/opera
lilian# bmake
>Fix:
fix the makefile.

>Release-Note:

>Audit-Trail:
From: "kordex -" <kordex@gmail.com>
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/39672: www/opera broken on freebsd
Date: Thu, 2 Oct 2008 16:13:03 +0300

 ------=_Part_4028_8464061.1222953183576
 Content-Type: text/plain; charset=UTF-8
 Content-Transfer-Encoding: 7bit
 Content-Disposition: inline

 Also.

 lilian% opera
 /libexec/ld-elf.so.1: Shared object "libz.so.2" not found, required by
 "opera"


 2008/10/2 <gnats-admin@netbsd.org>

 > Thank you very much for your problem report.
 > It has the internal identification `pkg/39672'.
 > The individual assigned to look at your
 > report is: pkg-manager.
 >
 > >Category:       pkg
 > >Responsible:    pkg-manager
 > >Synopsis:       www/opera broken on freebsd
 > >Arrival-Date:   Thu Oct 02 13:05:00 +0000 2008
 >
 >

 ------=_Part_4028_8464061.1222953183576
 Content-Type: text/html; charset=UTF-8
 Content-Transfer-Encoding: 7bit
 Content-Disposition: inline

 <div dir="ltr">Also.<br><br>lilian% opera<br>/libexec/ld-elf.so.1: Shared object &quot;libz.so.2&quot; not found, required by &quot;opera&quot;<br><br><br><div class="gmail_quote">2008/10/2  <span dir="ltr">&lt;<a href="mailto:gnats-admin@netbsd.org">gnats-admin@netbsd.org</a>&gt;</span><br>
 <blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Thank you very much for your problem report.<br>
 It has the internal identification `pkg/39672&#39;.<br>
 The individual assigned to look at your<br>
 report is: pkg-manager.<br>
 <br>
 &gt;Category: &nbsp; &nbsp; &nbsp; pkg<br>
 &gt;Responsible: &nbsp; &nbsp;pkg-manager<br>
 &gt;Synopsis: &nbsp; &nbsp; &nbsp; www/opera broken on freebsd<br>
 &gt;Arrival-Date: &nbsp; Thu Oct 02 13:05:00 +0000 2008<br>
 <br>
 </blockquote></div><br></div>

 ------=_Part_4028_8464061.1222953183576--

From: "OBATA Akio" <obache@netbsd.org>
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/39672: www/opera broken on freebsd
Date: Mon, 13 Oct 2008 20:45:04 +0900

 FreeBSD part of www/opera is not updated, need to adjust not only ${WRKSRC},
 but also PLIST.freebsd.

 Rest of library mismatches are came from using opera for FreeBSD 5.x on FreeBSD 7.0.
 But the pkgsrc emul framework does not have capabilities to switch depending on os version.

Responsible-Changed-From-To: pkg-manager->freebsd-pkg-people
Responsible-Changed-By: obache@NetBSD.org
Responsible-Changed-When: Mon, 12 Jan 2009 07:59:16 +0000
Responsible-Changed-Why:
I updated opera to 9.63 and it works on my FreeBSD-7.0 box with compat5x and
compat6x packages from FreeBSD ports.
Should we have own emulators/freebsd_compatXX packages and
mk/emulator/freebsd-compat.mk framework?


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.