NetBSD Problem Report #39877

From www@NetBSD.org  Fri Nov  7 11:27:33 2008
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [204.152.190.11])
	by narn.NetBSD.org (Postfix) with ESMTP id 043C963BD86
	for <gnats-bugs@gnats.netbsd.org>; Fri,  7 Nov 2008 11:27:33 +0000 (UTC)
Message-Id: <20081107112732.9219963BD76@narn.NetBSD.org>
Date: Fri,  7 Nov 2008 11:27:32 +0000 (UTC)
From: srcshelton@gmail.com
Reply-To: srcshelton@gmail.com
To: gnats-bugs@NetBSD.org
Subject: X11 packages not working on IRIX
X-Send-Pr-Version: www-1.0

>Number:         39877
>Category:       pkg
>Synopsis:       X11 packages not working on IRIX
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    irix-pkg-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Nov 07 11:30:01 +0000 2008
>Last-Modified:  Mon Dec 29 12:48:24 +0000 2008
>Originator:     Stuart Shelton
>Release:        pkgsrc latest from CVS
>Organization:
>Environment:
IRIX 6.5.30f; MIPSpro Compilers, version 7.4.4m
>Description:

pidgin now relies on libXScrnSaver, which fails with:


checking pkg-config is at least version 0.9.0... yes
checking for XSCRNSAVER... configure: error: Package requirements (x11 xext xextproto scrnsaverproto >= 1.1) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the XSCRNSAVER_CFLAGS and XSCRNSAVER_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.
*** Error code 1

Stop.
bmake: stopped in /usr/bsd/src/x11/libXScrnSaver
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package Makefile.
*** Error code 1

Stop.
bmake: stopped in /usr/bsd/src/x11/libXScrnSaver


... this is odd, because amongst my installed packages I have:

Xfixes-2.0.1nb4/
Xrandr-1.0.2nb3/
Xrender-0.9.0nb2/
fixesproto-4.0/
x11-links-0.40/
xcmiscproto-1.1.2/
xcursor-1.1.2nb2/
xdg-dirs-1.4/
xdg-x11-dirs-1.4/
xextproto-7.0.3/
xf86bigfontproto-1.1.2/
xproto-7.0.14/

Attempting to build 'xauth' (as a randomly-chosen X11 package) goes in to slightly more detail:


checking for XAUTH... configure: error: Package requirements (x11 xau xext xmuu) were not met:

No package 'x11' found
No package 'xau' found
No package 'xext' found
No package 'xmuu' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XAUTH_CFLAGS
and XAUTH_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error code 1

Stop.
bmake: stopped in /usr/bsd/src/x11/xauth
*** Error code 1

Stop.
bmake: stopped in /usr/bsd/src/x11/xauth

>How-To-Repeat:

So far as I can see, at the very least 'x11' and 'xext' should be installed, so is this a PKG_CONFIG_PATH issue, or are the installed X11 pacakges not installing a pkg-config file?

Even explicitly setting PKG_CONFIG_PATH to /usr/bsd/lib/pkgconfig doesn't alter the problem...
>Fix:

>Release-Note:

>Audit-Trail:
From: "Jeremy C. Reed" <reed@reedmedia.net>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/39877: X11 packages not working on IRIX
Date: Fri, 7 Nov 2008 07:14:51 -0600 (CST)

 On Fri, 7 Nov 2008, srcshelton@gmail.com wrote:

 > x11-links-0.40/

 I am guessing you are using your native X11 (not X11_TYPE=modular).

 > So far as I can see, at the very least 'x11' and 'xext' should be 
 > installed, so is this a PKG_CONFIG_PATH issue, or are the installed X11 
 > pacakges not installing a pkg-config file?

 Maybe your native X11 doesn't provide the .pc (pkg-config) files or your 
 pkg-config doesn't find them (by default).

 Note that the pkgsrc build environment works hard at making a consistent 
 build so expects to use the .pc files from your native X11 and not from 
 pkgsrc.

From: "Stuart Shelton" <srcshelton@gmail.com>
To: gnats-bugs@netbsd.org
Cc: pkg-manager@netbsd.org, gnats-admin@netbsd.org, pkgsrc-bugs@netbsd.org
Subject: Re: pkg/39877: X11 packages not working on IRIX
Date: Fri, 7 Nov 2008 16:47:28 +0000

 You're right - IRIX provides no pkg-config files for anything.

 Does this mean that I have no option but to abandon my native X
 installation if I wish to install packages, such as pidgin, which do
 have a reliance on X components (even if the OS does supply them in
 some shape or form)?  Or is there some other way to generate or remove
 the need for pkg-config files for native components?


 2008/11/7 Jeremy C. Reed <reed@reedmedia.net>:
 > The following reply was made to PR pkg/39877; it has been noted by GNATS.
 >
 > From: "Jeremy C. Reed" <reed@reedmedia.net>
 > To: gnats-bugs@NetBSD.org
 > Cc:
 > Subject: Re: pkg/39877: X11 packages not working on IRIX
 > Date: Fri, 7 Nov 2008 07:14:51 -0600 (CST)
 >
 >  On Fri, 7 Nov 2008, srcshelton@gmail.com wrote:
 >
 >  > x11-links-0.40/
 >
 >  I am guessing you are using your native X11 (not X11_TYPE=modular).
 >
 >  > So far as I can see, at the very least 'x11' and 'xext' should be
 >  > installed, so is this a PKG_CONFIG_PATH issue, or are the installed X11
 >  > pacakges not installing a pkg-config file?
 >
 >  Maybe your native X11 doesn't provide the .pc (pkg-config) files or your
 >  pkg-config doesn't find them (by default).
 >
 >  Note that the pkgsrc build environment works hard at making a consistent
 >  build so expects to use the .pc files from your native X11 and not from
 >  pkgsrc.
 >
 >

From: "Jeremy C. Reed" <reed@reedmedia.net>
To: Stuart Shelton <srcshelton@gmail.com>
Cc: gnats-bugs@netbsd.org
Subject: Re: pkg/39877: X11 packages not working on IRIX
Date: Fri, 7 Nov 2008 11:03:32 -0600 (CST)

 > You're right - IRIX provides no pkg-config files for anything.
 > 
 > Does this mean that I have no option but to abandon my native X
 > installation if I wish to install packages, such as pidgin, which do
 > have a reliance on X components (even if the OS does supply them in
 > some shape or form)?  Or is there some other way to generate or remove
 > the need for pkg-config files for native components?

 I don't know what type and versions of X you have your IRIX.

 It is possible that the libXScrnSaver just can't be easily forced to use 
 dependencies from your native X.

 Some solutions are:

 - get the builtin.mk (via pkgsrc buildlinking) to generate .pc files 
   temporarily as needed per build. This is hard to do since we need to 
   detect various features to see if native library and headers are even 
   good enough.

 - get x11-links to pre-generate .pc files and include them with the 
   x11-links install. (Same argument as above.)

 - Use environment variables for various *_CFLAGS and *_LIBS when running 
   ./configure in pkgsrc build to skip the pkg-config checks. This is 
   probably not a good idea, as it is hard to maintain, and takes away the
   convenience of checking for correct versions.

 - use X11_TYPE=modular and use the X.org as included in pkgsrc (and you 
   can still use your native X server on your desktop).

 You may want to ask on pkgsrc-users to see what other IRIX users are doing 
 for packages that need X.

Responsible-Changed-From-To: pkg-manager->irix-pkg-people
Responsible-Changed-By: obache@NetBSD.org
Responsible-Changed-When: Mon, 29 Dec 2008 12:48:24 +0000
Responsible-Changed-Why:
Problem on IRIX.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.