NetBSD Problem Report #41664

From kre@munnari.OZ.AU  Thu Jul  2 20:46:27 2009
Return-Path: <kre@munnari.OZ.AU>
Received: from mail.netbsd.org (mail.netbsd.org [204.152.190.11])
	by www.NetBSD.org (Postfix) with ESMTP id CB9DC63B883
	for <gnats-bugs@gnats.NetBSD.org>; Thu,  2 Jul 2009 20:46:26 +0000 (UTC)
Message-Id: <200907022046.n62KkPbX027250@jade.coe.psu.ac.th>
Date: Fri, 3 Jul 2009 03:46:25 +0700 (ICT)
From: kre@munnari.OZ.AU
To: gnats-bugs@gnats.NetBSD.org
Subject: misc/openoffice3 build failure (NetBSD 4.0)
X-Send-Pr-Version: 3.95

>Number:         41664
>Category:       pkg
>Synopsis:       misc/openoffice3 build failure (NetBSD 4.0)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jul 02 20:50:00 +0000 2009
>Closed-Date:    
>Last-Modified:  Mon Feb 28 15:07:38 +0000 2011
>Originator:     Robert Elz
>Release:        NetBSD 4.0_STABLE
>Organization:
	Prince of Songkla University
>Environment:
System: NetBSD jade.coe.psu.ac.th 4.0_STABLE NetBSD 4.0_STABLE (JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 kre@jade.coe.psu.ac.th:/usr/obj/4/kernels/JADE i386
Architecture: i386
Machine: i386
>Description:
	openoffice3 is not building in a NetBSD 4.0 environment
	(different symptoms at least than PR41427 which is from -current)

>How-To-Repeat:
	I use pkg_comp with NetBSD 4.0 release sets (except x*) installed
	and pkgsrc modular xorg - with libkver to similate a 4.0 release
	system (I doubt any of that is particularly relevant).

	Usually I set seamonkey and lang-en-GB and lang-th in the
	options, but before this PR, I disabled all of that, to see if
	it was the non-default options causing the problem (it isn't).

	What I see is ... (with everything I could see in the build log
	that even smells like it might be a problem included ...)

-------------
making .dpslo
----------------------------------------------------------
- start unit test on library ../unxbsdi3.pro/lib/libtests.so
----------------------------------------------------------
testshl2 -sf /tmp/mk24811n ../unxbsdi3.pro/lib/libtests.so
dmake:  Error code 139, while making 'unittest'
Running processes: 0
=============
Building module udkapi
Running processes: 1
/pkg_comp/obj/pkgsrc/misc/openoffice3/4x/OOO310_m11/udkapi/com/sun/star/uno

	[ much deleted ]

making .dpslo
Running processes: 0
Running processes: 1
/pkg_comp/obj/pkgsrc/misc/openoffice3/4x/OOO310_m11/cppu/util
dmake:  /pkg_comp/obj/pkgsrc/misc/openoffice3/4x/OOO310_m11/solenv/inc/target.mk:  line 555:  Warning: -- Macro `SHL2TARGETN' redefined after use
cat /pkg_comp/obj/pkgsrc/misc/openoffice3/4x/OOO310_m11/solenv/src/version.c | sed s/_version.h/uno_cppu_version.h/ > ../unxbsdi3.pro/misc/uno_cppu_version.c
------------------------------
Making: ../unxbsdi3.pro/slo/uno_cppu_version.obj

	[ much deleted ]

/pkg_comp/obj/pkgsrc/misc/openoffice3/4x/OOO310_m11/solenv/bin/checkdll.sh -L../unxbsdi3.pro/lib -L/pkg_comp/obj/pkgsrc/misc/openoffice3/4x/OOO310_m11/solver/310/unxbsdi3.pro/lib  ../unxbsdi3.pro/lib/check_i18npool.uno.so
Checking DLL ../unxbsdi3.pro/lib/check_i18npool.uno.so ...-rwxr-xr-x  1 root  wheel  1770270 Jul  2 18:45 ../unxbsdi3.pro/lib/i18npool.uno.so
-------------
Running processes: 0
deliver -- version: 266154
Module 'i18npool' delivered successfully. 29 files copied, 5 files unchanged

1 module(s): 
	o3tl
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /pkg_comp/obj/pkgsrc/misc/openoffice3/4x/OOO310_m11/o3tl/qa

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from o3tl"

rmdir /tmp/22289
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/misc/openoffice3
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package Makefile.
*** Error code 1

Stop.

	If I was asked to guess, I'd suspect that the "error code 139"
	indicates a SIGSEGV in something or other, but ...

	I haven't been able to build openoffice3 (in this environment,
	I think I tried once on NetBSD 3, not that anyone would care
	about that one any more, since it was last upgraded (about May 12).

>Fix:

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->hira
Responsible-Changed-By: reed@NetBSD.org
Responsible-Changed-When: Sat, 04 Jul 2009 13:31:46 +0000
Responsible-Changed-Why:
Assign to package maintainer.


State-Changed-From-To: open->feedback
State-Changed-By: tnn@NetBSD.org
State-Changed-When: Sat, 08 Aug 2009 07:35:05 +0000
State-Changed-Why:
do you have openoffice3 already installed on the system,
and does the problem go away if you delete the package
prior to building?


From: Robert Elz <kre@munnari.OZ.AU>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/41664 (misc/openoffice3 build failure (NetBSD 4.0)) 
Date: Sat, 08 Aug 2009 17:48:51 +0700

     Date:        Sat,  8 Aug 2009 07:35:06 +0000 (UTC)
     From:        tnn@NetBSD.org
     Message-ID:  <20090808073506.9E98463BDF9@www.NetBSD.org>

   | do you have openoffice3 already installed on the system,
   | and does the problem go away if you delete the package
   | prior to building?

 No, as I think I said in the OR, I build using pkg_comp, it typically
 starts the build with nothing installed at all, when it finishes, all
 that will exist are what is needed as prerequisites (and a couple of
 pkg* related basic tools,, like pkg_chk, and what they need, like perl).

 I haven't attempted building this again for a while now, I can if you
 think anything might have changed that might have corrected it (some other
 package being updated, perhaps).

 kre

State-Changed-From-To: feedback->open
State-Changed-By: tnn@NetBSD.org
State-Changed-When: Sat, 08 Aug 2009 11:44:56 +0000
State-Changed-Why:
got feedback, it's not the same problem I had.


From: Robert Elz <kre@munnari.OZ.AU>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/41664: misc/openoffice3 build failure (NetBSD 4.0) 
Date: Tue, 01 Sep 2009 19:36:55 +0700

     Date:        Thu,  2 Jul 2009 20:50:01 +0000 (UTC)
     From:        kre@munnari.oz.au
     Message-ID:  <20090702205001.4310D63B976@www.NetBSD.org>

   | 	openoffice3 is not building in a NetBSD 4.0 environment
   | 	(different symptoms at least than PR41427 which is from -current)

 This problem remains, seemingly just the same, in the current (newer than
 the PR) version of openoffice ... that is in openoffice3-3.1.1

 kre

Responsible-Changed-From-To: hira->pkg-manager
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Mon, 28 Feb 2011 15:07:38 +0000
Responsible-Changed-Why:
Reset responsible field for retired developer.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.