NetBSD Problem Report #42137

From www@NetBSD.org  Tue Sep 29 19:10:36 2009
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [204.152.190.11])
	by www.NetBSD.org (Postfix) with ESMTP id 5EA6163C378
	for <gnats-bugs@gnats.netbsd.org>; Tue, 29 Sep 2009 19:10:36 +0000 (UTC)
Message-Id: <20090929191035.EA1D963B8B6@www.NetBSD.org>
Date: Tue, 29 Sep 2009 19:10:35 +0000 (UTC)
From: ahoka@netbsd.org
Reply-To: ahoka@netbsd.org
To: gnats-bugs@NetBSD.org
Subject: Cant build math/py-numpy when lang/g95 is installed
X-Send-Pr-Version: www-1.0

>Number:         42137
>Category:       pkg
>Synopsis:       Cant build math/py-numpy when lang/g95 is installed
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Sep 29 19:15:00 +0000 2009
>Originator:     Adam Hoka
>Release:        
>Organization:
>Environment:
>Description:
When buildin py-numpy with g95 present, it picks up g95 as the compiler (instead of pkgsrc's fortran compiler) and fails with this:

compile options: '-DNO_ATLAS_INFO=1 -Inumpy/core/include -Ibuild/src.netbsd-5.99.18-i386-2.5/numpy/core/include/numpy -Inumpy/core/src -Inumpy/core/include -I/usr/pkg/include/python2.5 -c'
/usr/pkg/bin/g95 -shared -L/usr/lib -Wl,-R/usr/lib -L/usr/pkg/lib/python2.5/config -Wl,-R/usr/pkg/lib/python2.5/config -L/usr/pkg/lib -Wl,-R/usr/pkg/lib build/temp.netbsd-5.99.18-i386-2.5/numpy/linalg/lapack_litemodule.o build/temp.netbsd-5.99.18-i386-2.5/numpy/linalg/python_xerbla.o -L/usr/pkg/lib -Lbuild/temp.netbsd-5.99.18-i386-2.5 -llapack -lblas -lpython2.5 -o build/lib.netbsd-5.99.18-i386-2.5/numpy/linalg/lapack_lite.so
/usr/bin/ld: cannot find -lf95
/usr/bin/ld: cannot find -lf95
error: Command "/usr/pkg/bin/g95 -shared -L/usr/lib -Wl,-R/usr/lib -L/usr/pkg/lib/python2.5/config -Wl,-R/usr/pkg/lib/python2.5/config -L/usr/pkg/lib -Wl,-R/usr/pkg/lib build/temp.netbsd-5.99.18-i386-2.5/numpy/linalg/lapack_litemodule.o build/temp.netbsd-5.99.18-i386-2.5/numpy/linalg/python_xerbla.o -L/usr/pkg/lib -Lbuild/temp.netbsd-5.99.18-i386-2.5 -llapack -lblas -lpython2.5 -o build/lib.netbsd-5.99.18-i386-2.5/numpy/linalg/lapack_lite.so" failed with exit status 1
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/math/py-numpy
*** Error code 1



This is py25-numpy-1.3.0nb1.


>How-To-Repeat:

>Fix:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.