NetBSD Problem Report #44586

From www@NetBSD.org  Wed Feb 16 21:19:19 2011
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [204.152.190.11])
	by www.NetBSD.org (Postfix) with ESMTP id 28BD063B907
	for <gnats-bugs@gnats.NetBSD.org>; Wed, 16 Feb 2011 21:19:19 +0000 (UTC)
Message-Id: <20110216211918.7E8BF63B11D@www.NetBSD.org>
Date: Wed, 16 Feb 2011 21:19:18 +0000 (UTC)
From: schaecsn@gmx.net
Reply-To: schaecsn@gmx.net
To: gnats-bugs@NetBSD.org
Subject: print/poppler does not compile on solaris
X-Send-Pr-Version: www-1.0

>Number:         44586
>Category:       pkg
>Synopsis:       print/poppler does not compile on solaris
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    solaris-pkg-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Feb 16 21:20:10 +0000 2011
>Last-Modified:  Sun Mar 27 18:57:13 +0000 2011
>Originator:     Stefan
>Release:        Sparc Solaris 9
>Organization:
>Environment:
Solaris 9/sparc
>Description:
pkgsrc 2010Q4: compiling poppler/TextOutputDev.cc: symbols fmin and fmax are not found.
>How-To-Repeat:
bmake
>Fix:
add defined(__sun) around the defintions of fmin and fmax in poppler/TextOutputDev.cc:


--- poppler/TextOutputDev.cc.orig       Wed Feb 16 11:59:48 2011
+++ poppler/TextOutputDev.cc    Wed Feb 16 12:04:17 2011
@@ -63,7 +63,7 @@
 #include "ICSupport.h"
 #endif

-#if defined(__DragonFly__) || defined(__NetBSD__)
+#if defined(__DragonFly__) || defined(__NetBSD__) || defined(__sun)
 #include <sys/param.h>
 #if !(defined(__DragonFly__) && __DragonFly_version >= 200204) && !(defined(__NetBSD__) && (__NetBSD_Version__ >= 599002100 || (__NetBSD_Version__ >= 501000000 && __NetBSD_Version__ < 599000000)))
 static double fmax(double x, double y) { if (isnan(x)) return y; if (isnan(y)) return x; return (x > y ? x : y);}


>Release-Note:

>Audit-Trail:
[20110327 shattered] edited Environment: field

Responsible-Changed-From-To: pkg-manager->solaris-pkg-people
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Fri, 18 Feb 2011 08:06:07 +0000
Responsible-Changed-Why:
Solaris pkgsrc problem.

Patch is included, is it fine for newer Solaris versions?


From: Tim Zingelman <zingelman@gmail.com>
To: gnats-bugs@netbsd.org
Cc: wiz@netbsd.org, solaris-pkg-people@netbsd.org, pkg-manager@netbsd.org, 
	pkgsrc-bugs@netbsd.org, gnats-admin@netbsd.org, schaecsn@gmx.net
Subject: Re: pkg/44586 (print/poppler does not compile on solaris)
Date: Fri, 18 Feb 2011 15:03:04 -0600

 On Fri, Feb 18, 2011 at 2:06 AM,  <wiz@netbsd.org> wrote:
 > Synopsis: print/poppler does not compile on solaris
 >
 > Responsible-Changed-From-To: pkg-manager->solaris-pkg-people
 > Responsible-Changed-By: wiz@NetBSD.org
 > Responsible-Changed-When: Fri, 18 Feb 2011 08:06:07 +0000
 > Responsible-Changed-Why:
 > Solaris pkgsrc problem.
 >
 > Patch is included, is it fine for newer Solaris versions?

 No.  At least on Solaris 10 (SunOS 5.10 Generic_144488-06 sun4u sparc
 SUNW,Sun-Fire-V440 Solaris)
 Solaris 10 5/09 s10s_u7wos_08 SPARC the patch results in:

   CXX    TextOutputDev.lo
 TextOutputDev.cc: In function 'double fmax(double, double)':
 TextOutputDev.cc:69: error: 'double fmax(double, double)' was declared
 'extern' and later 'static'
 /usr/pkg/gcc44/lib/gcc/sparc-sun-solaris2.10/4.4.4/include-fixed/iso/math_c99.h:164:
 error: previous declaration of 'double fmax(double, double)'
 TextOutputDev.cc: In function 'double fmin(double, double)':
 TextOutputDev.cc:70: error: 'double fmin(double, double)' was declared
 'extern' and later 'static'
 /usr/pkg/gcc44/lib/gcc/sparc-sun-solaris2.10/4.4.4/include-fixed/iso/math_c99.h:165:
 error: previous declaration of 'double fmin(double, double)'

 That is using gcc44-4.4.4nb1 as the compiler.

From: Stefan Schaeckeler <schaecsn@gmx.net>
To: gnats-bugs@NetBSD.org
Cc: solaris-pkg-people@NetBSD.org, gnats-admin@netbsd.org,
	pkgsrc-bugs@netbsd.org
Subject: Re: pkg/44586 (print/poppler does not compile on solaris)
Date: Fri, 18 Feb 2011 13:18:01 -0800 (PST)

 > From: Tim Zingelman <zingelman@gmail.com>
 > 
 > The following reply was made to PR pkg/44586; it has been noted by GNATS.
 > 
 > From: Tim Zingelman <zingelman@gmail.com>
 > To: gnats-bugs@netbsd.org
 > Cc: wiz@netbsd.org, solaris-pkg-people@netbsd.org, pkg-manager@netbsd.org, 
 > 	pkgsrc-bugs@netbsd.org, gnats-admin@netbsd.org, schaecsn@gmx.net
 > Subject: Re: pkg/44586 (print/poppler does not compile on solaris)
 > Date: Fri, 18 Feb 2011 15:03:04 -0600
 > 
 >  On Fri, Feb 18, 2011 at 2:06 AM,  <wiz@netbsd.org> wrote:
 >  > Synopsis: print/poppler does not compile on solaris
 >  >
 >  > Responsible-Changed-From-To: pkg-manager->solaris-pkg-people
 >  > Responsible-Changed-By: wiz@NetBSD.org
 >  > Responsible-Changed-When: Fri, 18 Feb 2011 08:06:07 +0000
 >  > Responsible-Changed-Why:
 >  > Solaris pkgsrc problem.
 >  >
 >  > Patch is included, is it fine for newer Solaris versions?
 >  
 >  No.  At least on Solaris 10 (SunOS 5.10 Generic_144488-06 sun4u sparc
 >  SUNW,Sun-Fire-V440 Solaris)
 >  Solaris 10 5/09 s10s_u7wos_08 SPARC the patch results in:
 >  
 >    CXX    TextOutputDev.lo
 >  TextOutputDev.cc: In function 'double fmax(double, double)':
 >  TextOutputDev.cc:69: error: 'double fmax(double, double)' was declared
 >  'extern' and later 'static'
 >  /usr/pkg/gcc44/lib/gcc/sparc-sun-solaris2.10/4.4.4/include-fixed/iso/math_c99.h:164:
 >  error: previous declaration of 'double fmax(double, double)'
 >  TextOutputDev.cc: In function 'double fmin(double, double)':
 >  TextOutputDev.cc:70: error: 'double fmin(double, double)' was declared
 >  'extern' and later 'static'
 >  /usr/pkg/gcc44/lib/gcc/sparc-sun-solaris2.10/4.4.4/include-fixed/iso/math_c99.h:165:
 >  error: previous declaration of 'double fmin(double, double)'
 >  
 >  That is using gcc44-4.4.4nb1 as the compiler.

 I used gcc 3.4 on Solaris 9. It does not come with math_c99.h.

  Stefan

 -- 

 Scotty: Captain, we din' can reference it!
 Kirk:   Analysis, Mr. Spock?
 Spock:  Captain, it doesn't appear in the symbol table.
 Kirk:   Then it's of external origin?
 Spock:  Affirmative.
 Kirk:   Mr. Sulu, go to pass two.
 Sulu:   Aye aye, sir, going to pass two.

From: Thomas Klausner <wiz@netbsd.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/44586 (print/poppler does not compile on solaris)
Date: Sat, 19 Feb 2011 09:45:08 +0100

 Thought so, thanks for testing. It should really check for fmax
 in the configure script.
  Thomas

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.