NetBSD Problem Report #44922

From www@NetBSD.org  Sun May  1 17:04:24 2011
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [204.152.190.11])
	by www.NetBSD.org (Postfix) with ESMTP id DDA4563C344
	for <gnats-bugs@gnats.NetBSD.org>; Sun,  1 May 2011 17:04:23 +0000 (UTC)
Message-Id: <20110501170423.3A4C763B9D1@www.NetBSD.org>
Date: Sun,  1 May 2011 17:04:23 +0000 (UTC)
From: tcpip4000@gmail.com
Reply-To: tcpip4000@gmail.com
To: gnats-bugs@NetBSD.org
Subject: Postgresql problem when build as a dependency 
X-Send-Pr-Version: www-1.0

>Number:         44922
>Category:       pkg
>Synopsis:       Postgresql problem when build as a dependency
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun May 01 17:05:00 +0000 2011
>Closed-Date:    
>Last-Modified:  Mon Apr 30 23:31:44 +0000 2012
>Originator:     Juan P. Daza P.
>Release:        5.1
>Organization:
ER Technology
>Environment:
NetBSD sephiro.ertech.net 5.1 NetBSD 5.1 (GENERIC) #0: Sat Nov  6 13:19:33 UTC 2010  builds@b6.netbsd.org:/home/builds/ab/netbsd-5-1-RELEASE/amd64/201011061943Z-obj/home/builds/ab/netbsd-5-1-RELEASE/src/sys/arch/amd64/compile/GENERIC amd64
>Description:
When building py-pyscopg2 it checks the version of postgresql already installed for the compilation; but it is ignoring it and always compiles postgresql84-client.

Looks like it tries to find libraries with names libecpg.so.6.0.X but the system has libraries installed with the name libecpg.so.6.X, this causes to never find the installed postgresql version.
>How-To-Repeat:
Install postgresql90-client
Then install py-psycopg2

The system will install postgresql84-client when it should use the already installed postgresql90-client.
>Fix:
Modify the name of the libraries it checks in pgsql.buildlink3.mk

>Release-Note:

>Audit-Trail:
From: Matthew Mondor <mm_lists@pulsar-zone.net>
To: gnats-bugs@NetBSD.org
Cc: pkgsrc-bugs@NetBSD.org
Subject: Re: port-amd64/44922: Postgresql problem when build as a dependency
Date: Sun, 1 May 2011 15:00:03 -0400

 On Sun,  1 May 2011 17:05:00 +0000 (UTC)
 tcpip4000@gmail.com wrote:

 > >Number:         44922
 > >Category:       port-amd64
 > >Synopsis:       Postgresql problem when build as a dependency

 This PR should be recategorized to the pkg category.

 Unfortunately, because it was in the wrong category, the PR didn't show
 up on the pkgsrc-bugs@ mailing list, but on the netbsd-bugs@ one
 instead.  I'm thus CCing pkgsrc-bugs so the PR gets noticed.

 Thanks,
 -- 
 Matt

Responsible-Changed-From-To: port-amd64-maintainer->pkg-manager
Responsible-Changed-By: dholland@NetBSD.org
Responsible-Changed-When: Sun, 01 May 2011 20:41:39 +0000
Responsible-Changed-Why:
pkgsrc issue.
also, I'm not sure there's an issue here besides needing to set
PGSQL_VERSION_DEFAULT=90 in mk.conf.


State-Changed-From-To: open->feedback
State-Changed-By: asau@NetBSD.org
State-Changed-When: Mon, 02 May 2011 10:22:36 +0000
State-Changed-Why:
Check if you set PGSQL_VERSION_DEFAULT properly,
in this particular case it should be "90".


From: "OBATA Akio" <obache@netbsd.org>
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/44922 (Postgresql problem when build as a dependency)
Date: Wed, 04 May 2011 18:13:45 +0900

 PGSQL_VERSION should be picked up from installed one.

 This issue might come from installed Postgresql version check.
 In mk/pgsql.buildilnk3.mk, existence of ${LOCALBASE}/lib/libecpg.* will be checked.
 If PG_SUBPREFIX is set, it will not work as expected.

 -- 
 OBATA Akio / obache@NetBSD.org

From: David Holland <dholland-pbugs@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/44922 (Postgresql problem when build as a dependency)
Date: Sat, 7 May 2011 02:17:23 +0000

 On Wed, May 04, 2011 at 09:15:05AM +0000, OBATA Akio wrote:
  >  This issue might come from installed Postgresql version check.
  >  In mk/pgsql.buildilnk3.mk, existence of ${LOCALBASE}/lib/libecpg.*
  >  will be checked.
  >  If PG_SUBPREFIX is set, it will not work as expected.

 Is the idea of that to allow having different PG_SUBPREFIX settings
 for multiple versions installed at once? Or would it work to just
 change those checks to include PG_SUBPREFIX?

 -- 
 David A. Holland
 dholland@netbsd.org

State-Changed-From-To: feedback->open
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Mon, 30 Apr 2012 23:31:44 +0000
State-Changed-Why:
No response from submitter; however, some issues with the behavior
when PG_SUBPREFIX is set have been discovered, and this should be
sorted out.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.