NetBSD Problem Report #46154

From www@NetBSD.org  Thu Mar  8 16:48:50 2012
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	by www.NetBSD.org (Postfix) with ESMTP id AE1B263E2E8
	for <gnats-bugs@gnats.NetBSD.org>; Thu,  8 Mar 2012 16:48:50 +0000 (UTC)
Message-Id: <20120308164849.B86EC63B8C0@www.NetBSD.org>
Date: Thu,  8 Mar 2012 16:48:49 +0000 (UTC)
From: davshao@gmail.com
Reply-To: davshao@gmail.com
To: gnats-bugs@NetBSD.org
Subject: python27 mismatched installed packages using pkg_chk
X-Send-Pr-Version: www-1.0

>Number:         46154
>Category:       pkg
>Synopsis:       python27 mismatched installed packages using pkg_chk
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 08 16:50:00 +0000 2012
>Originator:     David Shao
>Release:        NetBSD 6.99.3
>Organization:
>Environment:
NetBSD 6.99.3 (GENERIC) /usr/obj/sys/arch/amd64/compile/GENERIC amd64

>Description:
Updating to pkgsrc current, apparently after the pkgsrc switch to Python 2.7 as default, running pkg_rolling-replace on a system with meta-pkgs installed such as kde4 and xfce4 produces errors such as:

RR> Checking for mismatched installed packages using pkg_chk
rr> devel/py-ZopeInterface - py27-ZopeInterface-3.6.7 missing
rr> devel/py-setuptools - py27-setuptools-0.6c11nb1 missing
rr> lang/py-pyrex - py27-pyrex-0.9.9 missing
rr> math/py-roman - py27-roman-1.4.0 missing
rr> net/py-twisted - py27-twisted-11.0.0 missing
rr> print/py-cups - py27-cups-1.9.47nb3 missing
rr> security/py-OpenSSL - py27-OpenSSL-0.13 missing
rr> sysutils/py-dbus - py27-dbus-0.83.1nb3 missing
rr> textproc/py-cElementTree - py27-cElementTree-0nb1 missing
rr> textproc/py-docutils - py27-docutils-0.8.1nb1 missing
rr> textproc/py-elementtree - py27-elementtree-1.2.6nb4 missing
rr> textproc/py-expat - py27-expat-0nb5 missing
rr> textproc/py-libxml2 - py27-libxml2-2.7.8nb1 missing
rr> textproc/py-libxslt - py27-libxslt-1.1.26nb1 missing
rr> x11/py-qt4 - py27-qt4-4.9.1nb1 missing
rr> x11/py-sip - py27-sip-4.13.2 missing
rr> x11/py-xcbgen - py27-xcbgen-1.6nb2 missing
rr> Installed: py27-ZopeInterface-3.6.7 py27-setuptools-0.6c11nb1 py27-pyrex-0.9.9 py27-roman-1.4.0 py27-twisted-11.0.0 py27-cups-1.9.47nb3 py27-OpenSSL-0.13 py27-dbus-0.83.1nb3 py27-cElementTree-0nb1 py27-docutils-0.8.1nb1 py27-elementtree-1.2.6nb4 py27-expat-0nb5 py27-libxml2-2.7.8nb1 py27-libxslt-1.1.26nb1 py27-qt4-4.9.1nb1 py27-sip-4.13.2 py27-xcbgen-1.6nb2

RR> Tsorting dependency graph
*** pkg_chk reports the following packages need replacing, but they are not installed: py27-OpenSSL
py27-ZopeInterface
py27-cElementTree
py27-cups
py27-dbus
py27-docutils
py27-elementtree
py27-expat
py27-libxml2
py27-libxslt
py27-pyrex
py27-qt4
py27-roman
py27-setuptools
py27-sip
py27-twisted
py27-xcbgen
*** Please read the errors listed above, fix the problem,
*** then re-run pkg_rolling-replace to continue.


>How-To-Repeat:
Update to pkgsrc current on a system with various large meta-pkgs installed and run
pkg_rolling-replace -u
>Fix:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.