NetBSD Problem Report #46406

From www@NetBSD.org  Fri May  4 06:15:39 2012
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	by www.NetBSD.org (Postfix) with ESMTP id 96DFE63B91F
	for <gnats-bugs@gnats.NetBSD.org>; Fri,  4 May 2012 06:15:39 +0000 (UTC)
Message-Id: <20120504061538.8464963B915@www.NetBSD.org>
Date: Fri,  4 May 2012 06:15:38 +0000 (UTC)
From: bartosz.kuzma@gmail.com
Reply-To: bartosz.kuzma@gmail.com
To: gnats-bugs@NetBSD.org
Subject: www/ap2-subversion does not build with PREFER_PKGSRC+= iconv
X-Send-Pr-Version: www-1.0

>Number:         46406
>Category:       pkg
>Synopsis:       www/ap2-subversion does not build with PREFER_PKGSRC+= iconv
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri May 04 06:20:00 +0000 2012
>Originator:     Bartosz Kuzma
>Release:        NetBSD/i386 5.1
>Organization:
>Environment:
>Description:
I have whole pkg build with PREFER_PKGSRC+= iconv. During building of www/ap2-subversion the following error occurs:

--- subversion/mod_authz_svn/mod_authz_svn.la ---
cd subversion/mod_authz_svn && /bin/sh /usr/pkgsrc/www/ap2-subversion/work/subversion-1.6.17/libtool --tag=CC --silent --mode=link cc  -O2 -I/usr/pkg/include -I/usr/include -I/usr/X11R7/include -I/usr/pkg/include/apr-1   -pthread   -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/lib -Wl,-R/usr/lib -L/usr/X11R7/lib -Wl,-R/usr/X11R7/lib    -L/usr/X11R7/lib  -rpath /usr/pkg/lib/httpd -avoid-version -module  -o mod_authz_svn.la  mod_authz_svn.lo ../../subversion/libsvn_repos/libsvn_repos-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la -lintl
*** Warning: linker path does not have real file for library -liconv.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libiconv but no candidates were found. (...for regex pattern test)
*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module mod_authz_svn.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.
*** Please use pkgtools/verifypc to sanity check dependencies.
=> Unwrapping files-to-be-installed.
gdr74# make install
=> Bootstrap dependency digest>=20010302: found digest-20111104
===> Installing for ap22-subversion-1.6.17nb3
=> Generating pre-install file lists
cd subversion/mod_dav_svn ; /usr/bin/install -c -o root -g wheel -d "/usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd" ; /usr/pkg/sbin/apxs -i -S LIBEXECDIR="/usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd" -n dav_svn mod_dav_svn.la
/usr/pkg/share/httpd/build/instdso.sh SH_LIBTOOL='libtool' mod_dav_svn.la /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd
libtool --mode=install cp mod_dav_svn.la /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/
libtool: install: warning: relinking `mod_dav_svn.la'
libtool: install:  (cd /usr/pkgsrc/www/ap2-subversion/work/subversion-1.6.17/subversion/mod_dav_svn; /bin/sh /usr/pkg/bin/libtool --tag CC --silent --mode=relink cc -O2 -pthread -L/usr/pkgsrc/www/ap2-subversion/work/.buildlink/lib -Wl,-R/usr/pkg/lib -L/usr/pkgsrc/www/ap2-subversion/work/.x11-buildlink/lib -Wl,-R/usr/X11R7/lib -rpath /usr/pkg/lib/httpd -avoid-version -module -o mod_dav_svn.la activity.lo authz.lo deadprops.lo liveprops.lo lock.lo merge.lo mirror.lo mod_dav_svn.lo reports/dated-rev.lo reports/deleted-rev.lo reports/file-revs.lo reports/get-location-segments.lo reports/get-locations.lo reports/get-locks.lo reports/log.lo reports/mergeinfo.lo reports/replay.lo reports/update.lo repos.lo util.lo version.lo -L../../subversion/libsvn_repos/.libs ../../subversion/libsvn_repos/libsvn_repos-1.la -L../../subversion/libsvn_fs/.libs ../../subversion/libsvn_fs/libsvn_fs-1.la -L../../subversion/libsvn_delta/.libs ../../subversion/libsvn_delta/libsvn_delta-1.la -L../../subve
 rsion/libsvn_subr/.libs ../../subversion/libsvn_subr/libsvn_subr-1.la -lintl -inst-prefix-dir /usr/pkgsrc/www/ap2-subversion/work/.destdir)

*** Warning: linker path does not have real file for library -liconv.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libiconv and none of the candidates passed a file format test
*** using a regex pattern. Last file checked: /usr/pkgsrc/www/ap2-subversion/work/.buildlink/lib/libaprutil-1.so

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module mod_dav_svn.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.
libtool: install: cp .libs/mod_dav_svn.lai /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/mod_dav_svn.la
libtool: install: cp .libs/mod_dav_svn.a /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/mod_dav_svn.a
libtool: install: chmod 644 /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/mod_dav_svn.a
libtool: install: ranlib /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/mod_dav_svn.a
libtool: install: warning: remember to run `libtool --finish /usr/pkg/lib/httpd'
Warning!  dlname not found in /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/mod_dav_svn.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/mod_dav_svn.so
chmod: /usr/pkgsrc/www/ap2-subversion/work/.destdir/usr/pkg/lib/httpd/mod_dav_svn.so: No such file or directory
apxs:Error: Command failed with rc=65536
.
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/www/ap2-subversion/work/subversion-1.6.17
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/www/ap2-subversion
*** Error code 1

>How-To-Repeat:
Add the following line to /etc/mk.conf:

PREFER_PKGSRC+= iconv

go to pkgsrc/www/ap2-subversion

# make install
>Fix:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.