NetBSD Problem Report #47060

From  Fri Oct 12 10:02:09 2012
Return-Path: <>
Received: from ( [])
	by (Postfix) with ESMTP id 4B91E63B8DB
	for <>; Fri, 12 Oct 2012 10:02:09 +0000 (UTC)
Message-Id: <>
Date: Fri, 12 Oct 2012 12:02:04 +0200 (CEST)
Subject: pkgin is sometimes too terse and operator-unfriendly
X-Send-Pr-Version: 3.95

>Number:         47060
>Category:       pkg
>Synopsis:       pkgin is sometimes too terse and operator-unfriendly
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    imil
>State:          closed
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Oct 12 10:05:00 +0000 2012
>Closed-Date:    Sat Jun 01 22:11:44 +0000 2013
>Last-Modified:  Sat Jun 01 22:11:44 +0000 2013
>Originator:     Havard Eidnes
>Release:        NetBSD 6.0_RC2
System: NetBSD 6.0_RC2 NetBSD 6.0_RC2 (JONSVATNET) #10: Mon Sep 24 14:50:04 CEST 2012 i386
Architecture: i386
Machine: i386
	I tried to use "pkgin full-upgrade" after doing "pkgin update"
	on this NetBSD/i386 6.0_RC2 system, pointing towards
	as the only repository.

	This is what I get:

jonsvatnet# pkgin -V fug
calculating dependencies... done.
pkgin: /var/db/pkgin/cache has not enough space for download


	(I beleive the error message is not good English, I would
	rather say "/var/db/pkgin/cache does not have enough space
	for download".)

	However, it does not say what it actually wants to do, how
	much it wants to download, or anything like that -- it just
	says "you have too little free space".

	Couple that with the apparent inability to direct it to use
	some other space for caching the binary packages, I'm sort
	of lost what to do.

	I could of course clean out the entire 1.2GB of packages in
	/var/db/pkgin/cache, but pkgin's claim looks ... preposterous,
	and I would like to have more information to go on before
	trusting that it did indeed get its calculation right.

	My /var file system has after all 2.9GB space free:

jonsvatnet# df -h /var
Filesystem         Size       Used      Avail %Cap Mounted on
/dev/wd0f          4.8G       1.6G       2.9G  35% /var

	and my /usr/pkg in total contains 4.7GB:

jonsvatnet# du -hs /usr/pkg
4.7G    /usr/pkg

	Doing just a "pkgin upgrade", on the other hand, says that there
	is nothing to do:

jonsvatnet# pkgin upgrade
nothing to do.

	so I am somewhat doubdtful that it wants to replace all my
	packages under the "full-upgrade" command.

	Don't quite know, but see above.


CVS version have a fix provided by stacktic@, will be bundled with pkgin 0.6.3



Responsible-Changed-From-To: pkg-manager->imil
Responsible-Changed-When: Fri, 12 Oct 2012 11:46:18 +0000
Over to author.

From: Havard Eidnes <>
Subject: Re: pkg/47060 (pkgin is sometimes too terse and
Date: Fri, 12 Oct 2012 15:58:19 +0200 (CEST)


 just an update:

 I moved away all of /var/db/pkgin/cache, and did a new "pkgin
 full-upgrade" attempt, and got the following.  I don't beleive
 pkgin is correct when it says "0B to install"?

 jonsvatnet# pkgin full-upgrade
 calculating dependencies... done.

 131 packages to be upgraded: xtrans-1.2.5 xchat-2.8.8nb5 xcb-proto-1.6 =
 xbitmaps-1.1.0 unzip-6.0 ruby19-base-1.9.2pl290nb5 ruby18-sqlite3-1.3.3=
 nb1 py26-pytz-2010k py26-libxml2-2.7.8 pixman-0.22.2nb2 pciutils-3.1.3n=
 b1 mew-6.4nb1 links-gui-2.5nb2 libdrm-2.4.20 kdenetwork4-4.8.0 imake-1.=
 0.3nb1 gtk-doc-1.18nb1 gtar-base-1.26 gsed-4.2.1nb2 gnome-doc-utils-0.2=
 0.6nb1 gmake-3.82nb3 glproto-1.4.14 gimp-2.6.12nb2 gawk-4.0.0 freetype2=
 -2.4.4 fontconfig-2.8.0nb3 font-util-1.1.1 emacs-w3m-1.4.394.20100524nb=
 1 bigreqsproto-1.1.0 automake-1.11.3nb2 xorg-cf-files-1.0.4nb3 xmlrpc-c=
 -ss-1.16.40 ruby193-sqlite3-1.3.5 ruby18-rubygems-1.8.12 ruby18-base-1.=
 8.7.357 qt4-qdbus-4.8.0nb3 python26-2.6.7nb2 py27-libxslt-1.1.26nb1 ort=
 p-0.16.1nb3 neon-0.29.6 nas-1.9.1nb2 mkfontscale-1.0.9nb1 mkfontdir-1.0=
 .6 meanwhile-1.0.2nb3 libVNCServer- kdelibs4-4.8.0nb2 kde-worksp=
 ace4-4.8.0 kde-runtime4-4.8.0nb1 kde-baseapps4-4.8.0nb1 libwmf-
 b10 babl-0.1.6 gegl-0.1.8nb2 gdk-pixbuf2-xlib-2.24.1nb2 encodings-1.0.3=
  emacs-23.4nb1 autoconf-2.68nb2 xine-lib-1.2.1 soprano-2.7.4 samba-3.6.=
 4 ruby193-base-1.9.3p125nb1 rarian-0.8.1nb1 qt4-tools-4.8.0nb2 qt4-libs=
 -4.8.0nb4 strigi-0.6.4nb11 py27-kde4-4.8.0 phonon-4.5.1 oxygen-icons-4.=
 8.0 m4-1.4.16nb1 m17n-lib-1.6.2nb3 libusb-0.1.12nb2 libdbusmenu-qt-0.9.=
 0 libcanberra-0.26nb5 libaudiofile-0.3.3 kdepimlibs4-4.8.0 libxklavier-=
 5.0nb3 kactivities-4.8.0 gnome-desktop-2.32.1nb6 exiv2-0.22 MesaLib-7.4=
 .4nb4 vcdimager-0.7.24 redland-1.0.15 python27-2.7.2nb3 py27-qt4-4.9.1n=
 b1 py27-numpy-1.4.1nb3 pulseaudio-0.9.21nb14 nss-3.13.3 iodbc-3.52.7nb2=
  gnome-icon-theme-2.30.3nb7 ffmpeg-20120112.0.7.11nb3 desktop-file-util=
 s-0.19nb1 bash-4.2nb1 akonadi-1.7.0 shared-mime-info-1.0nb1 rasqal-0.9.=
 28 py27-expat-0nb5 policykit-0.9nb10 pango-1.29.4nb3 nspr-4.9.3 libvpx-=
 1.0.0 hal-0.5.14nb6 gobject-introspection-1.30.0nb3 gnupg2-2.0.18nb2 gl=
 ib-networking-2.30.2nb2 gdk-pixbuf2-2.24.1nb3 cairo-1.10.2nb4 avahi-0.6=
 .30nb6 atk-2.2.0nb3 py27-libxml2-2.7.8nb1 png-1.5.10 mpfr- gnutl=
 s-2.12.17 fftw-3.3.1 dirmngr-1.1.0nb2 libtasn1-2.12 libidn-1.24 gmp-5.0=
 .4 tiff-4.0.1nb1

 133 packages to be installed: tiff-4.0.2nb1 libtasn1-2.13 libidn-1.25 g=
 mp-5.0.5 py27-libxml2-2.7.8nb2 png-1.5.12 mpfr-3.1.0 gnutls-2.12.19 fft=
 w-3.3.2 dirmngr-1.1.0nb3 shared-mime-info-1.0nb2 rasqal-0.9.29nb1 py27-=
 expat-0nb6 policykit-0.9nb11 pango-1.30.0 nspr- libvpx-1.1.0 hal=
 -0.5.14nb7 gobject-introspection-1.32.1 gnupg2-2.0.19 glib-networking-2=
 .32.1 gdk-pixbuf2-2.26.1nb2 cairo-1.10.2nb5 avahi-0.6.31nb1 atk-2.4.0 v=
 cdimager-0.7.24nb1 redland-1.0.15nb1 python27-2.7.3 py27-qt4-4.9.1nb3 p=
 y27-numpy-1.6.1 pulseaudio-0.9.21nb15 nss-3.13.5 iodbc-3.52.8 gnome-ico=
 n-theme-2.30.3nb8 ffmpeg-20120409.0.7.12 desktop-file-utils-0.20 bash-4=
 .2nb2 akonadi-1.7.0nb1 xine-lib-1.2.1nb1 soprano-2.7.4nb1 samba-3.6.5 r=
 uby193-base-1.9.3p194nb1 rarian-0.8.1nb2 qt4-tools-4.8.2 qt4-libs-4.8.2=
  strigi-0.6.4nb12 py27-kde4-4.8.4 phonon-4.5.1nb1 oxygen-icons-4.8.4 m4=
 -1.4.16nb3 m17n-lib-1.6.2nb4 libusb-0.1.12nb3 libdbusmenu-qt-0.9.2 libc=
 anberra-0.26nb6 libaudiofile-0.3.4 kdepimlibs4-4.8.4nb2 libxklavier-5.0=
 nb4 kactivities-4.8.4 gnome-desktop-2.32.1nb7 exiv2-0.23 MesaLib-7.4.4n=
 b5 xorg-cf-files-1.0.4nb4 xmlrpc-c-ss-1.16.41 ruby193-sqlite3-1.3.6 rub=
 y18-rubygems-1.8.24 ruby18-base- qt4-qdbus-4.8.2 python26-2=
 .6.8 py27-libxslt-1.1.26nb2 ortp-0.16.1nb4 neon-0.29.6nb1 nas-1.9.1nb3 =
 mkfontscale-1.1.0 mkfontdir-1.0.7 meanwhile-1.0.2nb4 libVNCServer-0.9.9=
  kdelibs4-4.8.4 kde-workspace4-4.8.4 kde-runtime4-4.8.4 kde-baseapps4-4=
 .8.4 libwmf- babl-0.1.10 gegl-0.2.0nb1 gdk-pixbuf2-xlib-2.26=
 .1 encodings-1.0.4 emacs-23.4nb4 autoconf-2.69 xtrans-1.2.7 xchat-2.8.8=
 nb6 xcb-proto-1.7.1nb1 xbitmaps-1.1.1 unzip-6.0nb1 ruby19-base-1.9.2pl3=
 20nb1 ruby18-sqlite3-1.3.6 g95-0.92 py26-pytz-2012c py26-libxml2-2.7.8n=
 b2 pixman-0.24.4nb1 pciutils-3.1.9 mew-6.5 links-gui-2.6 libpciaccess-0=
 .11.0nb1 libdrm-2.4.35 kdenetwork4-4.8.4 imake-1.0.5 gtk-doc-1.18nb2 gt=
 ar-base-1.26nb2 gsed-4.2.1nb4 gnome-doc-utils-0.20.6nb2 gmake-3.82nb5 g=
 lproto-1.4.15 gimp-2.8.0nb3 gawk-4.0.1nb2 freetype2-2.4.9 fontconfig-2.=
 9.0 font-util-1.3.0 emacs-w3m-1.4.442.20110729nb1 bigreqsproto-1.1.2 au=
 tomake-1.12.2 (3279M to download, 0B to install)

 proceed ? [Y/n] y


 - H=E5vard

State-Changed-From-To: open->feedback
State-Changed-When: Sat, 17 Nov 2012 14:09:20 +0000
Fix available in pkgin's CVS, could you try it ?

From: "Emile iMil Heitor" <>
Subject: PR/47060 CVS commit: pkgsrc/pkgtools/pkgin
Date: Fri, 14 Dec 2012 09:05:48 +0000

 Module Name:	pkgsrc
 Committed By:	imil
 Date:		Fri Dec 14 09:05:48 UTC 2012

 Modified Files:
 	pkgsrc/pkgtools/pkgin: Makefile distinfo

 Log Message:
         PR3555339@sf (stacktic)
         Avoid negative speed when a download start (stacktic)
         PR47196 fixed by stacktic
         PR47060 fixed by stacktic
         Added show-no-keep by orgrim
         Fixed PR47192 (by stacktic)

 To generate a diff of this commit:
 cvs rdiff -u -r1.29 -r1.30 pkgsrc/pkgtools/pkgin/Makefile
 cvs rdiff -u -r1.24 -r1.25 pkgsrc/pkgtools/pkgin/distinfo

 Please note that diffs are not public domain; they are subject to the
 copyright notices on the relevant files.

State-Changed-From-To: feedback->closed
State-Changed-When: Sat, 01 Jun 2013 22:11:44 +0000
Feedback timeout.


NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD:,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.