NetBSD Problem Report #47496

From www@NetBSD.org  Wed Jan 23 20:37:44 2013
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	by www.NetBSD.org (Postfix) with ESMTP id B18DC63EE07
	for <gnats-bugs@gnats.NetBSD.org>; Wed, 23 Jan 2013 20:37:44 +0000 (UTC)
Message-Id: <20130123203743.9CE9963EE07@www.NetBSD.org>
Date: Wed, 23 Jan 2013 20:37:43 +0000 (UTC)
From: Christoph_Egger@gmx.de
Reply-To: Christoph_Egger@gmx.de
To: gnats-bugs@NetBSD.org
Subject: incomplete yajl binary package install
X-Send-Pr-Version: www-1.0

>Number:         47496
>Category:       pkg
>Synopsis:       incomplete yajl binary package install
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    imil
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 23 20:40:00 +0000 2013
>Last-Modified:  Thu Jan 24 09:00:08 +0000 2013
>Originator:     Christoph Egger
>Release:        NetBSD 6.0.1 amd64
>Organization:
>Environment:
NetBSD 6.0.1 amd64
>Description:
# pkgin pkg-content yajl  
Information for http://ftp.netbsd.org/pub//pkgsrc/packages/NetBSD/amd64/6.0/All/yajl-2.0.1nb1.tgz:
Files:
/usr/pkg/bin/json_reformat
/usr/pkg/bin/json_verify
/usr/pkg/include/yajl/yajl_common.h
/usr/pkg/include/yajl/yajl_gen.h
/usr/pkg/include/yajl/yajl_parse.h
/usr/pkg/include/yajl/yajl_tree.h
/usr/pkg/include/yajl/yajl_version.h
/usr/pkg/lib/libyajl.so
/usr/pkg/lib/libyajl.so.2
/usr/pkg/lib/libyajl.so.2.0.1
/usr/pkg/lib/libyajl_s.a
# pkgin install yajl
calculating dependencies... done.

nothing to upgrade.
1 packages to be installed: yajl-2.0.1nb1 (63K to download, 187K to install)

proceed ? [Y/n] 
downloading packages...
yajl-2.0.1nb1.tgz                                                                                      100%   63KB  63.2KB/s  63.2KB/s   00:00    
installing packages...
installing yajl-2.0.1nb1...
pkg_install warnings: 1, errors: 0
pkg_install error log can be found in /var/db/pkgin/pkg_install-err.log
reading local summary...
processing local summary...
updating database: 100%
marking yajl-2.0.1nb1 as non auto-removable
# pkgin provides yajl
Files provided by yajl-2.0.1nb1:
        /usr/pkg/lib/libyajl.so.2.0.1
        /usr/pkg/lib/libyajl.so.2
        /usr/pkg/lib/libyajl.so

Where are the headers?
Where are the binaries?
Where is the static lib?

>How-To-Repeat:
pkgin pkg-content yajl
pkgin install yajl
pkgin provides yajl

To repeat this do:
pkgin remove yajl
pkgin clean
pkgin pkg-content yajl
pkgin install yajl
pkgin provides yajl


>Fix:

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->imil
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Wed, 23 Jan 2013 21:26:27 +0000
Responsible-Changed-Why:
Over to pkgin maintainer.
Just for the record, what is in /var/db/pkgin/pkg_install-err.log ?


From: Christoph Egger <Christoph_Egger@gmx.de>
To: gnats-bugs@NetBSD.org
Cc: wiz@NetBSD.org, imil@NetBSD.org, pkg-manager@netbsd.org, 
 pkgsrc-bugs@netbsd.org, gnats-admin@netbsd.org
Subject: Re: pkg/47496 (incomplete yajl binary package install)
Date: Thu, 24 Jan 2013 09:56:15 +0100

 On 23.01.13 22:26, wiz@NetBSD.org wrote:
 > Synopsis: incomplete yajl binary package install
 >
 > Responsible-Changed-From-To: pkg-manager->imil
 > Responsible-Changed-By: wiz@NetBSD.org
 > Responsible-Changed-When: Wed, 23 Jan 2013 21:26:27 +0000
 > Responsible-Changed-Why:
 > Over to pkgin maintainer.
 > Just for the record, what is in /var/db/pkgin/pkg_install-err.log ?

 ---Jan 23 20:27:51: installing yajl-2.0.1nb1...
 pkg_add: Warning: package `yajl-2.0.1nb1' was built for a platform:
 pkg_add: NetBSD/x86_64 6.0 (pkg) vs. NetBSD/x86_64 6.0.1 (this host)

 Christoph

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.