NetBSD Problem Report #47533

From dholland@macaran.localdomain  Tue Feb  5 06:25:04 2013
Return-Path: <dholland@macaran.localdomain>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	by www.NetBSD.org (Postfix) with ESMTP id A0AAA63E9CB
	for <gnats-bugs@gnats.NetBSD.org>; Tue,  5 Feb 2013 06:25:04 +0000 (UTC)
Message-Id: <20130205062627.6E3206E23C@macaran.localdomain>
Date: Tue,  5 Feb 2013 01:26:27 -0500 (EST)
From: dholland@eecs.harvard.edu
Reply-To: dholland@eecs.harvard.edu
To: gnats-bugs@gnats.NetBSD.org
Subject: numerous tex packages silently depend on luatex
X-Send-Pr-Version: 3.95

>Number:         47533
>Category:       pkg
>Synopsis:       numerous tex packages silently depend on luatex
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    minskim
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 05 06:30:00 +0000 2013
>Last-Modified:  Tue Feb 05 09:05:02 +0000 2013
>Originator:     David A. Holland
>Release:        NetBSD 6.99.11, pkgsrc 20130201
>Organization:
>Environment:
System: NetBSD macaran 6.99.11 NetBSD 6.99.11 (MACARAN) #15: Mon Oct 15 21:24:31 EDT 2012 dholland@macaran:/usr/src/sys/arch/amd64/compile/MACARAN amd64
Architecture: x86_64
Machine: amd64
>Description:

A number of tex packages (not sure exactly which ones) require luatex
and spew errors on removal (and at least in some cases on rebuild,
too) if luatex is not present, but pkgsrc is not aware of this
dependency.

>How-To-Repeat:

 - make update in print/poppler
 - stop it after everything's been removed but before it starts
   rebuilding tex packages
 - now make update in print/tex-tetex
 - watch the errors roll by (they do not cause uninstall or build to
   stop, but I'm not convinced they're harmless)

A number of the tex-hyphen-* packages are among those affected.

>Fix:

Dunno. From the behavior I'm guessing that there's some infrastructure-
level dependence in tex and/or texlive that causes this, so that it'll
be relatively easy to add it to pkgsrc so it appears in all the right
places. Otherwise it'll probably be a pain.

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->minskim
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Tue, 05 Feb 2013 07:50:55 +0000
Responsible-Changed-Why:
Over to tex maintainer.


From: David Holland <dholland@eecs.harvard.edu>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/47533: numerous tex packages silently depend on luatex
Date: Tue, 5 Feb 2013 03:00:13 -0500

 On Tue, Feb 05, 2013 at 06:30:01AM +0000, gnats-admin@netbsd.org wrote:
  > >Synopsis:       numerous tex packages silently depend on luatex

 At least some of them also need tex-pdftex (or maybe only
 tex-pdftex-def, I didn't try very hard) and tex-latex, or the luatex
 runs fail.

 -- 
    - David A. Holland / dholland@eecs.harvard.edu

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.