NetBSD Problem Report #47727

From makoto@mx.ki.nu  Mon Apr  8 00:44:43 2013
Return-Path: <makoto@mx.ki.nu>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	by www.NetBSD.org (Postfix) with ESMTP id 10D6463F2E5
	for <gnats-bugs@gnats.NetBSD.org>; Mon,  8 Apr 2013 00:44:42 +0000 (UTC)
Message-Id: <201304080044.r380idH5021661@mx.ki.nu>
Date: Mon, 8 Apr 2013 09:44:39 +0900 (JST)
From: makoto@ki.nu
Reply-To: makoto@ki.nu
To: gnats-bugs@gnats.NetBSD.org
Subject: (libXext) Requested 'xextproto >= 7.1.99' but XExtProto is 7.0.5
X-Send-Pr-Version: 3.95

>Number:         47727
>Category:       pkg
>Synopsis:       Requested 'xextproto >= 7.1.99' but XExtProto is 7.0.5
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Apr 08 00:45:00 +0000 2013
>Last-Modified:  Mon Apr 08 01:25:05 +0000 2013
>Originator:     Makoto Fujiwara
>Release:        NetBSD 5.2
>Organization:
KINU Corporation
>Environment:


System: NetBSD pinapa.z.ki.nu 5.2 NetBSD 5.2 (XEN3PAE_DOMU) #0: Wed Nov 28 09:34:42 UTC 2012 builds@b8.netbsd.org:/home/builds/ab/netbsd-5-2-RELEASE/i386/201211280503Z-obj/home/builds/ab/netbsd-5-2-RELEASE/src/sys/arch/i386/compile/XEN3PAE_DOMU i386
Architecture: i386
Machine: i386
>Description:
	Native X11 for NetBSD 5.2 is little bit outdated.
	To package x11/libXext, we need pkgsrc version of x11/xextproto.
	The problem looks:
checking for XEXT... configure: error: Package requirements 
  (xproto >= 7.0.13 x11 >= 1.1.99.1 xextproto >= 7.1.99) were not met:

Requested 'xextproto >= 7.1.99' but version of XExtProto is 7.0.5

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XEXT_CFLAGS
and XEXT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
*** Error code 1
Stop.
make: stopped in /usr/pkgsrc/x11/libXext

>How-To-Repeat:
	set X11_TYPE=native or unset X11_TYPE in /etc/mk.conf
	Have NetBSD/i386 5.2 installed with X11
	Have pkgsrc updated
	cd /usr/pkgsrc/x11/libXext
	make package
>Fix:
Index: x11/libXext/Makefile
===================================================================
RCS file: /cvs/cvsroot/pkgsrc/x11/libXext/Makefile,v
retrieving revision 1.16
diff -u -r1.16 Makefile
--- x11/libXext/Makefile	29 Oct 2012 05:06:34 -0000	1.16
+++ x11/libXext/Makefile	8 Apr 2013 00:31:48 -0000
@@ -37,7 +37,10 @@

 BUILDLINK_API_DEPENDS.libX11+=	libX11>=1.2
 .include "../../x11/libX11/buildlink3.mk"
-BUILDLINK_API_DEPENDS.xextproto+=	xextproto>=7.0.99.2
+BUILDLINK_API_DEPENDS.xextproto+=	xextproto>=7.1.99
+# .if ${X11_TYPE} != "modular"
+PREFER_PKGSRC+=	xextproto
+# .endif
 .include "../../x11/xextproto/buildlink3.mk"
 BUILDLINK_API_DEPENDS.xproto+=		xproto>=7.0.13
 .include "../../x11/xproto/buildlink3.mk"

>Audit-Trail:
From: "OBATA Akio" <obache@netbsd.org>
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/47727: (libXext) Requested 'xextproto >= 7.1.99' but
 XExtProto is 7.0.5
Date: Mon, 08 Apr 2013 10:24:24 +0900

 On Mon, 08 Apr 2013 09:45:01 +0900, <makoto@ki.nu> wrote:

 > -BUILDLINK_API_DEPENDS.xextproto+=	xextproto>=7.0.99.2
 > +BUILDLINK_API_DEPENDS.xextproto+=	xextproto>=7.1.99
 > +# .if ${X11_TYPE} != "modular"
 > +PREFER_PKGSRC+=	xextproto
 > +# .endif

 We should find bunch of such missing bump of API_DEPENDS,
 and update PREFER_PKGSRC patterns in mk/defaults/mk.conf.

 -- 
 OBATA Akio / obache@NetBSD.org

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.