NetBSD Problem Report #47876

From www@NetBSD.org  Sat Jun  1 20:04:36 2013
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 9935170D4D
	for <gnats-bugs@gnats.NetBSD.org>; Sat,  1 Jun 2013 20:04:36 +0000 (UTC)
Message-Id: <20130601200435.4651571763@mollari.NetBSD.org>
Date: Sat,  1 Jun 2013 20:04:35 +0000 (UTC)
From: jan.m.danielsson@gmail.com
Reply-To: jan.m.danielsson@gmail.com
To: gnats-bugs@NetBSD.org
Subject: devel/doxygen won't build on Mac OS X because compiler doesn't understand "-Wno-invalid-source-encoding"
X-Send-Pr-Version: www-1.0

>Number:         47876
>Category:       pkg
>Synopsis:       devel/doxygen won't build on Mac OS X because compiler doesn't understand "-Wno-invalid-source-encoding"
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jun 01 20:05:00 +0000 2013
>Last-Modified:  Sat Jun 01 22:15:00 +0000 2013
>Originator:     Jan Danielsson
>Release:        N/A
>Organization:
La Cosa Nostra
>Environment:
Darwin farrah.local 12.3.0 Darwin Kernel Version 12.3.0: Sun Jan  6 22:37:10 PST 2013; root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
>Description:
Building fails with:

[---]
===> Building for doxygen-1.8.4nb1
echo "char versionString[]=\"1.8.4\";" > src/version.cpp
/usr/bin/gnumake -C qtools
env TMAKEPATH="/Users/jan/pkgsrc/devel/doxygen/work/doxygen-1.8.4/tmake/lib/macosx-c++" /Users/jan/pkg/bin/perl "/Users/jan/pkgsrc/devel/doxygen/work/doxygen-1.8.4/tmake/bin/tmake" qtools.pro >Makefile.qtools
/usr/bin/gnumake -f Makefile.qtools    all
c++ -c -pipe -D__FreeBSD__=6 -DYY_TYPEDEF_YY_SIZE_T -Dyy_size_t=int -DQT_LITE_UNICODE -Wall -W -Wno-deprecated-declarations -Wno-invalid-source-encoding -O2 -I. -o ../objects/qbuffer.o qbuffer.cpp
cc1plus: error: unrecognized command line option "-Wno-invalid-source-encoding"
gnumake[2]: *** [../objects/qbuffer.o] Error 1
gnumake[1]: *** [all] Error 2
gnumake: *** [all] Error 2
*** Error code 2


I assume the issue is that clang doesn't support -Wno-invalid-source-encoding.
>How-To-Repeat:
Build devel/doxygen on a Mac OS X-system.
>Fix:
Remove the option for clang builds may work. Have no idea how to accomplish that.

>Audit-Trail:
From: Joerg Sonnenberger <joerg@britannica.bec.de>
To: gnats-bugs@NetBSD.org
Cc: pkg-manager@netbsd.org, gnats-admin@netbsd.org, pkgsrc-bugs@netbsd.org
Subject: Re: pkg/47876: devel/doxygen won't build on Mac OS X because
 compiler doesn't understand "-Wno-invalid-source-encoding"
Date: Sun, 2 Jun 2013 00:10:52 +0200

 On Sat, Jun 01, 2013 at 08:05:00PM +0000, jan.m.danielsson@gmail.com wrote:
 > >Number:         47876
 > >Category:       pkg
 > >Synopsis:       devel/doxygen won't build on Mac OS X because compiler doesn't understand "-Wno-invalid-source-encoding"
 > >Confidential:   no
 > >Severity:       serious
 > >Priority:       low
 > >Responsible:    pkg-manager
 > >State:          open
 > >Class:          sw-bug
 > >Submitter-Id:   net
 > >Arrival-Date:   Sat Jun 01 20:05:00 +0000 2013
 > >Originator:     Jan Danielsson
 > >Release:        N/A
 > >Organization:
 > La Cosa Nostra
 > >Environment:
 > Darwin farrah.local 12.3.0 Darwin Kernel Version 12.3.0: Sun Jan  6 22:37:10 PST 2013; root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
 > >Description:
 > Building fails with:
 > 
 > [---]
 > ===> Building for doxygen-1.8.4nb1
 > echo "char versionString[]=\"1.8.4\";" > src/version.cpp
 > /usr/bin/gnumake -C qtools
 > env TMAKEPATH="/Users/jan/pkgsrc/devel/doxygen/work/doxygen-1.8.4/tmake/lib/macosx-c++" /Users/jan/pkg/bin/perl "/Users/jan/pkgsrc/devel/doxygen/work/doxygen-1.8.4/tmake/bin/tmake" qtools.pro >Makefile.qtools
 > /usr/bin/gnumake -f Makefile.qtools    all
 > c++ -c -pipe -D__FreeBSD__=6 -DYY_TYPEDEF_YY_SIZE_T -Dyy_size_t=int -DQT_LITE_UNICODE -Wall -W -Wno-deprecated-declarations -Wno-invalid-source-encoding -O2 -I. -o ../objects/qbuffer.o qbuffer.cpp
 > cc1plus: error: unrecognized command line option "-Wno-invalid-source-encoding"
 > gnumake[2]: *** [../objects/qbuffer.o] Error 1
 > gnumake[1]: *** [all] Error 2
 > gnumake: *** [all] Error 2
 > *** Error code 2
 > 
 > 
 > I assume the issue is that clang doesn't support -Wno-invalid-source-encoding.

 cc1plus is GCC.

 Joerg

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.