NetBSD Problem Report #48737

From kivinen@tiiliskivi.i.kivinen.iki.fi  Sat Apr 12 10:00:55 2014
Return-Path: <kivinen@tiiliskivi.i.kivinen.iki.fi>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 5382BA5802
	for <gnats-bugs@gnats.NetBSD.org>; Sat, 12 Apr 2014 10:00:55 +0000 (UTC)
Message-Id: <20140412095931.94EEE1E370B@tiiliskivi.i.kivinen.iki.fi>
Date: Sat, 12 Apr 2014 12:59:31 +0300 (EEST)
From: kivinen@iki.fi
Reply-To: kivinen@iki.fi
To: gnats-bugs@gnats.NetBSD.org
Subject: libreoffice4 does not compile of postgresql{84,93}-client is installed
X-Send-Pr-Version: 3.95

>Number:         48737
>Category:       pkg
>Synopsis:       libreoffice4 does not compile of postgresql{84,93}-client is installed
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    ryoon
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Apr 12 10:05:00 +0000 2014
>Last-Modified:  Sat Apr 12 10:09:30 +0000 2014
>Originator:     Tero Kivinen
>Release:        NetBSD 6.1_STABLE
>Organization:
>Environment:
System: NetBSD tiiliskivi.i.kivinen.iki.fi 6.1_STABLE NetBSD 6.1_STABLE (TIILISKIVI) #0: Fri Apr 11 00:46:33 EEST 2014 root@tiiliskivi.i.kivinen.iki.fi:/usr/obj/sys/arch/amd64/compile/TIILISKIVI amd64
Architecture: x86_64
Machine: amd64
>Description:

	If you have postgresql84-client installed and you try to
	install misc/libreoffice4 the configure phase of the
	libreoffice4 fails because the configure checks and notices
	that -lpq needs to have version >= 9.0:

----------------------------------------------------------------------
...
checking PostgreSQL C interface... external PostgreSQL
checking for pg_config... /usr/pkgsrc/misc/libreoffice4/work/.buildlink/bin/pg_config
configure: checking system PostgreSQL prerequisites
checking libpq-fe.h usability... yes
checking libpq-fe.h presence... yes
checking for libpq-fe.h... yes
checking for PQconnectdbParams in -lpq... no
configure: error: libpq not found or too old. Need >= 9.0
Error running configure at ./autogen.sh line 209.
*** Error code 25

Stop.
----------------------------------------------------------------------

	postgresql93-client does not work either, as it fails to find
	libpq-fe.h:

----------------------------------------------------------------------
...
checking PostgreSQL C interface... external PostgreSQL
checking for pg_config... /usr/pkgsrc/misc/libreoffice4/work/.buildlink/bin/pg_config
configure: checking system PostgreSQL prerequisites
checking libpq-fe.h usability... no
checking libpq-fe.h presence... no
checking for libpq-fe.h... no
configure: error: libpq-fe.h is needed
Error running configure at ./autogen.sh line 209.
*** Error code 25

Stop.
----------------------------------------------------------------------

	The postgresql93-client do install the libpq-fe.h in the
	/usr/pkg/include and the pg_config properly says
	/usr/pkg/include in INCLUDEDIR, but the libreoffice4 does not
	find it because it fails to include pg_config_ext.h for some
	reason:

----------------------------------------------------------------------
...
configure:24141: checking libpq-fe.h usability
configure:24141: gcc -c -O2 -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/db4 -DLDAP_DEPRECATED -I/usr/pkg/include/cppunit -I/usr/pkg/include/nss/nss -I/usr/pkg/include/nspr -I/usr/pkg/include/freetype2 -I/usr/pkg/include/libdrm -I/usr/pkg/include/python3.3 -I/usr/include/krb5 -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/db4 -DLDAP_DEPRECATED -I/usr/pkg/include/cppunit -I/usr/pkg/include/nss/nss -I/usr/pkg/include/nspr -I/usr/pkg/include/freetype2 -I/usr/pkg/include/libdrm -I/usr/pkg/include/python3.3 -I/usr/include/krb5 -I/usr/pkg/include conftest.c >&5
In file included from /usr/pkgsrc/misc/libreoffice4/work/.buildlink/include/libpq-fe.h:29:0,
                 from conftest.c:114:
/usr/pkgsrc/misc/libreoffice4/work/.buildlink/include/postgres_ext.h:26:27: fatal error: pg_config_ext.h: No such file or directory
compilation terminated.
configure:24141: $? = 1
...
----------------------------------------------------------------------

>How-To-Repeat:

	Install postgresql84-client or postgresql93-client and then
	try to install libreoffice4.

>Fix:

	Simply install postgress91-client instead of
	postgress84-client before installing libreoffice4.

	Correct fix would be to make libreoffice4 to require postgress
	>= 9.0 in the misc/libreoffice4/Makefile. It currently accepts
	any postgress by including mk/pgsql.buildlink3.mk, but should
	require versions > 9.0. There seems to be problems if using
	postgress93-client too, so it may be that the
	postgress91-client (default) is only one that works. If no
	postgress*-client is installed before installing libreoffice4
	then the postgress91-client is the default and that at least
	goes through the configure phase (it is still compiling so not
	sure yet whether it will work :-)

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->ryoon
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Sat, 12 Apr 2014 10:09:30 +0000
Responsible-Changed-Why:
Over to maintainer.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.