NetBSD Problem Report #48839

From www@NetBSD.org  Wed May 28 02:18:23 2014
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 31014A5813
	for <gnats-bugs@gnats.NetBSD.org>; Wed, 28 May 2014 02:18:23 +0000 (UTC)
Message-Id: <20140528021821.A99DEA651D@mollari.NetBSD.org>
Date: Wed, 28 May 2014 02:18:21 +0000 (UTC)
From: manphiz@gmail.com
Reply-To: manphiz@gmail.com
To: gnats-bugs@NetBSD.org
Subject: gcc48 fails to build
X-Send-Pr-Version: www-1.0

>Number:         48839
>Category:       pkg
>Synopsis:       gcc48 fails to build
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    ryoon
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed May 28 02:20:00 +0000 2014
>Last-Modified:  Sat May 31 13:25:00 +0000 2014
>Originator:     Xiyue Deng
>Release:        pkgsrc-current
>Organization:
>Environment:
$ uname -a
Darwin Xiyues-MBP.local 13.2.0 Darwin Kernel Version 13.2.0: Thu Apr 17 23:03:13 PDT 2014; root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64
>Description:
lang/gcc48 fails to bmake due to missing perl in USE_TOOLS. Detailed log:

[..snip..]
rm -f libstdc++-symbols.ver.tmp                                                                                                                                
libtool: compile:  /Users/dxy/pkgsrc/lang/gcc48/work/build/./gcc/xgcc -shared-libgcc -B/Users/dxy/pkgsrc/lang/gcc48/work/build/./gcc -nostdinc++ -L/Users/dxy/pkgsrc/lang/gcc48/work/build/x86_64-apple-darwin13/libstdc++-v3/src -L/Users/dxy/pkgsrc/lang/gcc48/work/build/x86_64-apple-darwin13/libstdc++-v3/src/.libs -B/Users/dxy/pkg/gcc48/x86_64-apple-darwin13/bin/ -B/Users/dxy/pkg/gcc48/x86_64-apple-darwin13/lib/ -isystem /Users/dxy/pkg/gcc48/x86_64-apple-darwin13/include -isystem /Users/dxy/pkg/gcc48/x86_64-apple-darwin13/sys-include -I/Users/dxy/pkgsrc/lang/gcc48/work/build/x86_64-apple-darwin13/libstdc++-v3/include/x86_64-apple-darwin13 -I/Users/dxy/pkgsrc/lang/gcc48/work/build/x86_64-apple-darwin13/libstdc++-v3/include -I/Users/dxy/pkgsrc/lang/gcc48/work/gcc-4.8.2/libstdc++-v3/libsupc++ -I/Users/dxy/pkg/include -fno-common -DPIC -Wall -Wextra -Wwrite-strings -Wcast-qual -Wabi -fdiagnostics-show-location=once -fvisibility-inlines-hidden -ffunction-sections -fdata-sections -fra
 ndom-seed=compatibility-thread-c++0x.lo -g -pipe -O2 -I/Users/dxy/pkg/include -I/usr/include -std=gnu++11 -c ../../../../gcc-4.8.2/libstdc++-v3/src/c++11/compatibility-thread-c++0x.cc -o compatibility-thread-c++0x.o >/dev/null 2>&1                                                   
perl /Users/dxy/pkgsrc/lang/gcc48/work/gcc-4.8.2/libstdc++-v3/scripts/make_exports.pl \                                                                        
          libstdc++-symbols.ver \                                                                                                                              
          .libs/compatibility.o .libs/compatibility-debug_list.o .libs/compatibility-debug_list-2.o .libs/compatibility-c++0x.o .libs/compatibility-atomic-c++0x.o .libs/compatibility-thread-c++0x.o .libs/compatibility-chrono.o \                                                                                          
         `echo  ../libsupc++/libsupc++convenience.la ../src/c++98/libc++98convenience.la ../src/c++11/libc++11convenience.la | \                               
            sed 's,/\([^/.]*\)\.la,/.libs/\1.a,g'` \                                                                                                           
         > libstdc++-symbols.explist || (rm -f libstdc++-symbols.explist ; exit 1)                                                                             
ERROR: To use this tool, add USE_TOOLS+=perl to the package Makefile.                                                                                          
gnumake[6]: *** [libstdc++-symbols.explist] Error 1                                                                                                            
gnumake[5]: *** [all-recursive] Error 1                                                                                                                        
gnumake[4]: *** [all-recursive] Error 1                                                                                                                        
gnumake[3]: *** [all] Error 2                                                                                                                                  
gnumake[2]: *** [all-stage1-target-libstdc++-v3] Error 2                                                                                                       
gnumake[1]: *** [stage1-bubble] Error 2                                                                                                                        
gnumake: *** [all] Error 2                                                                                                                                     
*** Error code 2                                                                                                                                               

Stop.                                                                                                                                                          
bmake: stopped in /Users/dxy/pkgsrc/lang/gcc48                                                                                                                 
WARNING: Please add USE_TOOLS+=perl to the package Makefile.                                                                                                   
WARNING: Please add USE_TOOLS+=perl to the package Makefile.                                                                                                   
*** Error code 1                                                                                                                                               

Stop.                                                                                                                                                          
bmake: stopped in /Users/dxy/pkgsrc/lang/gcc48
>How-To-Repeat:
cd $HOME/pkgsrc/lang/gcc48 && bmake
>Fix:
It seems "USE_TOOLS+= perl" does exist in lang/gcc48/c++.mk but the main Makefile doesn't include it.

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->ryoon
Responsible-Changed-By: ryoon@NetBSD.org
Responsible-Changed-When: Wed, 28 May 2014 13:33:19 +0000
Responsible-Changed-Why:
I am working on gcc 4.8.3 now. This will be fixed.


From: Xiyue Deng <manphiz@gmail.com>
To: gnats-bugs@netbsd.org
Cc: ryoon@netbsd.org, pkg-manager@netbsd.org, pkgsrc-bugs@netbsd.org, 
	gnats-admin@netbsd.org
Subject: Re: pkg/48839 (gcc48 fails to build)
Date: Wed, 28 May 2014 12:41:51 -0700

 On Wed, May 28, 2014 at 6:33 AM,  <ryoon@netbsd.org> wrote:
 > Synopsis: gcc48 fails to build
 >
 > Responsible-Changed-From-To: pkg-manager->ryoon
 > Responsible-Changed-By: ryoon@NetBSD.org
 > Responsible-Changed-When: Wed, 28 May 2014 13:33:19 +0000
 > Responsible-Changed-Why:
 > I am working on gcc 4.8.3 now. This will be fixed.
 >
 >
 >

 Sounds great! Thanks for your work.

From: Ryo ONODERA <ryo_on@yk.rim.or.jp>
To: manphiz@gmail.com, gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/48839: gcc48 fails to build
Date: Thu, 29 May 2014 23:22:40 +0900 (JST)

 Hi,

 >>How-To-Repeat:
 > cd $HOME/pkgsrc/lang/gcc48 && bmake
 >>Fix:
 > It seems "USE_TOOLS+= perl" does exist in lang/gcc48/c++.mk but the main Makefile doesn't include it.

 I will convert lang/gcc48 to simple meta-pkg.
 How about the status of lang/gcc48-{libs,cc++,fortran,objc}
 under your platform?

 --
 Ryo ONODERA // ryo_on@yk.rim.or.jp
 PGP fingerprint = 82A2 DC91 76E0 A10A 8ABB  FD1B F404 27FA C7D1 15F3

From: Xiyue Deng <manphiz@gmail.com>
To: Ryo ONODERA <ryo_on@yk.rim.or.jp>
Cc: gnats-bugs@netbsd.org
Subject: Re: pkg/48839: gcc48 fails to build
Date: Thu, 29 May 2014 13:55:24 -0700

 Hi,

 On Thu, May 29, 2014 at 7:22 AM, Ryo ONODERA <ryo_on@yk.rim.or.jp> wrote:
 > Hi,
 >
 >>>How-To-Repeat:
 >> cd $HOME/pkgsrc/lang/gcc48 && bmake
 >>>Fix:
 >> It seems "USE_TOOLS+= perl" does exist in lang/gcc48/c++.mk but the main Makefile doesn't include it.
 >
 > I will convert lang/gcc48 to simple meta-pkg.

 Sounds good.

 > How about the status of lang/gcc48-{libs,cc++,fortran,objc}
 > under your platform?
 >

 I think there is also a problem with enabling gcc-graphite: currently
 math/isl is at version 0.13, which is not supported by gcc 4.8 and
 older versions (haven't checked gcc49 yet). So even with proper flags
 the graphite support will not be enabled. To make the situation even
 worth, cloog is required to be compiled with dedicated version of isl
 to provide proper support for gcc.

 gcc48snapshot from pkgsrc-wip uses in tree source for cloog and isl,
 and pulls the proper versions of them to enable graphite support. See
 this commit[1]. This looks like a proper solution and should be
 applied to gcc47 and gcc46 as well.

 [1] http://pkgsrc-wip.cvs.sourceforge.net/viewvc/pkgsrc-wip/wip/gcc48snapshot/options.mk?r1=1.2&r2=1.3

 > --
 > Ryo ONODERA // ryo_on@yk.rim.or.jp
 > PGP fingerprint = 82A2 DC91 76E0 A10A 8ABB  FD1B F404 27FA C7D1 15F3

From: Ryo ONODERA <ryo_on@yk.rim.or.jp>
To: manphiz@gmail.com
Cc: gnats-bugs@netbsd.org
Subject: Re: pkg/48839: gcc48 fails to build
Date: Sat, 31 May 2014 22:25:02 +0900 (JST)

 From: Xiyue Deng <manphiz@gmail.com>, Date: Thu, 29 May 2014 13:55:24 -0700

 > Hi,
 > 
 > On Thu, May 29, 2014 at 7:22 AM, Ryo ONODERA <ryo_on@yk.rim.or.jp> wrote:
 >> Hi,
 >>
 >>>>How-To-Repeat:
 >>> cd $HOME/pkgsrc/lang/gcc48 && bmake
 >>>>Fix:
 >>> It seems "USE_TOOLS+= perl" does exist in lang/gcc48/c++.mk but the main Makefile doesn't include it.
 >>
 >> I will convert lang/gcc48 to simple meta-pkg.
 > 
 > Sounds good.
 > 
 >> How about the status of lang/gcc48-{libs,cc++,fortran,objc}
 >> under your platform?
 >>
 > 
 > I think there is also a problem with enabling gcc-graphite: currently
 > math/isl is at version 0.13, which is not supported by gcc 4.8 and
 > older versions (haven't checked gcc49 yet). So even with proper flags
 > the graphite support will not be enabled. To make the situation even
 > worth, cloog is required to be compiled with dedicated version of isl
 > to provide proper support for gcc.
 > 
 > gcc48snapshot from pkgsrc-wip uses in tree source for cloog and isl,
 > and pulls the proper versions of them to enable graphite support. See
 > this commit[1]. This looks like a proper solution and should be
 > applied to gcc47 and gcc46 as well.
 > 
 > [1] http://pkgsrc-wip.cvs.sourceforge.net/viewvc/pkgsrc-wip/wip/gcc48snapshot/options.mk?r1=1.2&r2=1.3

 lang/gcc48* are update to 4.8.3.
 It seems that graphite option is enabled.

 I will try to package under non-NetBSD/OpenBSD later.

 --
 Ryo ONODERA // ryo_on@yk.rim.or.jp
 PGP fingerprint = 82A2 DC91 76E0 A10A 8ABB  FD1B F404 27FA C7D1 15F3

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.