NetBSD Problem Report #48889

From hauke@Espresso.Rhein-Neckar.DE  Mon Jun  9 21:33:34 2014
Return-Path: <hauke@Espresso.Rhein-Neckar.DE>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	by mollari.NetBSD.org (Postfix) with ESMTP id 1FC86A6531
	for <gnats-bugs@gnats.NetBSD.org>; Mon,  9 Jun 2014 21:33:34 +0000 (UTC)
Message-Id: <201406092115.s59LFJlB010061@pizza.causeuse.org>
Date: Mon, 9 Jun 2014 23:15:19 +0200 (CEST)
From: Hauke Fath <hauke@Espresso.Rhein-Neckar.DE>
Reply-To: Hauke Fath <hauke@Espresso.Rhein-Neckar.DE>
To: gnats-bugs@gnats.NetBSD.org
Cc: Hauke Fath <hauke@Espresso.Rhein-Neckar.DE>
Subject: Netatalk 2.2.5 incompatible with cups 1.7.x
X-Send-Pr-Version: 3.95

>Number:         48889
>Category:       pkg
>Synopsis:       Netatalk 2.2.5 incompatible with cups 1.7.x
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    markd
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jun 09 21:35:00 +0000 2014
>Last-Modified:  Wed Jun 11 11:25:00 +0000 2014
>Originator:     Hauke Fath
>Release:        NetBSD 6.1_STABLE
>Organization:
Falling Raindrops
>Environment:


System: NetBSD pizza.causeuse.org 6.1_STABLE NetBSD 6.1_STABLE (BLACKBOX-$Revision: 1.85 $) #0: Sat May 3 21:06:28 CEST 2014 hauke@pizza.causeuse.org:/var/obj/netbsd-builds/6/amd64/sys/arch/amd64/compile/BLACKBOX amd64
Architecture: x86_64
Machine: amd64
>Description:

	The print/cups upgrade to 1.7.x has broken net/netatalk (which
	is at v2.2.5).


>How-To-Repeat:

	Build net/netatalk with option cups:

[...]
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../..   -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/db4 -I../../include -I../../sys -I/usr/pkg/include -D_PATH_PAPDCONF=\"/etc/pkg/netatalk/papd.conf\" -D_PATH_PAPDUAMPATH=\"/usr/pkg/libexec/netatalk/uams/\" -DSPOOLDIR=\"/var/netatalk/spool/netatalk/\" -I../../sys/netbsd -I../../include -D_U_="__attribute__((unused))" -O2 -pipe -Wall -Wno-error -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/db4 -I../../sys -MT print_cups.o -MD -MP -MF .deps/print_cups.Tpo -c -o print_cups.o print_cups.c
print_cups.c: In function 'cups_printername_ok':
print_cups.c:135:16: error: dereferencing pointer to incomplete type
print_cups.c:136:16: error: dereferencing pointer to incomplete type
print_cups.c:168:21: error: dereferencing pointer to incomplete type
print_cups.c:170:9: error: dereferencing pointer to incomplete type
print_cups.c: In function 'cups_get_printer_status':
print_cups.c:247:16: error: dereferencing pointer to incomplete type
print_cups.c:248:16: error: dereferencing pointer to incomplete type
print_cups.c:278:21: error: dereferencing pointer to incomplete type
print_cups.c:280:9: error: dereferencing pointer to incomplete type
print_cups.c:295:25: error: dereferencing pointer to incomplete type
print_cups.c:297:30: error: dereferencing pointer to incomplete type
print_cups.c:305:12: error: dereferencing pointer to incomplete type
print_cups.c:312:31: error: dereferencing pointer to incomplete type
print_cups.c: In function 'cups_mangle_printer_name':
print_cups.c:478:3: warning: format '%2.2u' expects type 'unsigned int', but argument 4 has type 'size_t'
print_cups.c:478:3: warning: format '%2.2u' expects type 'unsigned int', but argument 4 has type 'size_t'
Makefile:507: recipe for target 'print_cups.o' failed
gmake[3]: *** [print_cups.o] Error 1
gmake[3]: Leaving directory '/var/obj/pkgsrc/net/netatalk/work/netatalk-2.2.5/etc/papd'
Makefile:374: recipe for target 'all-recursive' failed
gmake[2]: *** [all-recursive] Error 1


>Fix:
	Adapt the interface, I guess.

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->markd
Responsible-Changed-By: obache@NetBSD.org
Responsible-Changed-When: Tue, 10 Jun 2014 12:10:28 +0000
Responsible-Changed-Why:
Over to maintainer.


From: Hauke Fath <hf@spg.tu-darmstadt.de>
To: gnats-bugs@NetBSD.org
Cc: pkg-manager@NetBSD.org, gnats-admin@NetBSD.org
Subject: Re: pkg/48889: Netatalk 2.2.5 incompatible with cups 1.7.x
Date: Wed, 11 Jun 2014 13:18:15 +0200

 On Mon,  9 Jun 2014 21:35:00 +0000 (UTC), Hauke Fath wrote:
 >> Synopsis:       Netatalk 2.2.5 incompatible with cups 1.7.x

 Please note net/netatalk has been renamed to net/netatalk22.

 hauke

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.