NetBSD Problem Report #48975

From he@smistad.uninett.no  Tue Jul  8 08:13:25 2014
Return-Path: <he@smistad.uninett.no>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 15E7AA654A
	for <gnats-bugs@gnats.NetBSD.org>; Tue,  8 Jul 2014 08:13:25 +0000 (UTC)
Message-Id: <20140708081320.5D4D93D0B5@smistad.uninett.no>
Date: Tue,  8 Jul 2014 10:13:20 +0200 (CEST)
From: he@uninett.no
Reply-To: he@uninett.no
To: gnats-bugs@gnats.NetBSD.org
Subject: pkgin un-necessarily complains about conflicting packages
X-Send-Pr-Version: 3.95

>Number:         48975
>Category:       pkg
>Synopsis:       pkgin un-necessarily complains about conflicting packages
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    imil
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jul 08 08:15:00 +0000 2014
>Last-Modified:  Thu Jul 10 15:18:26 +0000 2014
>Originator:     Havard Eidnes
>Release:        NetBSD 6.1.4
>Organization:
	UNINETT AS
>Environment:
System: NetBSD floke.uninett.no 6.1.4_PATCH NetBSD 6.1.4_PATCH (GENERIC) #1: Sun Jun 29 13:59:55 CEST 2014  he@floke.uninett.no:/usr/obj/sys/arch/i386/compile/GENERIC i386
Architecture: i386
Machine: i386
>Description:
	Trying to update the pkg installation on one of my machines
	using "pkgin" gives me this warning:

floke# pkgin fug
calculating dependencies... done.
postgresql93-client-9.3.4 (to be installed) conflicts with installed package postgresql93-client-9.3.3.
proceed ? [y/N] 

	This is the same base package name, so why can't just pkgin
	put it on the list of packages which needs to be updated,
	instead of complaining that it conflicts?

	This is with

floke# pkgin -v
pkgin 0.6.4 for NetBSD-6.0 i386 (using SQLite 3.7.10)
floke# 

       in the pkgin-0.6.4nb3 version.

>How-To-Repeat:
	Don't exactly know.  I have taken a copy of my /var/db/pkg,
	though.
>Fix:
	Sorry, don't know.

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->imil
Responsible-Changed-By: ryoon@NetBSD.org
Responsible-Changed-When: Thu, 10 Jul 2014 15:18:26 +0000
Responsible-Changed-Why:
Over to pkgin maintainer


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.