NetBSD Problem Report #49199

From oster@cs.usask.ca  Fri Sep 12 15:28:44 2014
Return-Path: <oster@cs.usask.ca>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id BC3FDCD6FA
	for <gnats-bugs@gnats.NetBSD.org>; Fri, 12 Sep 2014 15:28:44 +0000 (UTC)
Message-Id: <20140912152829.D554D87D50@mickey.usask.ca>
Date: Fri, 12 Sep 2014 09:28:29 -0600 (CST)
From: oster@netbsd.org
Reply-To: oster@netbsd.org
To: gnats-bugs@gnats.NetBSD.org
Subject: boost errors - net/libcmis fails to build on NetBSD-6.1.4_PATCH/amd64
X-Send-Pr-Version: 3.95

>Number:         49199
>Category:       pkg
>Synopsis:       boost errors - net/libcmis fails to build on NetBSD-6.1.4_PATCH/amd64
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Sep 12 15:30:00 +0000 2014
>Last-Modified:  Wed Nov 26 20:05:01 +0000 2014
>Originator:     Greg Oster
>Release:        NetBSD 6.1.4_PATCH
>Organization:
>Environment:


System: NetBSD mickey 6.1.4_PATCH NetBSD 6.1.4_PATCH (QUAD) #0: Wed Aug 27 11:31:05 CST 2014 oster@quad:/u1/builds/build251/src/obj/amd64/u1/builds/build251/src/sys/arch/amd64/compile/QUAD amd64
Architecture: x86_64
Machine: amd64
>Description:

net/libcmis fails to build on NetBSD-6.1.4_PATCH/amd64 with the
following errors related to boost: 


checking for ld used by c++... /usr/pkgsrc/net/libcmis/work.mickey/.wrapper/bin/ld
checking if the linker (/usr/pkgsrc/net/libcmis/work.mickey/.wrapper/bin/ld) is GNU ld... yes
checking whether the c++ linker (/usr/pkgsrc/net/libcmis/work.mickey/.wrapper/bin/ld) supports shared libraries... yes
checking for c++ option to produce PIC... -fPIC -DPIC
checking if c++ PIC flag -fPIC -DPIC works... yes
checking if c++ static flag -static works... yes
checking if c++ supports -c -o file.o... rm: conftest*: No such file or directory
yes
checking if c++ supports -c -o file.o... (cached) yes
checking whether the c++ linker (/usr/pkgsrc/net/libcmis/work.mickey/.wrapper/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... NetBSD ld.elf_so
checking how to hardcode library paths into programs... immediate
checking for native Win32... no
checking for cppcheck... no
checking pkg-config is at least version 0.9.0... yes
checking for CURL... yes
checking for XML2... yes
checking for CPPUNIT... yes
checking for Boost headers version >= 0... yes
checking for Boost's header version... 1_56
checking for the toolset name used by Boost for c++... configure: WARNING: could not figure out which toolset name to use for c++

checking boost/date_time/posix_time/posix_time.hpp usability... yes
checking boost/date_time/posix_time/posix_time.hpp presence... yes
checking for boost/date_time/posix_time/posix_time.hpp... yes
checking for the Boost date_time library... yes
checking boost/scoped_ptr.hpp usability... yes
checking boost/scoped_ptr.hpp presence... yes
checking for boost/scoped_ptr.hpp... yes
checking boost/shared_ptr.hpp usability... yes
checking boost/shared_ptr.hpp presence... yes
checking for boost/shared_ptr.hpp... yes
checking boost/uuid/uuid.hpp usability... no
checking boost/uuid/uuid.hpp presence... yes
configure: WARNING: boost/uuid/uuid.hpp: present but cannot be compiled
configure: WARNING: boost/uuid/uuid.hpp:     check for missing prerequisite headers?
configure: WARNING: boost/uuid/uuid.hpp: see the Autoconf documentation
configure: WARNING: boost/uuid/uuid.hpp:     section "Present But Cannot Be Compiled"
configure: WARNING: boost/uuid/uuid.hpp: proceeding with the compiler's result
checking for boost/uuid/uuid.hpp... no
configure: error: cannot find boost/uuid/uuid.hpp
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/net/libcmis
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/net/libcmis




>How-To-Repeat:

	cd /usr/pkgsrc/net/libcmis
	make install package

>Fix:

Please.  Logs available upon request.

>Audit-Trail:
From: Thomas Klausner <wiz@NetBSD.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Fri, 12 Sep 2014 18:05:57 +0200

 On Fri, Sep 12, 2014 at 03:30:01PM +0000, oster@netbsd.org wrote:
 > >Number:         49199
 > >Category:       pkg
 > >Synopsis:       boost errors - net/libcmis fails to build on NetBSD-6.1.4_PATCH/amd64

 I know this doesn't help you much, but just for comparison: builds for
 me on 7.99.1/amd64 with latest pkgsrc.
  Thomas

From: Greg Oster <oster@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Fri, 12 Sep 2014 10:28:53 -0600

 On Fri, 12 Sep 2014 16:10:06 +0000 (UTC)
 Thomas Klausner <wiz@NetBSD.org> wrote:

 > The following reply was made to PR pkg/49199; it has been noted by
 > GNATS.
 > 
 > From: Thomas Klausner <wiz@NetBSD.org>
 > To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
 > Cc: 
 > Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 >  NetBSD-6.1.4_PATCH/amd64
 > Date: Fri, 12 Sep 2014 18:05:57 +0200
 > 
 >  On Fri, Sep 12, 2014 at 03:30:01PM +0000, oster@netbsd.org wrote:
 >  > >Number:         49199
 >  > >Category:       pkg
 >  > >Synopsis:       boost errors - net/libcmis fails to build on
 >  > >NetBSD-6.1.4_PATCH/amd64
 >  
 >  I know this doesn't help you much, but just for comparison: builds
 > for me on 7.99.1/amd64 with latest pkgsrc.
 >   Thomas
 >  

 I *think* it also builds fine on 6.1.4 -- but not 6.1.4_PATCH... 

 So your datapoint might be most relevant -- maybe it's just something
 not parsing the _PATCH bit properly?

 Later...

 Greg Oster

From: Greg Oster <oster@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Mon, 15 Sep 2014 09:50:54 -0600

 More details from config.log:

 ...
 In file included from conftest.cpp:59:0:
 /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/uuid.hpp:197:40:
 warning: base class 'struct boost::integral_constant<bool, true>' has a
 non-virtual destructor In file included
 from /usr/include/gcc-4.5/xmmintrin.h:39:0,
 from /usr/include/gcc-4.5/emmintrin.h:36,
 from /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/detail/uuid_x86.hpp:22,
 from /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/uuid.hpp:203,
 from conftest.cpp:59: /usr/include/gcc-4.5/mm_malloc.h:34:64: error:
 declaration of 'int posix_memalign(void**, size_t, size_t) throw ()'
 throws different exceptions /usr/include/stdlib.h:237:6: error: from
 previous declaration 'int posix_memalign(void**, size_t, size_t)'
 ...



 Later...

 Greg Oster

From: Joerg Sonnenberger <joerg@britannica.bec.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Mon, 15 Sep 2014 18:29:40 +0200

 On Mon, Sep 15, 2014 at 03:55:01PM +0000, Greg Oster wrote:
 >  In file included from conftest.cpp:59:0:
 >  /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/uuid.hpp:197:40:
 >  warning: base class 'struct boost::integral_constant<bool, true>' has a
 >  non-virtual destructor In file included
 >  from /usr/include/gcc-4.5/xmmintrin.h:39:0,
 >  from /usr/include/gcc-4.5/emmintrin.h:36,
 >  from /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/detail/uuid_x86.hpp:22,
 >  from /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/uuid.hpp:203,
 >  from conftest.cpp:59: /usr/include/gcc-4.5/mm_malloc.h:34:64: error:
 >  declaration of 'int posix_memalign(void**, size_t, size_t) throw ()'
 >  throws different exceptions /usr/include/stdlib.h:237:6: error: from
 >  previous declaration 'int posix_memalign(void**, size_t, size_t)'
 >  ...

 The GCC header is bogus. Known issue, was fixed for GCC 4.8 in -current.

 Joerg

From: Greg Oster <oster@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Mon, 15 Sep 2014 10:33:54 -0600

 On Mon, 15 Sep 2014 16:30:01 +0000 (UTC)
 Joerg Sonnenberger <joerg@britannica.bec.de> wrote:

 > The following reply was made to PR pkg/49199; it has been noted by
 > GNATS.
 > 
 > From: Joerg Sonnenberger <joerg@britannica.bec.de>
 > To: gnats-bugs@NetBSD.org
 > Cc: 
 > Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 >  NetBSD-6.1.4_PATCH/amd64
 > Date: Mon, 15 Sep 2014 18:29:40 +0200
 > 
 >  On Mon, Sep 15, 2014 at 03:55:01PM +0000, Greg Oster wrote:
 >  >  In file included from conftest.cpp:59:0:
 >  >  /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/uuid.hpp:197:40:
 >  >  warning: base class 'struct boost::integral_constant<bool, true>'
 >  > has a non-virtual destructor In file included
 >  >  from /usr/include/gcc-4.5/xmmintrin.h:39:0,
 >  >  from /usr/include/gcc-4.5/emmintrin.h:36,
 >  >  from /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/detail/uuid_x86.hpp:22,
 >  >  from /usr/pkgsrc/net/libcmis/work.mickey/.buildlink/include/boost/uuid/uuid.hpp:203,
 >  >  from conftest.cpp:59: /usr/include/gcc-4.5/mm_malloc.h:34:64:
 >  > error: declaration of 'int posix_memalign(void**, size_t, size_t)
 >  > throw ()' throws different exceptions /usr/include/stdlib.h:237:6:
 >  > error: from previous declaration 'int posix_memalign(void**,
 >  > size_t, size_t)' ...
 >  
 >  The GCC header is bogus. Known issue, was fixed for GCC 4.8 in
 > -current. 

 What needs to be done for NetBSD 6.1.4_PATCH running gcc version 4.5.3
 (NetBSD nb2 20110806)?  More specifically, what can be done from the
 land of pkgsrc to address this? :)

 Thanks!

 Later...

 Greg Oster

From: Greg Oster <oster@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Wed, 17 Sep 2014 16:10:07 -0600

 On Fri, 12 Sep 2014 16:30:00 +0000 (UTC)
 Greg Oster <oster@netbsd.org> wrote:

 > The following reply was made to PR pkg/49199; it has been noted by
 > GNATS.
 > 
 > From: Greg Oster <oster@netbsd.org>
 > To: gnats-bugs@NetBSD.org
 > Cc: 
 > Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 >  NetBSD-6.1.4_PATCH/amd64
 > Date: Fri, 12 Sep 2014 10:28:53 -0600
 > 
 >  On Fri, 12 Sep 2014 16:10:06 +0000 (UTC)
 >  Thomas Klausner <wiz@NetBSD.org> wrote:
 >  
 >  > The following reply was made to PR pkg/49199; it has been noted by
 >  > GNATS.
 >  > 
 >  > From: Thomas Klausner <wiz@NetBSD.org>
 >  > To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
 >  > Cc: 
 >  > Subject: Re: pkg/49199: boost errors - net/libcmis fails to build
 >  > on NetBSD-6.1.4_PATCH/amd64
 >  > Date: Fri, 12 Sep 2014 18:05:57 +0200
 >  > 
 >  >  On Fri, Sep 12, 2014 at 03:30:01PM +0000, oster@netbsd.org wrote:
 >  >  > >Number:         49199
 >  >  > >Category:       pkg
 >  >  > >Synopsis:       boost errors - net/libcmis fails to build on
 >  >  > >NetBSD-6.1.4_PATCH/amd64
 >  >  
 >  >  I know this doesn't help you much, but just for comparison: builds
 >  > for me on 7.99.1/amd64 with latest pkgsrc.
 >  >   Thomas
 >  >  
 >  
 >  I *think* it also builds fine on 6.1.4 -- but not 6.1.4_PATCH... 
 >  
 >  So your datapoint might be most relevant -- maybe it's just something
 >  not parsing the _PATCH bit properly?

 Actually, it doesn't build fine on 6.1.4 either...  It would be rather
 nice to have this working before we push a new pkgsrc out the door... 

 Later...

 Greg Oster

From: Joerg Sonnenberger <joerg@britannica.bec.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Thu, 18 Sep 2014 01:02:01 +0200

 On Mon, Sep 15, 2014 at 05:15:01PM +0000, Greg Oster wrote:
 >  What needs to be done for NetBSD 6.1.4_PATCH running gcc version 4.5.3
 >  (NetBSD nb2 20110806)?  More specifically, what can be done from the
 >  land of pkgsrc to address this? :)

 I'm not sure if it can be handled sanely in pkgsrc. There is a pending
 pull up for the fix.

 Joerg

From: Makoto Fujiwara <makoto@ki.nu>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on NetBSD-6.1.4_PATCH/amd64
Date: Mon, 06 Oct 2014 14:38:41 +0900

 I needed to package net/libcmis on NetBSD/amd64 6.1.4 and checked
 the difference against 7.99.1.

 I have applied the change attached diff and it is packaged OK
 (but with huge warning).

 Thank you,
 ---
 mef@NetBSD.org
 Makoto Fujiwara, 
 Chiba, Japan, Narita Airport and Disneyland prefecture.

 --- /usr/include/gcc-4.5/mm_malloc.h	2013-05-13 10:52:55.000000000 +0900
 +++ /home/makoto/mm_malloc.h	2014-10-06 14:10:13.000000000 +0900
 @@ -1,4 +1,4 @@
 -/* Copyright (C) 2004, 2006, 2009 Free Software Foundation, Inc.
 +/* Copyright (C) 2004-2013 Free Software Foundation, Inc.

     This file is part of GCC.

 @@ -31,7 +31,7 @@
  #ifndef __cplusplus
  extern int posix_memalign (void **, size_t, size_t);
  #else
 -extern "C" int posix_memalign (void **, size_t, size_t) throw ();
 +extern "C" int posix_memalign (void **, size_t, size_t);
  #endif

  static __inline void *

From: Greg Oster <oster@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: joerg@britannica.bec.de, pkg-manager@netbsd.org, gnats-admin@netbsd.org,
 pkgsrc-bugs@netbsd.org
Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 NetBSD-6.1.4_PATCH/amd64
Date: Wed, 26 Nov 2014 14:00:31 -0600

 On Wed, 17 Sep 2014 23:05:00 +0000 (UTC)
 Joerg Sonnenberger <joerg@britannica.bec.de> wrote:

 > The following reply was made to PR pkg/49199; it has been noted by
 > GNATS.
 > 
 > From: Joerg Sonnenberger <joerg@britannica.bec.de>
 > To: gnats-bugs@NetBSD.org
 > Cc: 
 > Subject: Re: pkg/49199: boost errors - net/libcmis fails to build on
 >  NetBSD-6.1.4_PATCH/amd64
 > Date: Thu, 18 Sep 2014 01:02:01 +0200
 > 
 >  On Mon, Sep 15, 2014 at 05:15:01PM +0000, Greg Oster wrote:
 >  >  What needs to be done for NetBSD 6.1.4_PATCH running gcc version
 >  > 4.5.3 (NetBSD nb2 20110806)?  More specifically, what can be done
 >  > from the land of pkgsrc to address this? :)
 >  
 >  I'm not sure if it can be handled sanely in pkgsrc. There is a
 > pending pull up for the fix.

 My 'fix' is to add:

 GCC_REQD+=4.7

 to the Makefile.  Not perfect, but it means that this at least builds
 for people without them having to modify their default systems.

 Later...

 Greg Oster

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.