NetBSD Problem Report #50236

From tsutsui@ceres.dti.ne.jp  Sun Sep 13 06:45:32 2015
Return-Path: <tsutsui@ceres.dti.ne.jp>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 0BEE1A6554
	for <gnats-bugs@gnats.NetBSD.org>; Sun, 13 Sep 2015 06:45:32 +0000 (UTC)
Message-Id: <201509130645.t8D6jRbp018103@mirage.localdomain>
Date: Sun, 13 Sep 2015 15:45:27 +0900 (JST)
From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
Reply-To: tsutsui@ceres.dti.ne.jp
To: gnats-bugs@NetBSD.org
Cc: tsutsui@ceres.dti.ne.jp
Subject: lang/php54 fails to build on NetBSD/m68k 7.0_RC1
X-Send-Pr-Version: 3.95

>Number:         50236
>Category:       pkg
>Synopsis:       lang/php54 fails to build on NetBSD/m68k 7.0_RC1
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    bsiegert
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Sep 13 06:50:00 +0000 2015
>Closed-Date:    
>Last-Modified:  Sun Oct 09 14:06:17 +0000 2016
>Originator:     Izumi Tsutsui
>Release:        NetBSD 7.0_RC1 + pkgsrc-2015Q2
>Organization:
>Environment:
System: NetBSD luna68k 7.0_RC1 GENERIC
Architecture: m68k (probably alpha, sh3, and hppa are also affected)
Machine: luna68k
>Description:
lang/php54 builds on pkgsrc-2015Q2 tree fails on NetBSD/m68k 7.0_RC1
due to lack of SLJIT support.

It looks upstream sljit sources in pcrelib have inconsistent definitions.

>How-To-Repeat:
build lang/php54 on architectures which don't have SLJIT support,
like m68k, alpha, sh3, or hppa:
(the log is taken from php-5.4.43 before the latest pullup but same on 5.4.44)
---
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:65:2: error: #error Unsupported architecture
 #error Unsupported architecture
---

The full log messages are here:
---
/bin/sh /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/libtool --silent --preserve-dup-deps --mode=compile gcc -DHAVE_CONFIG_H -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib -Iext/pcre/ -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/ -DPHP_ATOM_INC -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/include -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/main -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43 -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/date/lib -I/usr/pkg/include/libxml2 -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/TSRM -I/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/Zend  -I/usr/pkg/include -I/usr/include -I/usr/pkg/include  -O2 -fno-reorder-blocks -pthread -I/usr/pkg/include -I/usr/include  -c /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c -o ext/pcre/pcrelib/pcre_jit_compile.lo 
In file included from /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:62:0:
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/sljit/sljitLir.c:1714:49: error: conflicting types for 'sljit_create_compiler'
 SLJIT_API_FUNC_ATTRIBUTE struct sljit_compiler* sljit_create_compiler(void)
                                                 ^
In file included from /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/sljit/sljitLir.c:27:0,
                 from /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:62:
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/sljit/sljitLir.h:420:49: note: previous declaration of 'sljit_create_compiler' was here
 SLJIT_API_FUNC_ATTRIBUTE struct sljit_compiler* sljit_create_compiler(void *allocator_data);
                                                 ^
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:65:2: error: #error Unsupported architecture
 #error Unsupported architecture
  ^
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c: In function '_pcre_jit_compile':
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:9970:1: error: too many arguments to function 'sljit_create_compiler'
 compiler = sljit_create_compiler(NULL);
 ^
In file included from /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:62:0:
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/sljit/sljitLir.c:1714:49: note: declared here
 SLJIT_API_FUNC_ATTRIBUTE struct sljit_compiler* sljit_create_compiler(void)
                                                 ^
In file included from /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/sljit/sljitLir.c:27:0,
                 from /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:62:
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c: At top level:
/usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/sljit/sljitLir.h:438:31: warning: 'sljit_set_compiler_memory_error' used but never defined [enabled by default]
 SLJIT_API_FUNC_ATTRIBUTE void sljit_set_compiler_memory_error(struct sljit_compiler *compiler);
                               ^
Makefile:466: recipe for target 'ext/pcre/pcrelib/pcre_jit_compile.lo' failed
gmake: *** [ext/pcre/pcrelib/pcre_jit_compile.lo] Error 1
*** Error code 2

Stop.
make[3]: stopped in /usr/pkgsrc/lang/php54
*** Error code 1

Stop.
make[2]: stopped in /usr/pkgsrc/lang/php54
*** Error code 1

Stop.
---

>Fix:
Add similar confitionals to '#define SUPPORT_JIT' line
in ext/pcre/pcrelib/config.h:
 https://github.com/php/php-src/blob/f38ca75a3cc5737bdb922dc5e2a7505cd20cd7ea/ext/pcre/pcrelib/config.h#L397
as ext/pcre/pcrelib/sljit/sljitConfigInternal.h defines
 https://github.com/php/php-src/blob/f38ca75a3cc5737bdb922dc5e2a7505cd20cd7ea/ext/pcre/pcrelib/sljit/sljitConfigInternal.h#L117
via local patch?

--- php-5.4.43/ext/pcre/pcrelib/config.h.orig	2015-08-03 09:58:18.000000000 +0900
+++ php-5.4.43/ext/pcre/pcrelib/config.h
@@ -395,7 +395,18 @@
 #undef SUPPORT_GCOV

 /* Define to any value to enable support for Just-In-Time compiling. */
+#if defined(__i386__) || defined(__i386) \
+|| defined(__x86_64__) \
+|| defined(__arm__) || defined(__ARM__) \
+|| defined (__aarch64__) \
+|| defined(__ppc64__) || defined(__powerpc64__) || defined(_ARCH_PPC64) || (defined(_POWER) && defined(__64BIT__)) \
+|| defined(__ppc__) || defined(__powerpc__) || defined(_ARCH_PPC) || defined(_ARCH_PWR) || defined(_ARCH_PWR2) || defined(_POWER) \
+|| (defined(__mips__) && !defined(_LP64)) \
+|| defined(__mips64) \
+|| defined(__sparc__) || defined(__sparc) \
+|| defined(__tilegx__)
 #define SUPPORT_JIT
+#endif

 /* Define to any value to allow pcregrep to be linked with libbz2, so that it
    is able to handle .bz2 files. */
---

>Release-Note:

>Audit-Trail:
From: Joerg Sonnenberger <joerg@britannica.bec.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/50236: lang/php54 fails to build on NetBSD/m68k 7.0_RC1
Date: Sun, 13 Sep 2015 12:03:46 +0200

 On Sun, Sep 13, 2015 at 06:50:00AM +0000, Izumi Tsutsui wrote:
 > /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/pcre_jit_compile.c:65:2: error: #error Unsupported architecture
 >  #error Unsupported architecture

 Does devel/pcre work and why the heck is php uses its own pce copy?

 Joerg

From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
To: gnats-bugs@NetBSD.org
Cc: tsutsui@ceres.dti.ne.jp
Subject: Re: pkg/50236: lang/php54 fails to build on NetBSD/m68k 7.0_RC1
Date: Sun, 13 Sep 2015 21:38:56 +0900

 >  Does devel/pcre work and why the heck is php uses its own pce copy?

 No idea.

 ---
 Izumi Tsutsui

From: Filip Hajny <filip@joyent.com>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/50236: lang/php54 fails to build on NetBSD/m68k 7.0_RC1
Date: Sun, 13 Sep 2015 20:58:03 +0200

 > 13. 9. 2015 v 12:05, Joerg Sonnenberger <joerg@britannica.bec.de>:
 >=20
 > The following reply was made to PR pkg/50236; it has been noted by =
 GNATS.
 >=20
 > From: Joerg Sonnenberger <joerg@britannica.bec.de>
 > To: gnats-bugs@NetBSD.org
 > Cc:=20
 > Subject: Re: pkg/50236: lang/php54 fails to build on NetBSD/m68k =
 7.0_RC1
 > Date: Sun, 13 Sep 2015 12:03:46 +0200
 >=20
 > On Sun, Sep 13, 2015 at 06:50:00AM +0000, Izumi Tsutsui wrote:
 >> =
 /usr/obj.luna68k/pkgsrc/lang/php54/work.m68k/php-5.4.43/ext/pcre/pcrelib/p=
 cre_jit_compile.c:65:2: error: #error Unsupported architecture
 >> #error Unsupported architecture
 >=20
 > Does devel/pcre work and why the heck is php uses its own pce copy?
 >=20

 Same thing with sqlite3 that=E2=80=99s also built from bundled sources.

 It may be related to this comment in graphics/php-gd:

 # XXX we use bundled GD so that extension is usable also by non-threaded
 # PHP, such as CLI/CGI version or ap-php on Apache 1.x.

 -F=

Responsible-Changed-From-To: pkg-manager->bsiegert
Responsible-Changed-By: bsiegert@NetBSD.org
Responsible-Changed-When: Mon, 28 Dec 2015 12:30:24 +0000
Responsible-Changed-Why:


State-Changed-From-To: open->closed
State-Changed-By: bsiegert@NetBSD.org
State-Changed-When: Mon, 28 Dec 2015 12:30:24 +0000
State-Changed-Why:
lang/php54 has been removed from pkgsrc.


From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
To: gnats-bugs@NetBSD.org
Cc: tsutsui@ceres.dti.ne.jp
Subject: Re: pkg/50236 (lang/php54 fails to build on NetBSD/m68k 7.0_RC1)
Date: Mon, 28 Dec 2015 22:48:54 +0900

 > lang/php54 has been removed from pkgsrc.

 Probably php55 also has the same problem.
 (php-5.5.30/ext/pcre/pcrelib/config.h unconditionally defines "SUPPORT_JIT")

 ---
 Izumi Tsutsui

State-Changed-From-To: closed->feedback
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Sun, 01 May 2016 04:55:43 +0000
State-Changed-Why:
can you confirm if the problem still affects current php versions?


From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
To: gnats-bugs@NetBSD.org
Cc: dholland@NetBSD.org, tsutsui@ceres.dti.ne.jp
Subject: Re: pkg/50236 (lang/php54 fails to build on NetBSD/m68k 7.0_RC1)
Date: Mon, 2 May 2016 17:04:24 +0900

 php-5.5.34 in pkgsrc-2016Q1 on (a bit faster) NetBSD/sh3 7.0 still complains:

 ---
 /bin/sh /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/libtool --silent --preserve-dup-deps --mode=compile gcc -DHAVE_CONFIG_H -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib -Iext/pcre/ -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/ -DPHP_ATOM_INC -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/include -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/main -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34 -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/date/lib -I/usr/pkg/include/libxml2 -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/TSRM -I/usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/Zend  -I/usr/pkg/include -I/usr/include -I/usr/pkg/include  -Os -freorder-blocks -pthread -I/usr/pkg/include -I/usr/include  -c /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c -o ext/pcre/pcrelib/pcre_jit_compile.lo 
 In file included from /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c:62:0:
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/sljit/sljitLir.c:1718:49: error: conflicting types for 'sljit_create_compiler'
  SLJIT_API_FUNC_ATTRIBUTE struct sljit_compiler* sljit_create_compiler(void)
                                                  ^
 In file included from /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/sljit/sljitLir.c:27:0,
                  from /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c:62:
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/sljit/sljitLir.h:420:49: note: previous declaration of 'sljit_create_compiler' was here
  SLJIT_API_FUNC_ATTRIBUTE struct sljit_compiler* sljit_create_compiler(void *allocator_data);
                                                  ^
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c:65:2: error: #error Unsupported architecture
  #error Unsupported architecture
   ^
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c: In function '_pcre_jit_compile':
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c:10012:1: error: too many arguments to function 'sljit_create_compiler'
  compiler = sljit_create_compiler(NULL);
  ^
 In file included from /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c:62:0:
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/sljit/sljitLir.c:1718:49: note: declared here
  SLJIT_API_FUNC_ATTRIBUTE struct sljit_compiler* sljit_create_compiler(void)
                                                  ^
 In file included from /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/sljit/sljitLir.c:27:0,
                  from /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c:62:
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/pcre_jit_compile.c: At top level:
 /usr/obj.sh3el/pkgsrc/lang/php55/work.sh3el/php-5.5.34/ext/pcre/pcrelib/sljit/sljitLir.h:438:31: warning: 'sljit_set_compiler_memory_error' used but never defined [enabled by default]
  SLJIT_API_FUNC_ATTRIBUTE void sljit_set_compiler_memory_error(struct sljit_compiler *compiler);
                                ^
 Makefile:479: recipe for target 'ext/pcre/pcrelib/pcre_jit_compile.lo' failed
 gmake: *** [ext/pcre/pcrelib/pcre_jit_compile.lo] Error 1
 *** Error code 2

 Stop.
 make[1]: stopped in /usr/pkgsrc/lang/php55
 *** Error code 1

 Stop.
 make: stopped in /usr/pkgsrc/lang/php55

 ---

 The essencial problem is
 >> #error Unsupported architecture
 so it's still there.

 ---
 Izumi Tsutsui

State-Changed-From-To: feedback->open
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Mon, 02 May 2016 15:49:39 +0000
State-Changed-Why:
problem still exists.
let's not rush to close things...


From: coypu@SDF.ORG
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/50236: lang/php54 fails to build on NetBSD/m68k 7.0_RC1
Date: Tue, 3 May 2016 11:16:29 +0000

 Hi!

 Others are forcing PHP to build with system PCRE with the configure
 flag --with-pcre-regex=$PREFIX.

From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
To: coypu@SDF.ORG
Cc: gnats-bugs@NetBSD.org, bsiegert@NetBSD.org, pkgsrc-bugs@netbsd.org,
        tsutsui@ceres.dti.ne.jp
Subject: Re: pkg/50236: lang/php54 fails to build on NetBSD/m68k 7.0_RC1
Date: Wed, 4 May 2016 12:13:25 +0900

 coypu@ wrote:

 >  Others are forcing PHP to build with system PCRE with the configure
 >  flag --with-pcre-regex=$PREFIX.

 The following patch makes pkgsrc-2016Q1 lang/php55 build on NetBSD/sh3el 7.0
 (though not tested with actuall applications)

 ---
 Index: Makefile.php
 ===================================================================
 RCS file: /cvsroot/pkgsrc/lang/php55/Makefile.php,v
 retrieving revision 1.4
 diff -u -d -p -r1.4 Makefile.php
 --- Makefile.php	13 Jun 2014 14:13:20 -0000	1.4
 +++ Makefile.php	4 May 2016 03:09:58 -0000
 @@ -41,6 +41,8 @@ CONFIGURE_ARGS+=	--enable-mysqlnd
  CONFIGURE_ARGS+=	--enable-xml
  CONFIGURE_ARGS+=	--with-libxml-dir=${PREFIX}
  .include "../../textproc/libxml2/buildlink3.mk"
 +CONFIGURE_ARGS+=	--with-pcre-regex=${PREFIX}
 +.include "../../devel/pcre/buildlink3.mk"

  PKG_OPTIONS_VAR=	PKG_OPTIONS.${PHP_PKG_PREFIX}
  PKG_SUPPORTED_OPTIONS+=	inet6 ssl maintainer-zts readline
 Index: PLIST
 ===================================================================
 RCS file: /cvsroot/pkgsrc/lang/php55/PLIST,v
 retrieving revision 1.5
 diff -u -d -p -r1.5 PLIST
 --- PLIST	19 Feb 2015 13:35:24 -0000	1.5
 +++ PLIST	4 May 2016 03:09:58 -0000
 @@ -116,11 +116,6 @@ include/php/ext/mysqlnd/mysqlnd_structs.
  include/php/ext/mysqlnd/mysqlnd_wireprotocol.h
  include/php/ext/mysqlnd/php_mysqlnd.h
  include/php/ext/mysqlnd/php_mysqlnd_config.h
 -include/php/ext/pcre/pcrelib/config.h
 -include/php/ext/pcre/pcrelib/pcre.h
 -include/php/ext/pcre/pcrelib/pcre_internal.h
 -include/php/ext/pcre/pcrelib/pcreposix.h
 -include/php/ext/pcre/pcrelib/ucp.h
  include/php/ext/pcre/php_pcre.h
  include/php/ext/phar/php_phar.h
  include/php/ext/session/mod_files.h

 ---
 Izumi Tsutsui

From: Thomas Klausner <wiz@NetBSD.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/50236: lang/php54 fails to build on NetBSD/m68k 7.0_RC1
Date: Thu, 28 Jul 2016 12:33:11 +0200

 On Wed, May 04, 2016 at 03:15:01AM +0000, Izumi Tsutsui wrote:
 >  The following patch makes pkgsrc-2016Q1 lang/php55 build on NetBSD/sh3el 7.0
 >  (though not tested with actuall applications)
 >  
 >  ---
 >  Index: Makefile.php
 >  ===================================================================
 >  RCS file: /cvsroot/pkgsrc/lang/php55/Makefile.php,v
 >  retrieving revision 1.4
 >  diff -u -d -p -r1.4 Makefile.php
 >  --- Makefile.php	13 Jun 2014 14:13:20 -0000	1.4
 >  +++ Makefile.php	4 May 2016 03:09:58 -0000
 >  @@ -41,6 +41,8 @@ CONFIGURE_ARGS+=	--enable-mysqlnd
 >   CONFIGURE_ARGS+=	--enable-xml
 >   CONFIGURE_ARGS+=	--with-libxml-dir=${PREFIX}
 >   .include "../../textproc/libxml2/buildlink3.mk"
 >  +CONFIGURE_ARGS+=	--with-pcre-regex=${PREFIX}
 >  +.include "../../devel/pcre/buildlink3.mk"
 >   
 >   PKG_OPTIONS_VAR=	PKG_OPTIONS.${PHP_PKG_PREFIX}
 >   PKG_SUPPORTED_OPTIONS+=	inet6 ssl maintainer-zts readline
 >  Index: PLIST
 >  ===================================================================
 >  RCS file: /cvsroot/pkgsrc/lang/php55/PLIST,v
 >  retrieving revision 1.5
 >  diff -u -d -p -r1.5 PLIST
 >  --- PLIST	19 Feb 2015 13:35:24 -0000	1.5
 >  +++ PLIST	4 May 2016 03:09:58 -0000
 >  @@ -116,11 +116,6 @@ include/php/ext/mysqlnd/mysqlnd_structs.
 >   include/php/ext/mysqlnd/mysqlnd_wireprotocol.h
 >   include/php/ext/mysqlnd/php_mysqlnd.h
 >   include/php/ext/mysqlnd/php_mysqlnd_config.h
 >  -include/php/ext/pcre/pcrelib/config.h
 >  -include/php/ext/pcre/pcrelib/pcre.h
 >  -include/php/ext/pcre/pcrelib/pcre_internal.h
 >  -include/php/ext/pcre/pcrelib/pcreposix.h
 >  -include/php/ext/pcre/pcrelib/ucp.h
 >   include/php/ext/pcre/php_pcre.h
 >   include/php/ext/phar/php_phar.h
 >   include/php/ext/session/mod_files.h

 This looks good to me.

 Please bump PKGREVISION and commit.
 Do php56 and php70 need the same fix?
  Thomas

Responsible-Changed-From-To: bsiegert->tsutsui
Responsible-Changed-By: bsiegert@NetBSD.org
Responsible-Changed-When: Sun, 09 Oct 2016 13:30:33 +0000
Responsible-Changed-Why:
Please commit your patch.


From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
To: gnats-bugs@NetBSD.org
Cc: tsutsui@ceres.dti.ne.jp
Subject: Re: pkg/50236 (lang/php54 fails to build on NetBSD/m68k 7.0_RC1)
Date: Sun, 9 Oct 2016 22:57:11 +0900

 Sorry I have no patch for current version and
 I no longer have demands for php on m68k..

 ---
 Izumi Tsutsui

Responsible-Changed-From-To: tsutsui->bsiegert
Responsible-Changed-By: bsiegert@NetBSD.org
Responsible-Changed-When: Sun, 09 Oct 2016 14:06:17 +0000
Responsible-Changed-Why:
Take back, the submitter is no longer interested in his own patch.
*sigh*


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.