NetBSD Problem Report #50260

From www@NetBSD.org  Sat Sep 19 15:57:52 2015
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 220C1A5864
	for <gnats-bugs@gnats.NetBSD.org>; Sat, 19 Sep 2015 15:57:52 +0000 (UTC)
Message-Id: <20150919155750.A7D8AA6562@mollari.NetBSD.org>
Date: Sat, 19 Sep 2015 15:57:50 +0000 (UTC)
From: tritthardt@neuro.mpg.de
Reply-To: tritthardt@neuro.mpg.de
To: gnats-bugs@NetBSD.org
Subject: ffmpeg1 build error
X-Send-Pr-Version: www-1.0

>Number:         50260
>Category:       pkg
>Synopsis:       ffmpeg1 build error
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Sep 19 16:00:00 +0000 2015
>Originator:     Juergen
>Release:        pkgsrc-2015Q2
>Organization:
Tritthardt
>Environment:
NetBSD rpi1 7.0_RC3 NetBSD 7.0_RC3 (RPI.201508110747Z) evbarm
>Description:
During build of meta-pkgs/xfce4 on a Raspberry Pi 1 I got the following build error, also libvpx-1.3.0nb4 is installed:

===> Installing dependencies for ffmpegthumbnailer-2.0.8nb3
==========================================================================
The following variables will affect the build process of this package,
ffmpegthumbnailer-2.0.8nb3.  Their current value is shown below:

        * JPEG_DEFAULT = jpeg

Based on these variables, the following variables have been set:

        * JPEGBASE (defined, but empty)
        * JPEG_TYPE = jpeg

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
==========================================================================
=> Tool dependency libtool-base>=2.2.6bnb3: found libtool-base-2.4.2nb9
=> Tool dependency pkg-config>=0.25: found pkg-config-0.28
=> Full dependency jpeg>=9: found jpeg-9anb1
=> Full dependency png>=1.6.0nb1: found png-1.6.17
=> Full dependency ffmpeg1>=1.2.6nb1: NOT found
=> Verifying package-install for ../../multimedia/ffmpeg1
=> Bootstrap dependency digest>=20010302: found digest-20121220
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/sbin/pkg_admin -K /var/db/pkg fetch-pkg-vulnerabilities'.
===> Configuring for ffmpeg1-1.2.12
mkdir /usr/pkgsrc/multimedia/ffmpeg1/work/ffmpeg-1.2.12/tmp
=> Generating pkg-config file for builtin expat package.
=> Replacing Perl interpreter in doc/texi2pod.pl.
=> Replacing sh interpreter in configure version.sh.
ERROR: libvpx decoder version must be >=0.9.1

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.
*** Error code 1

Stop.
make[4]: stopped in /usr/pkgsrc/multimedia/ffmpeg1
*** Error code 1

Stop.
make[3]: stopped in /usr/pkgsrc/multimedia/ffmpeg1
*** Error code 1

Stop.
make[2]: stopped in /usr/pkgsrc/multimedia/ffmpegthumbnailer
*** Error code 1

Stop.
make[1]: stopped in /usr/pkgsrc/x11/xfce4-tumbler
*** Error code 1
r
Stop.
make: stopped in /usr/pkgsrc/meta-pkgs/xfce4

rpi1# pkg_info|grep libvpx
libvpx-1.3.0nb4     On2 VP8 library from Google


>How-To-Repeat:
Tried it two several times with a recursive make clean clean-depends inbetween, same error again.

>Fix:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.