NetBSD Problem Report #50421

From oster@cs.usask.ca  Thu Nov 12 14:29:19 2015
Return-Path: <oster@cs.usask.ca>
Received: from mail.netbsd.org (mail.netbsd.org [149.20.53.66])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 775EEA6551
	for <gnats-bugs@gnats.NetBSD.org>; Thu, 12 Nov 2015 14:29:19 +0000 (UTC)
Message-Id: <20151112142712.AB2A587D39@mickey.usask.ca>
Date: Thu, 12 Nov 2015 08:27:12 -0600 (CST)
From: oster@netbsd.org
Reply-To: oster@netbsd.org
To: gnats-bugs@NetBSD.org
Subject: PLIST conflicts with py27-qt4 and py34-qt4
X-Send-Pr-Version: 3.95

>Number:         50421
>Category:       pkg
>Synopsis:       PLIST conflicts with py27-qt4 and py34-qt4
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Nov 12 14:30:00 +0000 2015
>Last-Modified:  Thu Nov 12 14:55:01 +0000 2015
>Originator:     Greg Oster
>Release:        NetBSD 7.0
>Organization:
>Environment:


System: NetBSD mickey 7.0 NetBSD 7.0 (QUAD) #0: Mon Sep 28 11:54:36 CST 2015 oster@quad:/u1/builds/build265/src/obj/amd64/u1/builds/build265/src/sys/arch/amd64/compile/QUAD amd64
Architecture: x86_64
Machine: amd64
>Description:

When building x11/py-qt4 for both python27 and python34, the following
error is observed:

=> Creating binary package /usr/pkgsrc/x11/py-qt4/work.mickey/.packages/py34-qt4-4.11.1nb1.tgz
===> Install binary package of py34-qt4-4.11.1nb1
pkg_add: Conflicting PLIST with py27-qt4-4.11.1nb1: bin/pylupdate4
pkg_add: 1 package addition failed
*** Error code 1


>How-To-Repeat:

Desire to have python34 as the default version with:

	PYTHON_VERSION_DEFAULT = 34

in /etc/mk.conf .  Discover that some things (e.g. math/cantor, and
hence, meta/kde4) will not build with python34, and require python27.
Tell math/cantor to use python7.  Then watch kde4 build kate, which
wants py-kde4, which wants py-qt4, which needs py34-qt4... but that
has a PLIST conflict with the py27-qt4 built when making math/cantor.

>Fix:

Rename bin/pylupdate4 for one of the versions?

>Audit-Trail:
From: Thomas Klausner <wiz@NetBSD.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/50421: PLIST conflicts with py27-qt4 and py34-qt4
Date: Thu, 12 Nov 2015 15:53:17 +0100

 On Thu, Nov 12, 2015 at 02:30:00PM +0000, oster@netbsd.org wrote:
 > Rename bin/pylupdate4 for one of the versions?

 Usually we rename all of them to bin/foo-${PYVERSSUFFIX} and sometimes
 add ALTERNATES files if its an enduser tool.

 I have no clue what pylupdate4 does though, i.e., if it's something a
 user would call or which is used during compilation.
  Thomas

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.