NetBSD Problem Report #50583

From www@NetBSD.org  Wed Dec 23 09:38:21 2015
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.NetBSD.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 1207E7A213
	for <gnats-bugs@gnats.NetBSD.org>; Wed, 23 Dec 2015 09:38:21 +0000 (UTC)
Message-Id: <20151223093820.087DC7ACB6@mollari.NetBSD.org>
Date: Wed, 23 Dec 2015 09:38:20 +0000 (UTC)
From: randolf+netbsd.org@inter-corporate.com
Reply-To: randolf+netbsd.org@inter-corporate.com
To: gnats-bugs@NetBSD.org
Subject: p5-libapreq2 needs to be compiled for ap24-perl so that Perl modules like Apache2::Cookies can work
X-Send-Pr-Version: www-1.0

>Number:         50583
>Category:       pkg
>Synopsis:       p5-libapreq2 needs to be compiled for ap24-perl so that Perl modules like Apache2::Cookies can work
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          feedback
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Dec 23 09:40:00 +0000 2015
>Closed-Date:    
>Last-Modified:  Tue Mar 14 05:15:58 +0000 2017
>Originator:     Randolf Richardson
>Release:        7.0
>Organization:
Inter-Corporate Computer & Network Services, Inc.
>Environment:
NetBSD netbsd 7.0 NetBSD 7.0 (GENERIC.201509250726Z) amd64
>Description:
I'd like to transition from Apache HTTPd v2.2 to v2.4.  Most of my web sites are developed with ModPerl 2 on Apache HTTP v2.2, and they depend on APR to access cookies and other features.

apache-2.4.16 (Apache HTTPd v2.4) installs and seems to function correctly.

perl-5.22.0 (Perl 5) installs and seems to function correctly.

ap24-perl-2.0.9 (ModPerl v2.0.9) installs and seems to function correctly.

p5-libapreq2 (APR) fails because it depends on ap22-perl (but I'm using ap24-perl, so ap22-perl won't even start installing).

>How-To-Repeat:
pkgin install perl
pkgin install apache-2.4
pkgin install ap24-perl
pkgin install p5-libapreq2

>Fix:

>Release-Note:

>Audit-Trail:

From: "Maya Rashish" <maya@netbsd.org>
To: gnats-bugs@gnats.NetBSD.org
Cc: 
Subject: PR/50583 CVS commit: pkgsrc/www/p5-libapreq2
Date: Sat, 11 Mar 2017 19:08:19 +0000

 Module Name:	pkgsrc
 Committed By:	maya
 Date:		Sat Mar 11 19:08:19 UTC 2017

 Modified Files:
 	pkgsrc/www/p5-libapreq2: Makefile

 Log Message:
 libapreq2: Embed apache version into PKGNAME.

 This package has a dependency on an apache-versioned pkg (ap22-perl) and so
 the binary package will only work for one version of apache, previously
 apache22.

 PR pkg/50583 from Randolf Richardson


 To generate a diff of this commit:
 cvs rdiff -u -r1.38 -r1.39 pkgsrc/www/p5-libapreq2/Makefile

 Please note that diffs are not public domain; they are subject to the
 copyright notices on the relevant files.

State-Changed-From-To: open->feedback
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Tue, 14 Mar 2017 05:15:58 +0000
State-Changed-Why:
Did that change help? It should be possible to build it for either apache
version now.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.