NetBSD Problem Report #50835

From www@NetBSD.org  Mon Feb 22 13:43:16 2016
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.NetBSD.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 86F077ABDA
	for <gnats-bugs@gnats.NetBSD.org>; Mon, 22 Feb 2016 13:43:16 +0000 (UTC)
Message-Id: <20160222134315.68D087ACD8@mollari.NetBSD.org>
Date: Mon, 22 Feb 2016 13:43:15 +0000 (UTC)
From: manyphall@manlymail.net
Reply-To: manyphall@manlymail.net
To: gnats-bugs@NetBSD.org
Subject: Package build error dependency problem
X-Send-Pr-Version: www-1.0

>Number:         50835
>Category:       pkg
>Synopsis:       Package build error dependency problem
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Mon Feb 22 13:45:00 +0000 2016
>Closed-Date:    
>Last-Modified:  Fri Sep 09 03:10:45 +0000 2016
>Originator:     Jonn Fox
>Release:        2015Q3 (I believe it is in Q4 also)
>Organization:
N/A
>Environment:
7.0 NetBSD 7.0 (GENERIC.201509250726Z) amd64
>Description:
A very small problem. net/dcsharp calls for mono2 (.include "../../lang/mono2/buildlink3.mk") but has already installed mono4 to fulfill a different dependency.
>How-To-Repeat:
Just try to build and package dcsharp
>Fix:
change the  entry in the net/dcsharp Makefile from

.include "../../lang/mono2/buildlink3.mk"

to 

.include "../../lang/mono/buildlink3.mk"

>Release-Note:

>Audit-Trail:
From: David Holland <dholland-pbugs@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/50835: Package build error dependency problem
Date: Fri, 26 Feb 2016 03:55:22 +0000

 On Mon, Feb 22, 2016 at 01:45:00PM +0000, manyphall@manlymail.net wrote:
  > A very small problem. net/dcsharp calls for mono2 (.include
  > "../../lang/mono2/buildlink3.mk") but has already installed mono4
  > to fulfill a different dependency.

 Does it build/work with mono4? Most of the things that explicitly use
 mono2 do so because they don't. Or didn't, at least, with mono3.

 -- 
 David A. Holland
 dholland@netbsd.org

State-Changed-From-To: open->feedback
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Fri, 26 Aug 2016 02:39:34 +0000
State-Changed-Why:
I asked a question, six months ago


State-Changed-From-To: feedback->open
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Fri, 09 Sep 2016 03:10:45 +0000
State-Changed-Why:
Feedback mail bounced. Anyone know about mono versions and this package?


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.