NetBSD Problem Report #51281

From www@NetBSD.org  Mon Jun 27 04:48:15 2016
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 1C57A7A2AE
	for <gnats-bugs@gnats.NetBSD.org>; Mon, 27 Jun 2016 04:48:15 +0000 (UTC)
Message-Id: <20160627044813.E6F7C7AAA2@mollari.NetBSD.org>
Date: Mon, 27 Jun 2016 04:48:13 +0000 (UTC)
From: richard@NetBSD.org
Reply-To: richard@NetBSD.org
To: gnats-bugs@NetBSD.org
Subject: shared-mime-info fails with configure: error: XML::Parser perl module is required for intltool
X-Send-Pr-Version: www-1.0

>Number:         51281
>Category:       pkg
>Synopsis:       shared-mime-info fails with configure: error: XML::Parser perl module is required for intltool
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jun 27 04:50:00 +0000 2016
>Last-Modified:  Sat Jul 09 20:15:01 +0000 2016
>Originator:     Richard PALO
>Release:        current
>Organization:
>Environment:
SunOS omnis 5.11 omnios-master-7397b49 i86pc i386 i86pc

>Description:
pkg_rr uncovered with a recent refresh of current:

checking for perl... /opt/local/bin/perl
checking for perl >= 5.8.1... 5.24.0
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
*** Error code 2

Stop.
bmake[1]: stopped in /home/richard/src/pkgsrc/databases/shared-mime-info

perl seems to be an implicit dependency and p5-XML-Parser doesn't seem to be depended upon correctly forcing a rebuild.

Manually rebuilding p5-XML-Parser gets over the problem now, but doesn't solve the issue.
>How-To-Repeat:

>Fix:

>Audit-Trail:
From: Thomas Klausner <wiz@NetBSD.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 XML::Parser perl module is required for intltool
Date: Mon, 27 Jun 2016 08:39:36 +0200

 On Mon, Jun 27, 2016 at 04:50:00AM +0000, Richard Palo wrote:
 > >Number:         51281
 > >Category:       pkg
 > >Synopsis:       shared-mime-info fails with configure: error: XML::Parser perl module is required for intltool
 > >Confidential:   no
 > >Severity:       serious
 > >Priority:       high
 > >Responsible:    pkg-manager
 > >State:          open
 > >Class:          sw-bug
 > >Submitter-Id:   net
 > >Arrival-Date:   Mon Jun 27 04:50:00 +0000 2016
 > >Originator:     Richard PALO
 > >Release:        current
 > >Organization:
 > >Environment:
 > SunOS omnis 5.11 omnios-master-7397b49 i86pc i386 i86pc
 > 
 > >Description:
 > pkg_rr uncovered with a recent refresh of current:
 > 
 > checking for perl... /opt/local/bin/perl
 > checking for perl >= 5.8.1... 5.24.0
 > checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
 > *** Error code 2

 This usually only happens when intltool is not in USE_TOOLS, but
 that's the case here.

 Perhaps there's a weird interaction with pkg_rr, can you make sure
 it's installed?
  Thomas

From: Richard PALO <richard@netbsd.org>
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error: XML::Parser
 perl module is required for intltool
Date: Mon, 27 Jun 2016 09:27:30 +0200

 Le 27/06/16 08:40, Thomas Klausner a ťcrit :
 >   This usually only happens when intltool is not in USE_TOOLS, but
 >   that's the case here.
 >
 >   Perhaps there's a weird interaction with pkg_rr, can you make sure
 >   it's installed?
 >    Thomas
 >
 >
 Both intltools and p5-XML-Parser were installed (I believe that is what 
 you're asking).

 The problem, as I indicated, is related more to the perl upgrade where 
 p5-XML-Parser wasn't upgraded yet as it isn't deemed to be a dependency.

 Perhaps there needs to be a DEPENDS clause added to mk/tools/intltool.mk
 for p5-XML-Parser.

From: Thomas Klausner <wiz@NetBSD.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 XML::Parser perl module is required for intltool
Date: Mon, 27 Jun 2016 10:34:57 +0200

 On Mon, Jun 27, 2016 at 07:30:00AM +0000, Richard Palo wrote:
 >  Both intltools and p5-XML-Parser were installed (I believe that is what 
 >  you're asking).

 Actually, only intltool.

 >  The problem, as I indicated, is related more to the perl upgrade where 
 >  p5-XML-Parser wasn't upgraded yet as it isn't deemed to be a dependency.
 >  
 >  Perhaps there needs to be a DEPENDS clause added to mk/tools/intltool.mk
 >  for p5-XML-Parser.

 No, p5-XML-Parser is a dependency for intltool. We don't want to
 expand all dependencies recursively.

 I think that if there is a bug here, it's in pkg_rr.
  Thomas

From: David Holland <dholland-pbugs@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 XML::Parser perl module is required for intltool
Date: Mon, 27 Jun 2016 08:50:54 +0000

 On Mon, Jun 27, 2016 at 04:50:00AM +0000, richard@NetBSD.org wrote:
  > pkg_rr uncovered with a recent refresh of current:
  > 
  > checking for perl... /opt/local/bin/perl
  > checking for perl >= 5.8.1... 5.24.0
  > checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
  > *** Error code 2
  > 
  > Stop.
  > bmake[1]: stopped in /home/richard/src/pkgsrc/databases/shared-mime-info
  > 
  > perl seems to be an implicit dependency and p5-XML-Parser doesn't
  > seem to be depended upon correctly forcing a rebuild.
  >
  > Manually rebuilding p5-XML-Parser gets over the problem now, but
  > doesn't solve the issue.

 shared-mime-info depends on intltool (via USE_TOOLS) and intltool
 depends on p5-XML-Parser, so in theory it all ought to work. Is
 pkg_rr losing track of this?

 -- 
 David A. Holland
 dholland@netbsd.org

From: Richard PALO <richard@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error: XML::Parser
 perl module is required for intltool
Date: Mon, 27 Jun 2016 12:55:18 +0200

 Le 27/06/16 10:35, Thomas Klausner a écrit :
 > The following reply was made to PR pkg/51281; it has been noted by GNATS.
 > 
 > From: Thomas Klausner <wiz@NetBSD.org>
 > To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
 > Cc: 
 > Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 >  XML::Parser perl module is required for intltool
 > Date: Mon, 27 Jun 2016 10:34:57 +0200
 > 
 >  On Mon, Jun 27, 2016 at 07:30:00AM +0000, Richard Palo wrote:
 >  >  Both intltools and p5-XML-Parser were installed (I believe that is what 
 >  >  you're asking).
 >  
 >  Actually, only intltool.
 >  
 >  >  The problem, as I indicated, is related more to the perl upgrade where 
 >  >  p5-XML-Parser wasn't upgraded yet as it isn't deemed to be a dependency.
 >  >  
 >  >  Perhaps there needs to be a DEPENDS clause added to mk/tools/intltool.mk
 >  >  for p5-XML-Parser.
 >  
 >  No, p5-XML-Parser is a dependency for intltool. We don't want to
 >  expand all dependencies recursively.
 >  
 >  I think that if there is a bug here, it's in pkg_rr.
 >   Thomas
 >  
 > 

 Ah yeah, I see, it's in textproc/intltool that p5-XML-Parser is depended on.
 Okay.  I just checked the log after the pkg_rr restart, and now that shared-mime-info was replaced
 after rebuilding p5-XML-Parser, I see that intltool is finally chosen to be replaced...

 Here is an extract of this:
 > RR> Checking for rebuild-requested installed packages (rebuild=YES)

 > RR> Checking for unsafe installed packages (unsafe_depends_strict=YES)

 > RR> Packages to rebuild:

 > rr> MISMATCH_TODO=[bsdtar engrampa libarchive p5-Archive-Zip libpurple p5-JSON p5-Unicode-EastAsianWidth mysql-client mysql-server openldap-client postgresql94-client byacc gettext-tools git git-base git-contrib git-docs git-gitk gmake gtexinfo meld mercurial p5-Capture-Tiny p5-Class-Singleton p5-CPAN-Meta p5-CPAN-Meta-Check p5-Data-OptList p5-Date-Manip p5-Devel-Symdump p5-Devel-Trace p5-Dist-CheckConflicts p5-enum p5-Error p5-Exporter-Tiny p5-File-BaseDir p5-File-DesktopEntry p5-File-Listing p5-File-MimeInfo p5-File-ShareDir-Install p5-File-Slurp p5-File-Which p5-gettext p5-inc-latest p5-Inline p5-Inline-C p5-IO-All p5-IO-CaptureOutput p5-IO-HTML p5-IPC-Run3 p5-IPC-System-Simple p5-List-AllUtils p5-List-MoreUtils p5-List-SomeUtils p5-List-SomeUtils-XS p5-Module-Build p5-Module-Implementation p5-Module-Metadata p5-Module-Runtime p5-Params-Util p5-Params-Validate p5-Parse-RecDescent p5-Path-Class p5-Pegex p5-Perl4-CoreLibs p5-Probe-Perl p5-Scalar-List-Utils p5-Sub-Exporter p5-Sub-I
  d
 entify p5-Sub-Install p5-Sub-Uplevel p5-SUPER p5-Test-Deep p5-Test-Exception p5-Test-Fatal p5-Test-Inter p5-Test-LeakTrace p5-Test-MockModule p5-Test-NoWarnings p5-Test-Output p5-Test-Pod p5-Test-Pod-Coverage p5-Test-Requires p5-Test-Script p5-Test-Simple p5-Test-Taint p5-Test-Warn p5-Test-Warnings p5-Try-Tiny py27-cffi py27-mercurial py27-setuptools py27-test vim-share p5-Finance-Quote gsftopkk tex-alegreya tex-cabin tex-dantelogo tex-erewhon tex-fbb tex-fetamont tex-fira tex-fontawesome tex-inconsolata tex-ipaex-type1 tex-knuth-local tex-newpx tex-newtx tex-newtxsf tex-roboto tex-sourcecodepro tex-sourceserifpro tex-tex-gyre-math eom graphviz ImageMagick tex-mptopdf lua53 mutt p5-Email-Valid p5-MailTools p5-Net-SMTP-SSL p5-Math-Round texlive-collection-basic texlive-collection-fontsextra texlive-collection-fontsrecommended texlive-collection-latex libreoffice p5-Business-ISBN p5-Business-ISBN-Data p5-Locale-libintl ffmpeg1 gst-plugins1-base gstreamer1 p5-IO-Socket-INET6 p5-Net p5-N
  e
 t-DBus p5-Net-DNS p5-Net-Domain-TLD p5-Net-IP p5-Net-LibIDN p5-Socket6 p5-pkgsrc-Dewey pkglint4 atril cups cups-filters luatex podofo tex-algorithms tex-amsmath tex-babel tex-etex-pkg tex-graphics tex-hyperref tex-koma-script tex-latex tex-latex-bin tex-luatex tex-oberdiek tex-pdfpages tex-pdftex tex-plain tex-tetex tex-texlive-scripts tex-titlesec tex-tools tex-xcolor web2c xdvik mate-polkit openssl p5-Authen-SASL p5-Crypt-SSLeay p5-Digest-HMAC p5-Digest-SHA1 p5-GSSAPI p5-IO-Socket-SSL p5-Mozilla-CA p5-Net-SSLeay p5-pcsc polkit py27-cryptography caja consolekit file p5-File-Copy-Recursive system-tools-backends p5-Encode-Locale p5-File-ReadBackwards p5-Pod-Coverage p5-Text-Balanced p5-Text-Unidecode p5-XML-NamespaceSupport p5-XML-SAX p5-XML-SAX-Base p5-XML-SAX-Expat p5-XML-Simple p5-XML-Twig p5-YAML-LibYAML p5-YAML-Syck p5-DateTime p5-DateTime-Locale p5-DateTime-TimeZone p5-TimeDate marco p5-CGI p5-HTML-Element-Extended p5-HTML-Parser p5-HTML-TableExtract p5-HTML-Tagset p5-HTML-Tree 
  p
 5-HTTP-Cookies p5-HTTP-Daemon p5-HTTP-Date p5-HTTP-Message p5-HTTP-Negotiate p5-libwww p5-LWP-MediaTypes p5-LWP-Protocol-https p5-Net-HTTP p5-URI p5-WWW-RobotRules py27-flask py27-werkzeug libmatekbd libxklavier mate-desktop mate-menus mate-panel mate-screensaver qt5-qtwebchannel xkeyboard-config xterm]

 > rr> REBUILD_TODO=[]

 > rr> UNSAFE_TODO=[p5-Locale-libintl mate-system-monitor tex-raleway p5-Encode-Locale vim-share p5-pcsc tex-pigpen gst-plugins0.10-pulse tex-helvetic tex-adfsymbols tex-merriweather tex-yfonts-t1 tex-xkeyval tex-mptopdf p5-Params-Validate p5-DateTime-Locale tex-esrelation goocanvas p5-CGI tex-courier postgresql94-client tex-doublestroke libwmf p5-Test-Warnings tex-aspectratio ImageMagick libnice p5-Test-Fatal tex-fontawesome libgnomecanvas gvfs p5-Math-Round podofo tex-cm-super tex-iwona pulseaudio qt4-qdbus py27-imaging wv gtkhtml314 neon tex-natbib upower py27-lxml tex-frcursive p5-XML-SAX-Expat tex-semaphor p5-HTML-Tagset grantlee tex-sansmathaccent tex-luatex p5-TimeDate automake gtk2+ tex-cabin meld tex-koma-script pluma p5-Test-MockModule gnupg polkit atk luatex t1lib py-gobject3-common cups-filters totem tex-calligra-type1 py27-dbus p5-Inline-C tex-texlive-scripts texlive-collection-basic intltool gdk-pixbuf2 autoconf tex-boondox tex-staves wxGTK30 p5-Class-Singleton p5-Captur
  e
 -Tiny tex-librebaskerville gucharmap tex-antiqua mate-media pangomm vim-gtk2 tex-amsmath tex-mfware tex-carlito python27 tex-comfortaa tex-bbold p5-Path-Class tex-trajan python35 p5-Devel-Trace xdvik w3m tex-eco tex-ocherokee attica mate-power-manager libgnome-keyring tex-wasysym qt4-sqlite3 p5-Net-SMTP-SSL poppler-qt4 tex-antt at-spi libgdata tex-accanthis tex-linearA tex-brushscr tex-recycle libarchive gobject-introspection tex-erewhon texlive-collection-latex p5-Params-Util p5-Business-ISBN-Data groff postgresql94-server farstream tex-libertine libbonoboui qt5-qtbase hal tex-tex-gyre libxklavier mate-menus tex-manfnt-font p5-File-ReadBackwards tex-beton tex-plain tex-babel-english poppler-glib tex-carolmin-ps rasqal tex-amsfonts p5-CPAN-Meta tex-bera p5-Test-Output p5-Net-SSLeay tex-overlock p5-File-MimeInfo texlive-collection-fontsextra tex-xcharter tex-electrum pgadmin3 p5-Crypt-SSLeay tex-gfsdidot glib-networking tex-ocr-b-outline libetonyek mutt tex-comicneue tex-times pkglint
  4
  tex-esvect opensp p5-IO-CaptureOutput xdg-utils tex-baskervald p5-GSSAPI asciidoc py35-expat p5-IO-All marco p5-inc-latest libofa ghostscript-gpl p5-Module-Runtime gtkmm p5-Test-NoWarnings cairo p5-URI webkit24-gtk gsftopkk mysql-server caja-dropbox libbonobo tex-graphics tex-carlisle p5-Test-Taint p5-HTTP-Message tex-archaic tex-clearsans p5-Test-Script p5-File-Copy-Recursive tex-metafont tex-gfsbodoni py27-gobject p5-XML-Simple p5-Digest-SHA1 tex-hyperref tex-symbol tex-algorithms gnome-icon-theme caja tex-babel p5-enum tex-euro tex-fancyhdr libodfgen tex-epigrafica libwnck libgnome tex-cantarell p5-Text-Balanced tex-cm tex-cyklop polkit-qt p5-HTML-Parser tex-amscls libpurple tex-sansmathfonts tex-pdftex elinks pkg_developer tex-knuth-local tex-berenisadf p5-HTTP-Cookies p5-HTML-TableExtract libmateweather libnotify tex-latex-bin p5-Try-Tiny tex-grotesq libsecret tex-libris tex-pxtxalfa tex-mintspirit p5-HTML-Tree gst-plugins0.10-theora tex-geometry p5-Sub-Uplevel tex-mdsymbol tex
  -
 listings tex-adforn p5-Module-Metadata dbus-glib p5-LWP-Protocol-https GConf-ui p5-Authen-SASL tex-rsfso uim strigi gst-plugins0.10-good netpbm p5-Data-OptList p5-File-ShareDir-Install gtksourceview2 p5-WWW-RobotRules p5-XML-NamespaceSupport gstreamer1 libreoffice p5-Mozilla-CA mysql-client gnome-vfs p5-libwww tex-caladea libXft firefox24 libsoup tex-newtxtt p5-File-Slurp tex-lm tex-fourier tex-fge tex-gfsneohellenic p5-Net-HTTP tex-metapost tex-mathdesign apr-util tex-lxfonts tex-esstix tex-tex phonon tex-inconsolata policykit gst-plugins0.10-gio libgltf cairo-gobject curl libgpod qca2 gtksourceview3 tex-fbb system-tools-backends at-spi2-atk qt4-tools pidgin docbook-xsl tex-fancybox libass p5-pkgsrc-Dewey tex-fdsymbol xdg-user-dirs ImageMagick6 gst-plugins0.10-ogg eom gupnp tex-ebgaramond gst-plugins1-base p5-XML-SAX-Base xload swfdec p5-List-SomeUtils-XS gst-plugins0.10-soup git-base tex-poltawski p5-HTTP-Daemon libgtop p5-Test-LeakTrace gtar-base mozo tex-latex tex-opensans p5-Tes
  t
 -Warn autogen tex-titlesec py27-gobject3 tex-eso-pic yelp-tools p5-Finance-Quote brasero tex-ltxmisc tex-overpic p5-Text-Unidecode p5-Inline tex-initials mate-control-center gutenprint-lib tex-fp gconf-editor subversion-base tex-baskervaldx tex-palatino tex-anonymouspro tex-txfontsb p5-Test-Pod libabw xcursorgen mate-user-share p5-Sub-Identify p5-Dist-CheckConflicts cups tex-mnsymbol gssdp fltk tex-txfonts vte tex-aurical poppler gettext-tools tex-gfscomplutum tex-kurier gdbus-codegen apache tex-rsfs tex-stmaryrd lucene++ tex-belleek loudmouth tex-cm-lgc p5-Perl4-CoreLibs evolution-webcal tex-prodint tex-hfbright raptor2 py27-libxml2 p5-Test-Inter tex-bbold-type1 p5-Exporter-Tiny p5-Scalar-List-Utils tex-rotating p5-Test-Pod-Coverage totem-pl-parser gst-plugins0.10-base libcmis libe-book gsettings-desktop-schemas mate-sensors-applet swfdec-gnome tex-psnfss tex-cmll tex-newpx mate-utils gkrellm libXpm dbus mate-applets openjpeg15 p5-Net-DNS p5-MailTools tex-mathabx-type1 gtk-doc tex-a
  s
 cii-font p5-Test-Simple tex-placeins p5-Digest-HMAC tex-augie mate-panel qtscriptgenerator p5-Pegex p5-Test-Deep gimp tex-oberdiek tex-cmextra gcalctool qt4-libs tex-sourcesanspro tex-zapfchan dirmngr evolution-data-server p5-IO-HTML tex-avantgar tex-sourceserifpro p5-Net-DBus tex-dictsym gphoto2 p5-Net-Domain-TLD tex-pdfpages mate-notification-daemon libxslt p5-Email-Valid p5-List-SomeUtils tex-ms mate-screensaver tex-dejavu gpgme gst-plugins0.10-vorbis tex-etex-pkg gio-fam p5-Probe-Perl tex-gillius texi2html p5-IPC-System-Simple tex-kpfonts p5-HTML-Element-Extended xfd aspell gtkmm3 tex-tipa tex-gfsartemisia help2man tex-countriesofeurope libxml++1 libmatekbd libgphoto2 p5-Net tex-tools openjdk7 p5-gettext caja-extensions p5-Date-Manip tex-roboto p5-YAML-Syck py27-qt4 rarian graphviz xterm mate-desktop tex-notoccite libglade tex-wasy2-ps p5-Socket6 tex-xcolor at-spi2-core gtk3+ json-glib gegl tex-bibtex gtkspell p5-SUPER liblangtag tex-cinzel gtexinfo tex-starfont filezilla p5-IO-S
  o
 cket-SSL liblastfm tex-cyrillic tex-arev sane-backends mate-terminal p5-Sub-Install libmtp fontforge libdbusmenu-qt tex-colortbl tex-dutchcal p5-File-DesktopEntry libgsf pcsc-tools tex-ncntrsbk tex-librecaslon p5-List-AllUtils libplist tex-dantelogo p5-XML-SAX tex-lm-math texlive-collection-fontsrecommended tex-lato p5-JSON tex-changebar thunderbird24 p5-Sub-Exporter libcroco autoconf213 p5-Net-IP findutils p5-YAML-LibYAML tex-tetex tex-fonetika py27-expat tex-romande tex-superiors gdk-pixbuf2-xlib gnupg2 gnome-doc-utils qjson p5-Module-Build tex-quattrocento gstreamer0.10 tex-sourcecodepro libgxps tex-lobster2 avahi tex-tfrupee tex-pxfonts tex-ccicons tex-gentium-tug tex-bguq p5-Test-Requires foomatic-db-engine gupnp-igd p5-Module-Implementation tex-ae libprelude py27-cElementTree p5-Pod-Coverage tex-fetamont dblatex p5-HTTP-Date tex-alegreya p5-File-BaseDir gst-plugins0.10-flac tex-newtxsf mate-settings-daemon py-gobject-shared tex-droid gmime tex-tex-gyre-math tex-euler libwnck3 o
  p
 encv pango p5-IO-Socket-INET6 web2c tex-venturisadf GConf tex-ebgaramond-maths adwaita-icon-theme tex-fancyvrb p5-XML-Twig tex-allrunes dconf p5-Unicode-EastAsianWidth tex-phaistos zenity p5-Devel-Symdump p5-File-Listing tex-etex p5-Business-ISBN atkmm tex-minitoc tex-ec mupdf p5-IPC-Run3 icon-naming-utils atril ccid p5-LWP-MediaTypes engrampa tex-bookhands p5-Archive-Zip tex-playfair librsvg tex-bookman tex-foekfont tex-fira tex-gfssolomos libgnomeui transfig p5-File-Which p5-Test-Exception cmake tex-mflogo-font MesaLib p5-DateTime-TimeZone automoc4 tex-fpl p5-HTTP-Negotiate vala tex-lh tex-oinuit openjpeg xmlto gdm p5-DateTime tex-marvosym p5-Net-LibIDN tex-heuristica p5-Parse-RecDescent mate-session-manager tex-hacm tex-ipaex-type1 tex-epsf vino tex-paratype libdbusmenu-glib p5-CPAN-Meta-Check p5-List-MoreUtils poppler-utils tex-eurosym tex-newtx kdelibs4 p5-Error tex-auncial-new tex-universalis tex-stix xorg-cf-files mate-netbook tex-zapfding tex-cfr-lm gnutls]

 > RR> Building dependency graph for installed packages

 > RR> Tsorting dependency graph

 > RR> Selecting p5-Encode-Locale (textproc/p5-Encode-Locale) as next package to replace

 > RR> Checking if p5-Encode-Locale has new depends...

 > RR> p5-Encode-Locale has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-Locale-libintl (misc/p5-Locale-libintl) as next package to replace

 > RR> Checking if p5-Locale-libintl has new depends...

 > RR> p5-Locale-libintl has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-File-Slurp (devel/p5-File-Slurp) as next package to replace

 > RR> Checking if p5-File-Slurp has new depends...

 > RR> p5-File-Slurp has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-Test-Requires (devel/p5-Test-Requires) as next package to replace

 > RR> Checking if p5-Test-Requires has new depends...

 > RR> p5-Test-Requires has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-Module-Metadata (devel/p5-Module-Metadata) as next package to replace

 > RR> Checking if p5-Module-Metadata has new depends...

 > RR> p5-Module-Metadata has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting tex-fontawesome (fonts/tex-fontawesome) as next package to replace

 > RR> Checking if tex-fontawesome has new depends...

 > RR> tex-fontawesome has the following new depends (need to re-tsort):

 > rr> [tex-tetex]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-Math-Round (math/p5-Math-Round) as next package to replace

 > RR> Checking if p5-Math-Round has new depends...

 > RR> p5-Math-Round has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-XML-NamespaceSupport (textproc/p5-XML-NamespaceSupport) as next package to replace

 > RR> Checking if p5-XML-NamespaceSupport has new depends...

 > RR> p5-XML-NamespaceSupport has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-HTML-Tagset (www/p5-HTML-Tagset) as next package to replace

 > RR> Checking if p5-HTML-Tagset has new depends...

 > RR> p5-HTML-Tagset has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-TimeDate (time/p5-TimeDate) as next package to replace

 > RR> Checking if p5-TimeDate has new depends...

 > RR> p5-TimeDate has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-Test-Pod (devel/p5-Test-Pod) as next package to replace

 > RR> Checking if p5-Test-Pod has new depends...

 > RR> p5-Test-Pod has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-File-ShareDir-Install (devel/p5-File-ShareDir-Install) as next package to replace

 > RR> Checking if p5-File-ShareDir-Install has new depends...

 > RR> p5-File-ShareDir-Install has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting p5-File-Copy-Recursive (sysutils/p5-File-Copy-Recursive) as next package to replace

 > RR> Checking if p5-File-Copy-Recursive has new depends...

 > RR> p5-File-Copy-Recursive has the following new depends (need to re-tsort):

 > rr> [perl<5.26.00]

 > RR> Tsorting dependency graph

 > RR> Selecting intltool (textproc/intltool) as next package to replace

 > RR> Checking if intltool has new depends...

 > RR> Replacing intltool-0.51.0nb1

 > ===> Cleaning for intltool-0.51.0nb1

 > => Bootstrap dependency digest>=20010302: found digest-20160304

 > => Checksum SHA1 OK for intltool-0.51.0.tar.gz

 > => Checksum RMD160 OK for intltool-0.51.0.tar.gz

 > => Checksum SHA512 OK for intltool-0.51.0.tar.gz

 > ===> Installing dependencies for intltool-0.51.0nb1

 > => Tool dependency gmake>=3.81: found gmake-4.2nb1

 > => Tool dependency nbpatch-[0-9]*: found nbpatch-20151107

 > => Tool dependency pax>=20040802: found pax-20080110nb2

 > => Tool dependency checkperms>=1.1: found checkperms-1.11nb1

 > => Build dependency cwrappers>=20150314: found cwrappers-20160110nb1

 > => Full dependency p5-XML-Parser>=2.34nb4: found p5-XML-Parser-2.44nb2

 > => Full dependency perl>=5.0: found perl-5.24.0

 > => Full dependency gettext-lib>=0.18: found gettext-lib-0.19.8.1

 > => Full dependency libiconv>=1.9.1nb4: found libiconv-1.14nb2

 > ===> Overriding tools for intltool-0.51.0nb1

 > ===> Extracting for intltool-0.51.0nb1

 > ===> Patching for intltool-0.51.0nb1

 > blah blah

 So I'm not sure why intltool wasn't selected to rebuild prior to shared-mime-info...

 (now I have a problem with autogen too)
 -- 
 Richard PALO

From: David Holland <dholland-pbugs@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 XML::Parser perl module is required for intltool
Date: Mon, 27 Jun 2016 14:24:06 +0000

 On Mon, Jun 27, 2016 at 10:55:01AM +0000, Richard PALO wrote:
  >  So I'm not sure why intltool wasn't selected to rebuild prior to
  > shared-mime-info...

 Did it get missed in the perl update revbump?

 Still, the symptoms you got suggest that p5-XML-Parser wasn't rebuilt
 either.

 -- 
 David A. Holland
 dholland@netbsd.org

From: Thomas Klausner <wiz@NetBSD.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 XML::Parser perl module is required for intltool
Date: Mon, 27 Jun 2016 16:28:50 +0200

 On Mon, Jun 27, 2016 at 02:25:00PM +0000, David Holland wrote:
 >  On Mon, Jun 27, 2016 at 10:55:01AM +0000, Richard PALO wrote:
 >   >  So I'm not sure why intltool wasn't selected to rebuild prior to
 >   > shared-mime-info...
 >  
 >  Did it get missed in the perl update revbump?

 intltool was bumped for perl.

 shared-mime-info not, because it only uses intltool at build time.
  Thomas

From: Richard PALO <richard@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error: XML::Parser
 perl module is required for intltool
Date: Mon, 27 Jun 2016 17:27:49 +0200

 Le 27/06/16 16:30, Thomas Klausner a écrit :
 > The following reply was made to PR pkg/51281; it has been noted by GNATS.
 > 
 > From: Thomas Klausner <wiz@NetBSD.org>
 > To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
 > Cc: 
 > Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 >  XML::Parser perl module is required for intltool
 > Date: Mon, 27 Jun 2016 16:28:50 +0200
 > 
 >  On Mon, Jun 27, 2016 at 02:25:00PM +0000, David Holland wrote:
 >  >  On Mon, Jun 27, 2016 at 10:55:01AM +0000, Richard PALO wrote:
 >  >   >  So I'm not sure why intltool wasn't selected to rebuild prior to
 >  >   > shared-mime-info...
 >  >  
 >  >  Did it get missed in the perl update revbump?
 >  
 >  intltool was bumped for perl.
 >  
 >  shared-mime-info not, because it only uses intltool at build time.
 >   Thomas
 >  
 > 
 > 

 Are you sure?
 From my tree, I see 
 > # $NetBSD: Makefile,v 1.64 2015/06/12 10:51:21 wiz Exp $
 > 
 > DISTNAME=               intltool-0.51.0
 > PKGREVISION=            1

 I believe perl was updated more recently than a year ago.  

 This could be the issue, as since I use 'pkg_rr -suv', 
 it is more probable that intltool was rebuilt because
 I rebuilt p5-XML-Parser than anything else at the moment.

 -- 
 Richard PALO

From: Thomas Klausner <wiz@NetBSD.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 XML::Parser perl module is required for intltool
Date: Mon, 27 Jun 2016 17:36:26 +0200

 On Mon, Jun 27, 2016 at 03:30:01PM +0000, Richard Palo wrote:
 >  Le 27/06/16 16:30, Thomas Klausner a écrit :
 >  >  intltool was bumped for perl.
 >  >  
 >  >  shared-mime-info not, because it only uses intltool at build time.
 >  >   Thomas
 >  >  
 >  > 
 >  > 
 >  
 >  Are you sure?
 >  From my tree, I see 
 >  > # $NetBSD: Makefile,v 1.64 2015/06/12 10:51:21 wiz Exp $
 >  > 
 >  > DISTNAME=               intltool-0.51.0
 >  > PKGREVISION=            1
 >  
 >  I believe perl was updated more recently than a year ago.  

 You're right, I misread this as 2016.
  Thomas

From: Thomas Klausner <wiz@NetBSD.org>
To: NetBSD bugtracking <gnats-bugs@NetBSD.org>
Cc: 
Subject: Re: pkg/51281: shared-mime-info fails with configure: error:
 XML::Parser perl module is required for intltool
Date: Sat, 9 Jul 2016 22:10:29 +0200

 On Mon, Jun 27, 2016 at 03:40:01PM +0000, Thomas Klausner wrote:
 >  You're right, I misread this as 2016.

 I've now bumped a lot more packages, so I hope this is fixed in pkgsrc HEAD.
  Thomas

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.