NetBSD Problem Report #51865

From www@NetBSD.org  Fri Jan 13 20:33:24 2017
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id B767A7A2BE
	for <gnats-bugs@gnats.NetBSD.org>; Fri, 13 Jan 2017 20:33:24 +0000 (UTC)
Message-Id: <20170113203323.8DDE17A2BF@mollari.NetBSD.org>
Date: Fri, 13 Jan 2017 20:33:23 +0000 (UTC)
From: bsiegert@NetBSD.org
Reply-To: bsiegert@NetBSD.org
To: gnats-bugs@NetBSD.org
Subject: cwrappers failure in textproc/p5-Text-Markdown-Discount
X-Send-Pr-Version: www-1.0

>Number:         51865
>Category:       pkg
>Synopsis:       cwrappers failure in textproc/p5-Text-Markdown-Discount
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Jan 13 20:35:01 +0000 2017
>Last-Modified:  Tue Mar 14 05:55:00 +0000 2017
>Originator:     Benny Siegert
>Release:        pkgsrc-2016Q4
>Organization:
The NetBSD Foundation
>Environment:
Darwin lem2.local 16.3.0 Darwin Kernel Version 16.3.0: Thu Nov 17 20:23:58 PST 2016; root:xnu-3789.31.2~1/RELEASE_X86_64 x86_64

>Description:
=> Bootstrap dependency digest>=20010302: found digest-20160304
===> Skipping vulnerability checks.
WARNING: No /opt/pkg-2016Q4/pkgdb/pkg-vulnerabilities file found.
WARNING: To fix run: `/opt/pkg-2016Q4/sbin/pkg_admin -K /opt/pkg-2016Q4/pkgdb fetch-pkg-vulnerabilities'.
=> Checksum SHA1 OK for Text-Markdown-Discount-0.11.tar.gz
=> Checksum RMD160 OK for Text-Markdown-Discount-0.11.tar.gz
=> Checksum SHA512 OK for Text-Markdown-Discount-0.11.tar.gz
===> Installing dependencies for p5-Text-Markdown-Discount-0.11nb3
=> Tool dependency nbpatch-[0-9]*: found nbpatch-20151107
=> Build dependency cwrappers>=20150314: found cwrappers-20161125
=> Full dependency perl<5.26.0: found perl-5.24.0
=> Full dependency perl>=5.24.0: found perl-5.24.0
===> Overriding tools for p5-Text-Markdown-Discount-0.11nb3
===> Extracting for p5-Text-Markdown-Discount-0.11nb3
cd /opt/pkgsrc-2016Q4/textproc/p5-Text-Markdown-Discount/work/Text-Markdown-Discount-0.11 && mv discount/VERSION discount/MYVERSION
===> Patching for p5-Text-Markdown-Discount-0.11nb3
=> Applying pkgsrc patches for p5-Text-Markdown-Discount-0.11nb3
===> Creating toolchain wrappers for p5-Text-Markdown-Discount-0.11nb3
===> Configuring for p5-Text-Markdown-Discount-0.11nb3
Checking if your kit is complete...
Looks good
Warning: -Ldiscount changed to -L/opt/pkgsrc-2016Q4/textproc/p5-Text-Markdown-Discount/work/Text-Markdown-Discount-0.11/discount
Generating a Unix-style Makefile
Writing Makefile for Text::Markdown::Discount
Writing MYMETA.yml and MYMETA.json
===> Building for p5-Text-Markdown-Discount-0.11nb3
cp lib/Text/Markdown/Discount.pm blib/lib/Text/Markdown/Discount.pm
( cd discount; CC='cc -fPIC' sh configure.sh; make )
Configuring for [markdown]
Looking for cpp (/opt/pkgsrc-2016Q4/textproc/p5-Text-Markdown-Discount/work/.cwrapper/bin/cpp) (can't run cpp as a pipeline)
make[1]: no target to make.

make[1]: stopped in /opt/pkgsrc-2016Q4/textproc/p5-Text-Markdown-Discount/work/Text-Markdown-Discount-0.11/discount


Building with USE_CWRAPPERS=no succeeds.

I have .work.log files for both builds if you need them.
>How-To-Repeat:
Build p5-Text-Markdown-Discount from pkgsrc-2016Q4
>Fix:
not sure. Joerg?

>Audit-Trail:
From: Jonathan Perkin <jperkin@joyent.com>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/51865: cwrappers failure in
 textproc/p5-Text-Markdown-Discount
Date: Tue, 17 Jan 2017 15:36:40 +0000

 * On 2017-01-13 at 20:35 GMT, bsiegert@NetBSD.org wrote:

 > Looking for cpp (/opt/pkgsrc-2016Q4/textproc/p5-Text-Markdown-Discount/work/.cwrapper/bin/cpp) (can't run cpp as a pipeline)
 > make[1]: no target to make.

 I've seen this before, does this patch help?

   https://github.com/joyent/pkgsrc/commit/7ffc3807f4b4a846fd216b17bb6c51a831c16caf#diff-4f1d5d6ca8e37519b98ca5e8195fe9e4

 (just the mk/cwrappers.mk change, ignore the others).

 -- 
 Jonathan Perkin  -  Joyent, Inc.  -  www.joyent.com

From: Joerg Sonnenberger <joerg@bec.de>
To: gnats-bugs@NetBSD.org
Cc: pkg-manager@netbsd.org, gnats-admin@netbsd.org, pkgsrc-bugs@netbsd.org,
	bsiegert@NetBSD.org
Subject: Re: pkg/51865: cwrappers failure in
 textproc/p5-Text-Markdown-Discount
Date: Tue, 17 Jan 2017 16:57:56 +0100

 On Tue, Jan 17, 2017 at 03:40:01PM +0000, Jonathan Perkin wrote:
 > The following reply was made to PR pkg/51865; it has been noted by GNATS.
 > 
 > From: Jonathan Perkin <jperkin@joyent.com>
 > To: gnats-bugs@NetBSD.org
 > Cc: 
 > Subject: Re: pkg/51865: cwrappers failure in
 >  textproc/p5-Text-Markdown-Discount
 > Date: Tue, 17 Jan 2017 15:36:40 +0000
 > 
 >  * On 2017-01-13 at 20:35 GMT, bsiegert@NetBSD.org wrote:
 >  
 >  > Looking for cpp (/opt/pkgsrc-2016Q4/textproc/p5-Text-Markdown-Discount/work/.cwrapper/bin/cpp) (can't run cpp as a pipeline)
 >  > make[1]: no target to make.
 >  
 >  I've seen this before, does this patch help?
 >  
 >    https://github.com/joyent/pkgsrc/commit/7ffc3807f4b4a846fd216b17bb6c51a831c16caf#diff-4f1d5d6ca8e37519b98ca5e8195fe9e4
 >  
 >  (just the mk/cwrappers.mk change, ignore the others).

 As I said last time, this is not correct. "cc -E" is not a correct
 implementation of a cpp. It doesn't handle lack of input arguments and
 there are quite a few packages that handle it.

 Joerg

From: Benny Siegert <bsiegert@netbsd.org>
To: Joerg Sonnenberger <joerg@bec.de>
Cc: gnats-bugs@netbsd.org, pkg-manager@netbsd.org, gnats-admin@netbsd.org, 
	pkgsrc-bugs@netbsd.org
Subject: Re: pkg/51865: cwrappers failure in textproc/p5-Text-Markdown-Discount
Date: Wed, 18 Jan 2017 10:45:00 +0100

 On Tue, Jan 17, 2017 at 4:57 PM, Joerg Sonnenberger <joerg@bec.de> wrote:
 > As I said last time, this is not correct. "cc -E" is not a correct
 > implementation of a cpp. It doesn't handle lack of input arguments and
 > there are quite a few packages that handle it.

 Noted with thanks, Joerg. Please suggest something to use instead.
 Simply having a broken package is not helpful.

 --Benny.

From: christos@zoulas.com (Christos Zoulas)
To: Benny Siegert <bsiegert@netbsd.org>, Joerg Sonnenberger <joerg@bec.de>
Cc: gnats-bugs@netbsd.org, pkg-manager@netbsd.org, gnats-admin@netbsd.org, 
	pkgsrc-bugs@netbsd.org
Subject: Re: pkg/51865: cwrappers failure in textproc/p5-Text-Markdown-Discount
Date: Wed, 18 Jan 2017 07:50:23 -0500

 On Jan 18, 10:45am, bsiegert@netbsd.org (Benny Siegert) wrote:
 -- Subject: Re: pkg/51865: cwrappers failure in textproc/p5-Text-Markdown-Dis

 | On Tue, Jan 17, 2017 at 4:57 PM, Joerg Sonnenberger <joerg@bec.de> wrote:
 | > As I said last time, this is not correct. "cc -E" is not a correct
 | > implementation of a cpp. It doesn't handle lack of input arguments and
 | > there are quite a few packages that handle it.
 | 
 | Noted with thanks, Joerg. Please suggest something to use instead.
 | Simply having a broken package is not helpful.

 Perhaps this is helpful?

 http://cvsweb.netbsd.org/bsdweb.cgi/src/gnu/usr.bin/egcs/cpp/Attic/usr.bin.cpp.sh?rev=1.3&content-type=text/x-cvsweb-markup&only_with_tag=MAIN

 christos

From: David Holland <dholland-pbugs@netbsd.org>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/51865: cwrappers failure in
 textproc/p5-Text-Markdown-Discount
Date: Tue, 14 Mar 2017 05:52:28 +0000

 On Fri, Jan 13, 2017 at 08:35:01PM +0000, bsiegert@NetBSD.org wrote:
  > Looking for cpp (/opt/pkgsrc-2016Q4/textproc/p5-Text-Markdown-Discount/work/.cwrapper/bin/cpp) (can't run cpp as a pipeline)

 So, the package doesn't do anything particularly offensive here; it
 tries running cpp as follows:

    $CPP "$CPPFLAGS" foo.c > foo.o
    $CPP -traditional-cpp -E foo.c > foo.o
    $CPP -E foo.c > foo.o
    $CPP -traditional-cpp -pipe foo.c > foo.o
    $CPP -pipe foo.c > foo.o

 It does not seem to me that any of these invocations should make the
 cwrappers wrapper belch if the old wrapper didn't belch either. So I
 suppose the question is: which of these fail, and why? Examining
 work.log should reveal at least which one's different.

 To figure out why it might be necessary to use make build-env and run
 the wrapper cpp by hand...


 (If the package is specifically trying to get a traditional cpp it
 should probably be using tradcpp instead, though.)

 -- 
 David A. Holland
 dholland@netbsd.org

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.