NetBSD Problem Report #52113

From john@andromeda.zia.io  Mon Mar 27 20:57:54 2017
Return-Path: <john@andromeda.zia.io>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 4BD377A210
	for <gnats-bugs@gnats.NetBSD.org>; Mon, 27 Mar 2017 20:57:54 +0000 (UTC)
Message-Id: <201703272057.v2RKvpCa022251@andromeda.zia.io>
Date: Mon, 27 Mar 2017 20:57:51 GMT
From: john@ziaspace.com
Reply-To: john@ziaspace.com
To: gnats-bugs@NetBSD.org
Subject: archivers/xz fails to build on Darwin
X-Send-Pr-Version: 3.95

>Number:         52113
>Category:       pkg
>Synopsis:       archivers/xz fails to build on Darwin
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    sevan
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Mar 27 21:00:00 +0000 2017
>Last-Modified:  Mon May 08 15:38:55 +0000 2017
>Originator:     John Klos
>Release:        Darwin 9.8.0
>Organization:

>Environment:
System: Darwin johnspowermacg5 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:57:01 PDT 
2009; root:xnu-1228.15.4~1/RELEASE_PPC Power Macintosh
>Description:

archivers/xz fails to build on Mac OS X Leopard on PowerPC:

-- lzmadec ---
libtool:   error: cannot find the library 
'/usr/pkgsrc/archivers/xz/work/.buildlink/lib/libiconv.la' or unhandled argument 
'/usr/pkgsrc/archivers/xz/work/.buildlink/lib/libiconv.la'
*** [lzmadec] Error code 1

bmake[3]: stopped in /usr/pkgsrc/archivers/xz/work/xz-5.2.3/src/xzdec

>How-To-Repeat:

>Fix:


>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->macos-pkg-people
Responsible-Changed-By: leot@NetBSD.org
Responsible-Changed-When: Tue, 28 Mar 2017 07:38:40 +0000
Responsible-Changed-Why:
Darwin problem


From: coypu@sdf.org
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/52113: archivers/xz fails to build on Darwin
Date: Fri, 5 May 2017 05:20:06 +0000

 does this just need the addition of:
 .include "../../converters/libiconv/buildlink3.mk"
 to the Makefile?

 I thought we have more platforms that require an explicit -liconv, but I
 don't see other failures.

From: John Klos <john@ziaspace.com>
To: gnats-bugs@NetBSD.org
Cc: macos-pkg-people@netbsd.org, gnats-admin@netbsd.org,
        pkgsrc-bugs@netbsd.org
Subject: Re: pkg/52113: archivers/xz fails to build on Darwin
Date: Fri, 5 May 2017 20:02:30 +0000 (UTC)

 Hello,

 > does this just need the addition of:
 > .include "../../converters/libiconv/buildlink3.mk"
 > to the Makefile?

 No. That doesn't change anything. It does build with:

 PREFER_PKGSRC=yes

 I haven't looked in to why that works yet.

 Thanks,
 John

From: Sevan Janiyan <venture37@geeklan.co.uk>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/52113: archivers/xz fails to build on Darwin
Date: Mon, 8 May 2017 16:31:56 +0100

 As a workaround, you can build xz without the nls option and that
 succeeds but the issue is still present. Issue is actually in
 gettext-tools (install xz without nls option & then try to build
 devel/gettext-tools)
 No solution yet but I'll look into it. especially since on Tiger my bulk
 build has now hit a circular dependency here.

 Cyclic dependency for package:
 xz-5.2.3
 gettext-lib-0.19.8.1
 libtool-base-2.4.6
 m4-1.4.17
 checkperms-1.11nb1
 findutils-4.6.0nb1
 bison-3.0.4nb3
 flex-2.6.3nb1
 gettext-tools-0.19.8.1
 xz-5.2.3

 Sevan

Responsible-Changed-From-To: macos-pkg-people->sevan
Responsible-Changed-By: sevan@NetBSD.org
Responsible-Changed-When: Mon, 08 May 2017 15:38:55 +0000
Responsible-Changed-Why:
take


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.