NetBSD Problem Report #52116

From john@andromeda.zia.io  Mon Mar 27 22:08:33 2017
Return-Path: <john@andromeda.zia.io>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.netbsd.org", Issuer "Postmaster NetBSD.org" (verified OK))
	by mollari.NetBSD.org (Postfix) with ESMTPS id F36D97A217
	for <gnats-bugs@gnats.NetBSD.org>; Mon, 27 Mar 2017 22:08:32 +0000 (UTC)
Message-Id: <201703272103.v2RL3nxW016865@andromeda.zia.io>
Date: Mon, 27 Mar 2017 21:03:49 GMT
From: john@ziaspace.com
Reply-To: john@ziaspace.com
To: gnats-bugs@NetBSD.org
Subject: lang/g95 fails to build on Ubuntu ppc64le
X-Send-Pr-Version: 3.95

>Number:         52116
>Category:       pkg
>Synopsis:       lang/g95 fails to build on Ubuntu ppc64le
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    linux-pkg-people
>State:          feedback
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Mar 27 22:10:00 +0000 2017
>Closed-Date:    
>Last-Modified:  Thu Oct 19 18:00:03 +0000 2017
>Originator:     John Klos
>Release:        Linux 4.4.0-64-generic
>Organization:

>Environment:


System: Linux ibm 4.4.0-64-generic #85-Ubuntu SMP Mon Feb 20 17:05:51 UTC 2017 ppc64le ppc64le ppc64le GNU/Linux
>Description:

lang/g95, as a prerequisite for math/py-numpy, fails on ppc64le GNU/Linux:
checking for .preinit_array/.init_array/.fini_array support... ../../libcpp/macro.c: In 
function '_cpp_builtin_macro_text':
../../libcpp/macro.c:219:20: warning: assignment from incompatible pointer type 
[-Wincompatible-pointer-types]
        pfile->date = U"\"??? ?? ????\"";
                    ^
../../libcpp/macro.c:220:20: warning: assignment from incompatible pointer type 
[-Wincompatible-pointer-types]
        pfile->time = U"\"??:??:??\"";
                    ^
../../libcpp/lex.c:42:3: warning: initialization from incompatible pointer type 
[-Wincompatible-pointer-types]
 { U"%:", U"%:%:", U"<:", U":>", U"<%", U"%>" };
   ^
../../libcpp/lex.c:42:3: note: (near initialization for 'digraph_spellings[0]')
../../libcpp/lex.c:42:10: warning: initialization from incompatible pointer type 
[-Wincompatible-pointer-types]
 { U"%:", U"%:%:", U"<:", U":>", U"<%", U"%>" };
          ^
../../libcpp/lex.c:42:10: note: (near initialization for 'digraph_spellings[1]')
../../libcpp/lex.c:42:19: warning: initialization from incompatible pointer type 
[-Wincompatible-pointer-types]
 { U"%:", U"%:%:", U"<:", U":>", U"<%", U"%>" };
                   ^
../../libcpp/lex.c:42:19: note: (near initialization for 'digraph_spellings[2]')
../../libcpp/lex.c:42:26: warning: initialization from incompatible pointer type 
[-Wincompatible-pointer-types]
 { U"%:", U"%:%:", U"<:", U":>", U"<%", U"%>" };
                          ^
../../libcpp/lex.c:42:26: note: (near initialization for 'digraph_spellings[3]')
../../libcpp/lex.c:42:33: warning: initialization from incompatible pointer type 
[-Wincompatible-pointer-types]
 { U"%:", U"%:%:", U"<:", U":>", U"<%", U"%>" };
                                 ^
../../libcpp/lex.c:42:33: note: (near initialization for 'digraph_spellings[4]')
../../libcpp/lex.c:42:40: warning: initialization from incompatible pointer type 
[-Wincompatible-pointer-types]
 { U"%:", U"%:%:", U"<:", U":>", U"<%", U"%>" };
                                        ^
../../libcpp/lex.c:42:40: note: (near initialization for 'digraph_spellings[5]')
../../libcpp/directives.c:196:18: warning: initialization from incompatible pointer type 
[-Wincompatible-pointer-types]
   do_linemarker, U"#", 1, KANDR, IN_I
                  ^
../../libcpp/directives.c:196:18: note: (near initialization for 'linemarker_dir.name')
../../libcpp/directives.c: In function 'parse_include':
../../libcpp/directives.c:693:6: warning: assignment from incompatible pointer type 
[-Wincompatible-pointer-types]
  dir = U"pragma dependency";
      ^
yes
checking if mkdir takes one argument... no
*** Configuration powerpc64le-debian-linux-gnu not supported
../../libcpp/traditional.c: In function '_cpp_scan_out_logical_line':
../../libcpp/traditional.c:330:14: warning: 'fmacro.argc' may be used uninitialized in 
this function [-Wmaybe-uninitialized]
   macro->argc++;
              ^
../../libcpp/traditional.c:349:20: note: 'fmacro.argc' was declared here
   struct fun_macro fmacro;
                    ^
../../libcpp/traditional.c:576:11: warning: 'fmacro.offset' may be used uninitialized in 
this function [-Wmaybe-uninitialized]
           + fmacro.offset);
           ^
../../libcpp/traditional.c:820:14: warning: 'fmacro.node' may be used uninitialized in 
this function [-Wmaybe-uninitialized]
   cpp_macro *macro = fmacro->node->value.macro;
              ^
../../libcpp/traditional.c:349:20: note: 'fmacro.node' was declared here
   struct fun_macro fmacro;
                    ^
../../libcpp/traditional.c:858:26: warning: 'fmacro.args' may be used uninitialized in 
this function [-Wmaybe-uninitialized]
    arglen = (fmacro->args[b->arg_index]
                          ^
../../libcpp/traditional.c:349:20: note: 'fmacro.args' was declared here
   struct fun_macro fmacro;
                    ^
Makefile:3857: recipe for target 'configure-gcc' failed
make[1]: *** [configure-gcc] Error 1
make[1]: *** Waiting for unfinished jobs....


>How-To-Repeat:

>Fix:


>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->linux-pkg-people
Responsible-Changed-By: leot@NetBSD.org
Responsible-Changed-When: Tue, 28 Mar 2017 07:42:37 +0000
Responsible-Changed-Why:
Linux problem


From: coypu@sdf.org
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/52116: lang/g95 fails to build on Ubuntu ppc64le
Date: Fri, 28 Apr 2017 14:03:45 +0000

 We are mostly suggesting PKGSRC_FORTRAN=gfortran for all these bugs and
 I feel like it would be better to make it a default. g95 is old and not
 worth the effort.

 g95 doesn't build on debian in general for some issues (there's a few
 bug reports for it).

 I would also try GFORTRAN_VERSION=6 because ppc64le is new so the
 default of gcc 4.8 may be too old.

 For completeness, the current log doesn't seem to mention the actual
 error, so hard to work with.

From: "Maya Rashish" <maya@netbsd.org>
To: gnats-bugs@gnats.NetBSD.org
Cc: 
Subject: PR/52116 CVS commit: pkgsrc/lang/g95
Date: Wed, 18 Oct 2017 09:38:23 +0000

 Module Name:	pkgsrc
 Committed By:	maya
 Date:		Wed Oct 18 09:38:23 UTC 2017

 Modified Files:
 	pkgsrc/lang/g95: Makefile

 Log Message:
 g95: fix build on linux
 force passing asprintf test which is incorrectly not found due to FORTIFY
 pass LIBRARY_PATH so crtn.o and crti.o are found on Ubuntu & friends

 Note many reporters need to install g++-multilib as a package to overcome
 the errors they reported in the bugs (missing <sys/cdefs.h>)

 PR pkg/51198, PR pkg/51690, PR pkg/52116


 To generate a diff of this commit:
 cvs rdiff -u -r1.28 -r1.29 pkgsrc/lang/g95/Makefile

 Please note that diffs are not public domain; they are subject to the
 copyright notices on the relevant files.

State-Changed-From-To: open->feedback
State-Changed-By: maya@NetBSD.org
State-Changed-When: Wed, 18 Oct 2017 09:49:30 +0000
State-Changed-Why:
Do you get further with the changes? now it builds on x86_64 at least.


From: "Benny Siegert" <bsiegert@netbsd.org>
To: gnats-bugs@gnats.NetBSD.org
Cc: 
Subject: PR/52116 CVS commit: [pkgsrc-2017Q3] pkgsrc/lang/g95
Date: Thu, 19 Oct 2017 17:56:46 +0000

 Module Name:	pkgsrc
 Committed By:	bsiegert
 Date:		Thu Oct 19 17:56:46 UTC 2017

 Modified Files:
 	pkgsrc/lang/g95 [pkgsrc-2017Q3]: Makefile

 Log Message:
 Pullup ticket #5583 - requested by maya
 lang/g95: Linux build fix

 Revisions pulled up:
 - lang/g95/Makefile                                             1.29

 ---
    Module Name:    pkgsrc
    Committed By:   maya
    Date:           Wed Oct 18 09:38:23 UTC 2017

    Modified Files:
            pkgsrc/lang/g95: Makefile

    Log Message:
    g95: fix build on linux
    force passing asprintf test which is incorrectly not found due to FORTIFY
    pass LIBRARY_PATH so crtn.o and crti.o are found on Ubuntu & friends

    Note many reporters need to install g++-multilib as a package to overcome
    the errors they reported in the bugs (missing <sys/cdefs.h>)

    PR pkg/51198, PR pkg/51690, PR pkg/52116


 To generate a diff of this commit:
 cvs rdiff -u -r1.28 -r1.28.6.1 pkgsrc/lang/g95/Makefile

 Please note that diffs are not public domain; they are subject to the
 copyright notices on the relevant files.

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.