NetBSD Problem Report #52739

From www@NetBSD.org  Mon Nov 20 02:27:32 2017
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id C34FF7A1CB
	for <gnats-bugs@gnats.NetBSD.org>; Mon, 20 Nov 2017 02:27:31 +0000 (UTC)
Message-Id: <20171120022731.047A67A1EA@mollari.NetBSD.org>
Date: Mon, 20 Nov 2017 02:27:30 +0000 (UTC)
From: lechapelaing@yahoo.fr
Reply-To: lechapelaing@yahoo.fr
To: gnats-bugs@NetBSD.org
Subject: sysutils/xfm crashes on start
X-Send-Pr-Version: www-1.0

>Number:         52739
>Category:       pkg
>Synopsis:       sysutils/xfm crashes on start
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Nov 20 02:30:00 +0000 2017
>Originator:     Germain Le Chapelain
>Release:        current
>Organization:
CGN
>Environment:
NetBSD germ 8.99.1 NetBSD 8.99.1 (GENERIC) #0: Wed Jul  5 22:24:56 UTC 2017  german@germ:/usr/obj/sys/arch/amd64/compile/GENERIC amd64
b
>Description:
sysutils/xfm crashes on start-up
>How-To-Repeat:
install xfm 
launch it
observe segmentation violation
>Fix:
I have been battling to build it with debug symbols but couldn't 

I tried adding CFLAGS+=-g CXXFLAGS+=-g but then the package doesn't build

The package uses IMAKE which makes it tricky for me to debug further

I can swear I had a workaround in the past and got xfm working

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2014 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.