NetBSD Problem Report #53162

From www@NetBSD.org  Fri Apr  6 17:10:33 2018
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 8008D7A174
	for <gnats-bugs@gnats.NetBSD.org>; Fri,  6 Apr 2018 17:10:33 +0000 (UTC)
Message-Id: <20180406171032.60E957A214@mollari.NetBSD.org>
Date: Fri,  6 Apr 2018 17:10:32 +0000 (UTC)
From: scole_mail@gmx.com
Reply-To: scole_mail@gmx.com
To: gnats-bugs@NetBSD.org
Subject: pkgtools/pkg_install fails to build on FreeBSD
X-Send-Pr-Version: www-1.0

>Number:         53162
>Category:       pkg
>Synopsis:       pkgtools/pkg_install fails to build on FreeBSD
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    joerg
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Apr 06 17:15:00 +0000 2018
>Last-Modified:  Fri Apr 06 20:33:05 +0000 2018
>Originator:     scole_mail
>Release:        pkgsrc-2018Q1
>Organization:
none
>Environment:
FreeBSD itan 10.1-RELEASE-p45 FreeBSD 10.1-RELEASE-p45 #0 r318965: Fri May 26 18:49:51 EDT 2017     root@itan:/usr/obj/usr/src/sys/GENERIC  ia64
>Description:
pkg_install fails to build on some (older?) versions of freebsd

  CC       libarchive/archive_write_set_passphrase.lo
  CC       libarchive/filter_fork_posix.lo
  CC       libarchive/xxhash.lo
  CC       libarchive/archive_disk_acl_freebsd.lo
libarchive/archive_disk_acl_freebsd.c:96: error: 'ACL_ENTRY_INHERITED' undeclared here (not in a function)
*** Error code 1

ACL_ENTRY_INHERITED looks like it was added after 10.2?
>How-To-Repeat:
cd .../pkgsrc/pkgtools/pkg_install && bmake
>Fix:
It looks like newer versions of libarchive have a fix for this

https://github.com/mmatuska/libarchive/commit/a21b93dbdb84e51ae490db89234123f595ec64cb

I'm not sure if the 2nd patch for
 libarchive/test/test_acl_platform_nfs4.c
is also required for pkgsrc.

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->joerg
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Fri, 06 Apr 2018 20:33:05 +0000
Responsible-Changed-Why:
Over to libarchive maintainer


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.43 2018/01/16 07:36:43 maya Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2017 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.