NetBSD Problem Report #53249

From www@NetBSD.org  Wed May  2 08:23:28 2018
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 6AE557A110
	for <gnats-bugs@gnats.NetBSD.org>; Wed,  2 May 2018 08:23:28 +0000 (UTC)
Message-Id: <20180502082327.8FE317A267@mollari.NetBSD.org>
Date: Wed,  2 May 2018 08:23:27 +0000 (UTC)
From: joern.clausen@uni-bielefeld.de
Reply-To: joern.clausen@uni-bielefeld.de
To: gnats-bugs@NetBSD.org
Subject: can't install x11/qt5-qtbase on NetBSD 7.1.1/amd64
X-Send-Pr-Version: www-1.0

>Number:         53249
>Notify-List:    maya@NetBSD.org
>Category:       pkg
>Synopsis:       can't install x11/qt5-qtbase on NetBSD 7.1.1/amd64
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    ryoon
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed May 02 08:25:00 +0000 2018
>Closed-Date:    
>Last-Modified:  Tue Jul 10 14:08:10 +0000 2018
>Originator:     Joern Clausen
>Release:        
>Organization:
University of Bielefeld
>Environment:
>Description:
Installing x11/qt5-qtbase on NetBSD 7.1.1/amd64 as new prerequisite for wireshark fails with

=> Checking file-check results for qt5-qtbase-5.10.1nb5
ERROR: ************************************************************
ERROR: The following files are in the PLIST but not in /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg:
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/include/QtKmsSupport/5.10.1/QtKmsSupport/private/qkmsdevice_p.h
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/include/QtKmsSupport/QtKmsSupport
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/include/QtKmsSupport/QtKmsSupportDepends
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/include/QtKmsSupport/QtKmsSupportVersion
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/include/QtKmsSupport/qtkmssupportversion.h
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/lib/libQt5KmsSupport.a
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/lib/libQt5KmsSupport.prl
ERROR:         /usr/pkgsrc/x11/qt5-qtbase/work/.destdir/usr/pkg/qt5/mkspecs/modules/qt_lib_kms_support_private.pri
*** Error code 1

>How-To-Repeat:

>Fix:

>Release-Note:

>Audit-Trail:
From: coypu@sdf.org
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/53249: can't install x11/qt5-qtbase on NetBSD 7.1.1/amd64
Date: Fri, 1 Jun 2018 13:04:00 +0000

 Looks like this is the configure check

         "drm": {
             "label": "KMS",
             "test": {
                 "include": [ "stdlib.h", "stdint.h" ],
                 "tail": [
                     "extern \"C\" {",
                     "#include <xf86drmMode.h>",
                     "#include <xf86drm.h>",
                     "}"
                 ],
                 "main": "(void) drmModeGetCrtc(0, 0);"
             },
             "sources": [
                 { "type": "pkgConfig", "args": "libdrm" },
                 { "libs": "-ldrm", "condition": "!config.integrity" },
                 { "libs": "-ldrm-nvdc -lposix -livfs -lnvll -lnvdc -lnvrm -lnvrm_graphics -lnvos -lnvtegrahv", "condition": "config.integrity" }
             ]
         },


 This is in
 WRKSRC/src/gui/configure.json

 I wonder if it fails as a standalone

 $ cat testx.c
 #include <xf86drmMode.h>
 #include <xf86drm.h>
 int main() {
 	(void) drmModeGetCrtc(0,0);
 }

 $ gcc `env PKG_CONFIG_PATH=/usr/X11R7/lib/pkgconfig pkgconf --cflags --libs libdrm` testx.c -o testx; ./testx


 Or are you using pkgsrc mesa with disabled dri (my fault..)?

From: Joern Clausen <joern.clausen@uni-bielefeld.de>
To: gnats-bugs@NetBSD.org, pkg-manager@NetBSD.org, gnats-admin@NetBSD.org,
 pkgsrc-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/53249: can't install x11/qt5-qtbase on NetBSD 7.1.1/amd64
Date: Fri, 01 Jun 2018 15:22:47 +0200

 On 06/01/18 15:05, coypu@sdf.org wrote:
 [..]
 >   I wonder if it fails as a standalone
 >   
 >   $ cat testx.c
 >   #include <xf86drmMode.h>
 >   #include <xf86drm.h>
 >   int main() {
 >   	(void) drmModeGetCrtc(0,0);
 >   }
 >   
 >   $ gcc `env PKG_CONFIG_PATH=/usr/X11R7/lib/pkgconfig pkgconf --cflags --libs libdrm` testx.c -o testx; ./testx

 That snippet works for me.

 >   Or are you using pkgsrc mesa with disabled dri (my fault..)?

 I don't see the connection :) but that is exactly the case. I need to 
 disable dri for MesaLib on Solaris and have done the same on NetBSD to 
 keep my configs in sync.

 In the meantime, I have removed the offending lines from PLIST and was 
 able to install this package both on NetBSD and Solaris.

 -- 
 Jörn Clausen
 Plattformen & Serverdienste
 BITS - Bielefelder IT-Servicezentrum

Responsible-Changed-From-To: pkg-manager->ryoon
Responsible-Changed-By: bsiegert@NetBSD.org
Responsible-Changed-When: Sun, 08 Jul 2018 10:41:51 +0000
Responsible-Changed-Why:
Over to maintainer.


State-Changed-From-To: open->feedback
State-Changed-By: bsiegert@NetBSD.org
State-Changed-When: Sun, 08 Jul 2018 10:41:51 +0000
State-Changed-Why:
Does this need any action from our side, or do you consider this fixed,
or a local problem?


From: Joern Clausen <joern.clausen@uni-bielefeld.de>
To: gnats-bugs@NetBSD.org, ryoon@NetBSD.org, pkg-manager@NetBSD.org,
 pkgsrc-bugs@NetBSD.org, gnats-admin@NetBSD.org, bsiegert@NetBSD.org
Cc: 
Subject: Re: pkg/53249 (can't install x11/qt5-qtbase on NetBSD 7.1.1/amd64)
Date: Mon, 09 Jul 2018 16:45:31 +0200

 I consider this neither fixed nor a local problem. I define

 PKG_OPTIONS.MesaLib = -dri

 in mk.conf, and according to @coypu, this triggers the observed 
 behavior. If nobody else uses this option *and* tries to install qt5, 
 you might call it a local problem, though...

 -- 
 Jörn Clausen
 Plattformen & Serverdienste
 BITS - Bielefelder IT-Servicezentrum

State-Changed-From-To: feedback->open
State-Changed-By: bsiegert@NetBSD.org
State-Changed-When: Tue, 10 Jul 2018 14:08:10 +0000
State-Changed-Why:
Feedback provided. Yes, this is still an issue.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.43 2018/01/16 07:36:43 maya Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2017 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.