NetBSD Problem Report #53702

From martin@aprisoft.de  Mon Nov  5 18:01:30 2018
Return-Path: <martin@aprisoft.de>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 519207A172
	for <gnats-bugs@gnats.NetBSD.org>; Mon,  5 Nov 2018 18:01:30 +0000 (UTC)
Message-Id: <20181105180122.1878A5CC8BB@emmas.aprisoft.de>
Date: Mon,  5 Nov 2018 19:01:22 +0100 (CET)
From: martin@NetBSD.org
Reply-To: martin@aprisoft.de
To: gnats-bugs@NetBSD.org
Subject: lang/nodejs is broken
X-Send-Pr-Version: 3.95

>Number:         53702
>Category:       pkg
>Synopsis:       lang/nodejs is broken
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    fhajny
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Nov 05 18:05:00 +0000 2018
>Closed-Date:    
>Last-Modified:  Fri Sep 13 06:30:01 +0000 2019
>Originator:     Martin Husemann
>Release:        NetBSD 8.99.25
>Organization:
The NetBSD Foundation, Inc.
>Environment:
System: NetBSD whoever-brings-the-night.aprisoft.de 8.99.25 NetBSD 8.99.25 (WHOEVER) #239: Mon Oct 15 14:52:51 CEST 2018 martin@seven-days-to-the-wolves.aprisoft.de:/work/src/sys/arch/sparc64/compile/WHOEVER sparc64
Architecture: sparc64
Machine: sparc64
>Description:

Trying to build lang/nodejs fails, it tries to use absolutely stupid
compiler flags on sparc64:

	-mfpmath=sse
	-mmmx
	-m32

>How-To-Repeat:

Just try to build it.

>Fix:
n/a

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->filip
Responsible-Changed-By: bsiegert@NetBSD.org
Responsible-Changed-When: Mon, 05 Nov 2018 18:33:24 +0000
Responsible-Changed-Why:
Over to maintainer.


Responsible-Changed-From-To: filip->fhajny
Responsible-Changed-By: maya@NetBSD.org
Responsible-Changed-When: Mon, 05 Nov 2018 18:38:13 +0000
Responsible-Changed-Why:
Correct login name.


From: Martin Husemann <martin@duskware.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/53702 (lang/nodejs is broken)
Date: Tue, 6 Nov 2018 09:37:14 +0100

 It looks like there is no support for any sparc* at all in the source,
 but I might be missing something, the configure/build system is unparsable
 for me.

 Martin

From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
To: gnats-bugs@netbsd.org
Cc: tsutsui@ceres.dti.ne.jp
Subject: Re: pkg/53702: lang/nodejs is broken
Date: Sat, 23 Mar 2019 22:12:25 +0900

 Note currently nodejs-*/deps/openssl/config/arch/linux-elf seems used
 if there is no platform specific config exists, but it includes
 x86 linux settings ("-DL_ENDIAN", b32 -> "1" etc.) as its name.

 I tried to prepare "BSD-x86" configuration under
 nodejs-*/deps/openssl/config/arch:
  https://gist.githubusercontent.com/tsutsui/54a7e332a547f853f6d0eee3f27c593e/raw/9190146b49b8d3b021319f2cffc7700d4862325f/pkgsrc-lang-nodejs-i386_fixes.diff

 and it seems working even with no-asm settings.

 Maybe it's possible to prepare
 nodejs-*/deps/openssl/config/arch/BSD-sparc/no-asm
 (and other NetBSD MACHINE_ARCH) with
 "CONFIGURE_ARGS+=	--openssl-no-asm"
 as FreeBSD ports does:
  https://svnweb.freebsd.org/ports/head/www/node/Makefile?revision=495854&view=markup
 ---
 77 	.if ${PORT_OPTIONS:MBUNDLED_SSL} && ${ARCH} != amd64 && ${ARCH} != i386
 78 	CONFIGURE_ARGS+=--openssl-no-asm
 79 	.endif
 ---

 ---
 Izumi Tsutsui

State-Changed-From-To: open->feedback
State-Changed-By: maya@NetBSD.org
State-Changed-When: Sat, 07 Sep 2019 12:35:26 +0000
State-Changed-Why:
is this still a problem with nodejs after tsutsui's changes?
also, we can likely use base openssl on netbsd.


From: Martin Husemann <martin@duskware.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/53702: lang/nodejs is broken
Date: Mon, 9 Sep 2019 09:23:39 +0200

 Will test, but it will take like a week or so.

 Martin

State-Changed-From-To: feedback->open
State-Changed-By: martin@NetBSD.org
State-Changed-When: Thu, 12 Sep 2019 14:33:25 +0000
State-Changed-Why:
Tested, still failing


From: Martin Husemann <martin@duskware.de>
To: gnats-bugs@NetBSD.org
Cc: 
Subject: Re: pkg/53702: lang/nodejs is broken
Date: Thu, 12 Sep 2019 16:32:21 +0200

 Still fails for me:

   c++ -o /usr/pkgobj/lang/nodejs/work/node-v10.16.3/out/Release/obj.host/v8_libbase/deps/v8/src/base/division-by-constant.o ../deps/v8/src/base/division-by-constant.cc '-DV8_GYP_BUILD' '-DV8_TYPED_ARRAY_MAX_SIZE_IN_HEAP=0' '-DV8_TARGET_ARCH_IA32' '-DV8_EMBEDDER_STRING="-node.54"' '-DENABLE_DISASSEMBLER' '-DV8_PROMISE_INTERNAL_FIELD_COUNT=1' '-DV8_INTL_SUPPORT' '-DV8_CONCURRENT_MARKING' '-DDISABLE_UNTRUSTED_CODE_MITIGATIONS' -I/usr/pkg/include -I../deps/v8  -Wno-type-limits -pthread -Wall -Wextra -Wno-unused-parameter -m32 -msse2 -mfpmath=sse -mmmx -fno-strict-aliasing -I/usr/pkg/include -m32 -fdata-sections -ffunction-sections -O3 -O3 -fno-omit-frame-pointer -fno-rtti -fno-exceptions -std=gnu++1y -MMD -MF /usr/pkgobj/lang/nodejs/work/node-v10.16.3/out/Release/.deps//usr/pkgobj/lang/nodejs/work/node-v10.16.3/out/Release/obj.host/v8_libbase/deps/v8/src/base/division-by-constant.o.d.raw   -c
 g++: error: unrecognized command line option '-msse2'
 g++: error: unrecognized command line option '-mfpmath=sse'
 g++: error: unrecognized command line option '-mmmx'
 gmake[1]: *** [deps/v8/gypfiles/v8_libbase.host.mk:139: /usr/pkgobj/lang/nodejs/work/node-v10.16.3/out/Release/obj.host/v8_libbase/deps/v8/src/base/division-by-constant.o] Error 1
 gmake[1]: *** Waiting for unfinished jobs....


 Do I need to set something special?

 Martin

From: coypu@sdf.org
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/53702: lang/nodejs is broken\
Date: Fri, 13 Sep 2019 06:29:42 +0000

 We should just disable the OpenSSL option for netbsd 9.x.
 # nodejs 10.x requires OpenSSL 1.1.x. Use embedded source until we have such.

 Since netbsd does ship OpenSSL 1.1.x, this isn't a problem we have.

>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.43 2018/01/16 07:36:43 maya Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2017 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.