NetBSD Problem Report #53750

From www@NetBSD.org  Wed Nov 28 14:33:30 2018
Return-Path: <www@NetBSD.org>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id CF1477A19F
	for <gnats-bugs@gnats.NetBSD.org>; Wed, 28 Nov 2018 14:33:30 +0000 (UTC)
Message-Id: <20181128143329.8C1BE7A26F@mollari.NetBSD.org>
Date: Wed, 28 Nov 2018 14:33:29 +0000 (UTC)
From: rnestor@tx.rr.com
Reply-To: rnestor@tx.rr.com
To: gnats-bugs@NetBSD.org
Subject: virt-manager build fails with error in use of pod2man
X-Send-Pr-Version: www-1.0

>Number:         53750
>Category:       pkg
>Synopsis:       virt-manager build fails with error in use of pod2man
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    gls
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Nov 28 14:35:00 +0000 2018
>Last-Modified:  Thu Nov 29 07:36:24 +0000 2018
>Originator:     Robert Nestor
>Release:        pkgsrc-2017Q4 pkgsrc-2018Q1 pkgsrc-2018Q3 pkgsrc
>Organization:
Company name
>Environment:
NetBSD bandit 8.0 NetBSD 8.0 (GENERIC) #0: Tue Jul 17 14:59:51 UTC 2018  mkrepro@mkrepro.NetBSD.org:/usr/src/sys/arch/amd64/compile/GENERIC amd64
>Description:
The build of virt-manager has failed on a number of pkgsrc releases due to an error in its use of pod2man to generate a man page. The error reported is that pod2man requires a non-null string in its "release" argument, however the man page for pod2man specifically states that a null string is valid and will cause it to use a system default value.  In the absence of a "release" argument it states it will use the release value for the underlying python it uses.  So it would appear the error here is actually in pod2man, but a simple fix is to just remove the "release" argument in the build of virt-manager.
>How-To-Repeat:
Attempt building virt-manager in any of the last 4 or 5 pkgsrc releases.
>Fix:
Although this doesn't fix the actual problem of fixing pod2man to make the code conform to its man page, this does allow virt-manager to build on any of the last 4 or 5 pkgsrc releases. These 2 patches were made and tested on the pkgsrc-2017Q4 and pkgsrc-2018Q3 releases to the files in the virt-manager-0.9.4/man directory. (Sorry, can't figure out how to produce the full patch set using "cvs diff" on a pkgsrc release - it always seems to want to diff against -current.)

% diff -bu Makefile.am.orig Makefile.am
--- Makefile.am.orig    2012-07-29 15:20:46.000000000 -0500
+++ Makefile.am 2018-11-28 08:25:46.587530432 -0600
@@ -4,6 +4,6 @@
 EXTRA_DIST = virt-manager.pod

 %.1: %.pod
-       pod2man --release="" --center="Virtual Machine Manager" $< > $@
+       pod2man --center="Virtual Machine Manager" $< > $@

% diff -bu Makefile.in.orig Makefile.in
--- Makefile.in.orig    2012-07-29 15:28:51.000000000 -0500
+++ Makefile.in 2018-11-28 08:25:46.598877712 -0600
@@ -449,7 +449,7 @@


 %.1: %.pod
-       pod2man --release="" --center="Virtual Machine Manager" $< > $@
+       pod2man --center="Virtual Machine Manager" $< > $@

 # Tell versions [3.59,3.63) of GNU make to not export all variables.
 # Otherwise a system limit (for SysV at least) may be exceeded. CLEANFILES = virt-manager.1

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->gls
Responsible-Changed-By: leot@NetBSD.org
Responsible-Changed-When: Thu, 29 Nov 2018 07:36:24 +0000
Responsible-Changed-Why:
Guillaume, can you please give it a look?
(over to MAINTAINER)


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.43 2018/01/16 07:36:43 maya Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2017 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.