NetBSD Problem Report #53951

From root@lyrion.ch  Wed Feb  6 08:50:11 2019
Return-Path: <root@lyrion.ch>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 4BF2E7A169
	for <gnats-bugs@gnats.NetBSD.org>; Wed,  6 Feb 2019 08:50:11 +0000 (UTC)
Message-Id: <20190206085005.A8B4721AFE66@lyrion.ch>
Date: Wed,  6 Feb 2019 09:50:05 +0100 (CET)
From: "Daniel Ziltener" <dziltener@lyrion.ch>
Reply-To: "Daniel Ziltener" <dziltener@lyrion.ch>
To: gnats-bugs@NetBSD.org
Subject: Syncthing update
X-Send-Pr-Version: 3.95

>Number:         53951
>Category:       pkg
>Synopsis:       Updates Syncthing to the current version
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    gdt
>State:          feedback
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Wed Feb 06 08:55:00 +0000 2019
>Closed-Date:    
>Last-Modified:  Thu Feb 14 14:20:01 +0000 2019
>Originator:     "Daniel Ziltener" <dziltener@lyrion.ch>
>Release:        NetBSD 8.0
>Organization:

>Environment:


System: NetBSD lyrion.ch 8.0 NetBSD 8.0 (GENERIC) #0: Tue Jul 17 14:59:51 UTC 2018 mkrepro@mkrepro.NetBSD.org:/usr/src/sys/arch/amd64/compile/GENERIC amd64
Architecture: x86_64
Machine: amd64
>Description:

        The Syncthing version in pkgsrc is outdated. This patch fixes this.
>How-To-Repeat:
>Fix:

	diff -ENwbur /usr/pkgsrc/net/syncthing/Makefile /usr/pkgsrc/net/syncthing/Makefile
	--- /usr/pkgsrc/net/syncthing/Makefile	2019-02-06 09:29:24.601539771 +0100
	+++ /usr/pkgsrc/net/syncthing/Makefile	2019-02-06 09:29:03.343411651 +0100
	@@ -13,7 +13,7 @@
	 # Note that the android versioning is disconnected from syncthing versioning;
	 # see https://github.com/syncthing/syncthing-android/issues/652 for
	 # a fuller explanation.
	-DISTNAME=	syncthing-0.14.54
	+DISTNAME=	syncthing-1.0.1
	 PKGREVISION=	1
	 CATEGORIES=	net
	 MASTER_SITES=	${MASTER_SITE_GITHUB:=syncthing/}
	@@ -53,7 +53,7 @@
	 SUBST_SED.go+=		-e 's|go run|"${GO}" run|'

	 do-build:
	-	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GO} run build.go build syncthing
	+	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GO} run build.go -no-upgrade build syncthing

	 # Binaries other than syncthing proper should perhaps be installed.
	 do-install:
	diff -ENwbur /usr/pkgsrc/net/syncthing/distinfo /usr/pkgsrc/net/syncthing/distinfo
	--- /usr/pkgsrc/net/syncthing/distinfo	2019-02-06 09:29:24.602089382 +0100
	+++ /usr/pkgsrc/net/syncthing/distinfo	2019-02-06 09:30:15.501014646 +0100
	@@ -1,7 +1,6 @@
	 $NetBSD: distinfo,v 1.65 2018/12/06 07:09:07 wiz Exp $

	-SHA1 (syncthing-0.14.54.tar.gz) = 0da0057c920d6382781435b6a1b091db0bbe1000
	-RMD160 (syncthing-0.14.54.tar.gz) = 5497738b8f293504e4e52924c7cf623c4d87396b
	-SHA512 (syncthing-0.14.54.tar.gz) = 979a4099e188d213d21b1b7b2a2baea7e7c65bda403713245f1d1c0f3fafd935c0697ea0283b77284e8e24325088e43756814c9ae24bbebb3526f91235e9ae82
	-Size (syncthing-0.14.54.tar.gz) = 10609474 bytes
	-SHA1 (patch-build.go) = 9fc31a4bcb251e299b671903f540839f45a9bf32
	+SHA1 (syncthing-1.0.1.tar.gz) = 2588cf71e6b1a4a3469a736087e2684d389a2646
	+RMD160 (syncthing-1.0.1.tar.gz) = 0b5b784ba883479068fcf0f79b56f27b42f865aa
	+SHA512 (syncthing-1.0.1.tar.gz) = 7f9fd48e00fae2f0913eb9eeddadaad1d5d7559164a24020706e70411f8ec43420192c4c9422699be6faa1641a382d5b8627038ca9a5dad38ee0e189970efbb7
	+Size (syncthing-1.0.1.tar.gz) = 7114455 bytes
	diff -ENwbur /usr/pkgsrc/net/syncthing/patches/CVS/Entries /usr/pkgsrc/net/syncthing/patches/CVS/Entries
	--- /usr/pkgsrc/net/syncthing/patches/CVS/Entries	2019-02-06 09:29:24.781066491 +0100
	+++ /usr/pkgsrc/net/syncthing/patches/CVS/Entries	2019-02-06 09:27:05.116574041 +0100
	@@ -1,2 +1,2 @@
	-/patch-build.go/1.1/Wed Feb  6 08:29:24 2019//Tpkgsrc-2018Q4
	+/patch-build.go/1.1/Mon Feb  4 13:03:35 2019//Tpkgsrc-2018Q4
	 D
	diff -ENwbur /usr/pkgsrc/net/syncthing/patches/patch-build.go /usr/pkgsrc/net/syncthing/patches/patch-build.go
	--- /usr/pkgsrc/net/syncthing/patches/patch-build.go	2019-02-06 09:29:24.779941946 +0100
	+++ /usr/pkgsrc/net/syncthing/patches/patch-build.go	1970-01-01 01:00:00.000000000 +0100
	@@ -1,19 +0,0 @@
	-$NetBSD: patch-build.go,v 1.1 2018/08/29 13:27:40 tnn Exp $
	-
	-Without this I get:
	-
	-open /usr/pkg/go/pkg/netbsd_amd64/runtime/cgo.a: permission denied
	-
	-when building as non-root.
	-
	---- build.go.orig	2018-07-10 15:40:06.000000000 +0000
	-+++ build.go
	-@@ -440,7 +440,7 @@ func build(target target, tags []string)
	- 
	- 	rmr(target.BinaryName())
	- 
	--	args := []string{"build", "-i", "-v"}
	-+	args := []string{"build", "-v"}
	- 	args = appendParameters(args, tags, target)
	- 
	- 	os.Setenv("GOOS", goos)

>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->gdt
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Wed, 06 Feb 2019 09:35:37 +0000
Responsible-Changed-Why:
over to maintainer


State-Changed-From-To: open->feedback
State-Changed-By: wiz@NetBSD.org
State-Changed-When: Wed, 06 Feb 2019 09:35:37 +0000
State-Changed-Why:
The pkgsrc version is 1.0.0, the diff is against 0.14.54.
Can you please send a diff against the latest version?
Can you please comment on your changes? (-no-upgrade, removal of a patch)
Thanks.


From: Daniel Ziltener <dziltener@lyrion.ch>
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/53951 (Updates Syncthing to the current version)
Date: Thu, 14 Feb 2019 15:16:31 +0100

 Am Mittwoch, 6. Februar 2019, 10:35:37 CET schrieben Sie:
 > Synopsis: Updates Syncthing to the current version
 > 
 > Responsible-Changed-From-To: pkg-manager->gdt
 > Responsible-Changed-By: wiz@NetBSD.org
 > Responsible-Changed-When: Wed, 06 Feb 2019 09:35:37 +0000
 > Responsible-Changed-Why:
 > over to maintainer
 > 
 > 
 > State-Changed-From-To: open->feedback
 > State-Changed-By: wiz@NetBSD.org
 > State-Changed-When: Wed, 06 Feb 2019 09:35:37 +0000
 > State-Changed-Why:
 > The pkgsrc version is 1.0.0, the diff is against 0.14.54.
 > Can you please send a diff against the latest version?
 > Can you please comment on your changes? (-no-upgrade, removal of a patch)
 > Thanks.

 Ah, yes, I mistakenly still had the old ports tree. I removed the patch 
 because it was neither compatible nor needed anymore, and I added "-no-
 upgrade" since this removes the update function from the web gui - which 
 doesn't work, since it's supposed to be handled by pkgsrc anyway. Other 
 platforms like e.g. OpenSUSE also have this flag set.


>Unformatted:

 It builds as non-root for me.  Given the path in your comment, it
 looks like your go infrastructure is old.  Please ensure that all
 packages on your system are update to match pkgsrc-current, or at
 least that behavior in question would be unchanged if they were.

 It's probably best to either post on pkgsrc-users or file a new PR
 with specific issues relative to pkgsrc-current.  Note that as of now,
 pkgsrc has 1.0.1, so the update part is done.

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.43 2018/01/16 07:36:43 maya Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2017 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.