NetBSD Problem Report #56665

From www@netbsd.org  Mon Jan 24 08:43:53 2022
Return-Path: <www@netbsd.org>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 943001A923D
	for <gnats-bugs@gnats.NetBSD.org>; Mon, 24 Jan 2022 08:43:53 +0000 (UTC)
Message-Id: <20220124084352.3E7481A923E@mollari.NetBSD.org>
Date: Mon, 24 Jan 2022 08:43:52 +0000 (UTC)
From: youremailsarecrap@gmail.com
Reply-To: youremailsarecrap@gmail.com
To: gnats-bugs@NetBSD.org
Subject: BISON_REQD has no effect
X-Send-Pr-Version: www-1.0

>Number:         56665
>Category:       pkg
>Synopsis:       BISON_REQD has no effect
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          feedback
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jan 24 08:45:00 +0000 2022
>Closed-Date:    
>Last-Modified:  Sun May 15 04:42:37 +0000 2022
>Originator:     Niclas Rosenvik
>Release:        pkgsrc-current from 2022 jan 5
>Organization:
>Environment:
NetBSD localhost 9.2 NetBSD 9.2 (CAN_KERNEL) #0: Mon Dec 13 17:36:42 CET 2021  niclas@localhost:/usr/src/sys/arch/amd64/compile/CAN_KERNEL amd64
>Description:
When creating a package that uses bison as a tool with USE_TOOLS+=bison
and BISON_REQD=3.0 pkgsrc outputs the line:
=> Tool dependency bison>=1.0: found bison-3.8.2

When setting GMAKE_REQD=3.0 for gmake the output is
=> Tool dependency gmake>=3.0: found gmake-4.3

This is as it should be.
BISON_REQD can even be set to 4.0 a version newer than the one released and used in pkgsrc and the the build just continues with the same output line as above. My conclusion is that BISON_REQD has no effect and that something is wrong in pkgsrc/mk/tools/bison.mk .
>How-To-Repeat:
Do the steps in the full description.
>Fix:


>Release-Note:

>Audit-Trail:
From: David Holland <dholland-pbugs@netbsd.org>
To: gnats-bugs@netbsd.org
Cc: 
Subject: Re: pkg/56665: BISON_REQD has no effect
Date: Thu, 21 Apr 2022 03:10:55 +0000

 On Mon, Jan 24, 2022 at 08:45:00AM +0000, youremailsarecrap@gmail.com wrote:
                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^
 o_O

  > When creating a package that uses bison as a tool with USE_TOOLS+=bison
  > and BISON_REQD=3.0 pkgsrc outputs the line:
  > => Tool dependency bison>=1.0: found bison-3.8.2

 Given that bison.mk sets
    BISON_REQD?=            1.875
 probably something else is clobbering it.

 That doesn't appear to be anything in pkgsrc; there's no such
 reference to it in mk/ and only one package sets it itself, and that
 to 3.3.

 Check your mk.conf and other local bits I guess?

 -- 
 David A. Holland
 dholland@netbsd.org

State-Changed-From-To: open->feedback
State-Changed-By: dholland@NetBSD.org
State-Changed-When: Sun, 15 May 2022 04:42:37 +0000
State-Changed-Why:
A suggestion was made.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.46 2020/01/03 16:35:01 leot Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2020 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.