NetBSD Problem Report #19348

Received: (qmail 26205 invoked by uid 605); 11 Dec 2002 15:20:14 -0000
Message-Id: <20021211152011.E99D110596@home.mewburn.net>
Date: Thu, 12 Dec 2002 02:20:11 +1100 (EST)
From: lukem@netbsd.org
Sender: gnats-bugs-owner@netbsd.org
Reply-To: lukem@netbsd.org
To: gnats-bugs@gnats.netbsd.org
Subject: profiling doesn't work with USETOOLS=yes
X-Send-Pr-Version: 3.95

>Number:         19348
>Category:       bin
>Synopsis:       profiling doesn't work with USETOOLS=yes
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Dec 11 15:21:00 +0000 2002
>Closed-Date:    
>Last-Modified:  
>Originator:     Luke Mewburn
>Release:        NetBSD 1.6_STABLE
>Organization:
>Environment:
System: NetBSD argo.mewburn.net 1.6_STABLE NetBSD 1.6_STABLE (ARGO from GENERIC-$Revision: 1.491.4.2 $) #0: Sun Oct 13 18:45:29 EST 2002 lukem@argo.mewburn.net:/var/scratch/obj.i386/usr/src/sys/arch/i386/compile/ARGO i386
Architecture: i386
Machine: i386
>Description:
	Programs compiled with '-pg' with USETOOLS=yes don't
	generate the gmon.out profiling file (c.f, gprof(1)).

>How-To-Repeat:
	Add
		COPTS+=-pg
		LDFLAGS+=-pg
	and make a program with USETOOLS=yes (the default).
	Run it.  Notice that gmon.out isn't created/updated.

	Rebuild with "USETOOLS=no" and notice that gmon.out is
	created.

>Fix:
	Probably something to do with selecting gcrt0.o instead of
	crt0.o when USETOOLS=yes overrides the linker stuff.
>Release-Note:
>Audit-Trail:
>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.