NetBSD Problem Report #28150

From www@www.netbsd.org  Wed Nov 10 05:13:35 2004
Return-Path: <www@www.netbsd.org>
Received: by narn.netbsd.org (Postfix, from userid 31301)
	id 6B87225217E; Wed, 10 Nov 2004 05:13:35 +0000 (UTC)
Message-Id: <20041110051335.6B87225217E@narn.netbsd.org>
Date: Wed, 10 Nov 2004 05:13:35 +0000 (UTC)
From: rquinn@sec.sprint.net
Reply-To: rquinn@sec.sprint.net
To: gnats-bugs@gnats.NetBSD.org
Subject: emuxki hangs when trying to play music
X-Send-Pr-Version: www-1.0

>Number:         28150
>Category:       port-i386
>Synopsis:       emuxki hangs when trying to play music
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    port-i386-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Nov 10 05:14:01 +0000 2004
>Last-Modified:  Wed Mar 30 15:47:00 +0000 2005
>Originator:     Rob Quinn
>Release:        NetBSD-current as of 9 Nov 2004
>Organization:
>Environment:
NetBSD spiral.example.com 2.99.10 NetBSD 2.99.10 (SPIRAL) #211: Tue Nov  9 05:37:32 EST 2004  root@spiral.example.com:/usr/obj/SPIRAL i386

>Description:
 I can't play MP3s/oggs/etc on my Dell's emuxki card.  The applications
seem to hang in aud_dr or aud_wr.  Once hung the applications take
a while to exit from control-C or control-\.
 My computer is about a year old. Until around June (I think) this card
wasn't recognized.  Now:

%dmesg | egrep 'emuxki|audio|irq 3'
emuxki0 at pci2 dev 2 function 0: Creative Labs SBLive! EMU 10000 (audio multimedia)
emuxki0: ac97: SigmaTel STAC9708 codec; 18 bit DAC, 18 bit ADC, SigmaTel 3D
emuxki0: ac97: ext id 80<SDAC>
audio0 at emuxki0: full duplex, mmap, independent
emuxki0: interrupting at irq 3



#mixerctl -a
outputs.master=127,127
outputs.master.mute=off
outputs.mono=255
outputs.mono.mute=on
outputs.mono.source=mixerout
outputs.surround=127,127
outputs.surround.mute=off
inputs.speaker=255
inputs.speaker.mute=off
inputs.phone=191
inputs.phone.mute=on
inputs.mic=191
inputs.mic.mute=on
inputs.mic.preamp=off
inputs.mic.source=mic0
inputs.line=191,191
inputs.line.mute=off
inputs.cd=191,191
inputs.cd.mute=off
inputs.video=191,191
inputs.video.mute=off
inputs.aux=191,191
inputs.aux.mute=off
inputs.dac=191,191
inputs.dac.mute=off
record.source=mic
record.volume=0,0
record.volume.mute=off
outputs.spatial=off
outputs.spatial.center=0
outputs.spatial.depth=0


#audioctl -a
name=SB Live!
version=0x00
config=emuxki
encodings=ulinear:8,mulaw:8*,alaw:8*,slinear:8*,slinear_le:16,ulinear_le:16*,slinear_be:16*,ulinear_be:16*
properties=full_duplex,mmap,independent
full_duplex=0
fullduplex=0
blocksize=4096
hiwat=16
lowat=12
monitor_gain=0
mode=play
play.rate=44100
play.channels=2
play.precision=16
play.encoding=slinear_le
play.gain=127
play.balance=32
play.port=0x0
play.avail_ports=0x0
play.seek=65536
play.samples=0
play.eof=0
play.pause=0
play.error=0
play.waiting=0
play.open=1
play.active=1
play.buffer_size=65536
record.rate=44100
record.channels=2
record.precision=16
record.encoding=slinear_le
record.gain=0
record.balance=32
record.port=0x1
record.avail_ports=0x7
record.seek=0
record.samples=0
record.eof=0
record.pause=0
record.error=0
record.waiting=0
record.open=0
record.active=0
record.buffer_size=65536
record.errors=0

>How-To-Repeat:
spiral:~/music/Natalie Merchant/The House Carpenter's Daughter %ogg123 01.Sally_Ann.ogg

Audio Device:   OSS audio driver output 

Playing: 01.Sally_Ann.ogg
Ogg Vorbis stream: 2 channel, 44100 Hz
Artist: Natalie Merchant
Album: The House Carpenter's Daughter
Title: Sally Ann
Date: 2003
Genre: Folk
Track number: 01
Time: 00:00.30 [05:47.72] of 05:48.03  (  0.3 kbps)  Output Buffer  62.5%  

  It never progresses beyond there.  Control-T shows:

load: 0.13  cmd: ogg123 22577 [sawait aud_wr] 0.03u 0.00s 0% 2536k
load: 0.13  cmd: ogg123 22577 [sawait aud_wr] 0.03u 0.00s 0% 2536k


^C
load: 0.14  cmd: ogg123 22577 [sawait aud_wr] 0.03u 0.00s 0% 2536k
^C^C^C
load: 0.14  cmd: ogg123 22577 [sawait aud_wr] 0.03u 0.00s 0% 2536k
^\^\^\
load: 0.13  cmd: ogg123 22577 [aud_dr] 0.02u 0.16s 0% 47444k

>Fix:
Any advice is appreciated.
>Audit-Trail:
From: Rob Quinn <rquinn@sec.sprint.net>
To: gnats-admin@NetBSD.org
Cc: 
Subject: Re: port-i386/28150: emuxki hangs when trying to play music
Date: Thu, 10 Mar 2005 13:33:58 -0500

   I recently hooked up 5 speakers for surround sound under Windows, and when I
 rebooted into NetBSD the middle speaker had an annoying tone on it.  According
 to the SBLive web site the plug for the middle speaker is software switchable
 between digital out and analog out.  I think NetBSD is getting this wrong, or
 not selecting the right output mode at all.

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.39 2013/11/01 18:47:49 spz Exp $
$NetBSD: gnats_config.sh,v 1.8 2006/05/07 09:23:38 tsutsui Exp $
Copyright © 1994-2007 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.