NetBSD Problem Report #53331

From john@hlin.zia.io  Tue May 29 21:14:03 2018
Return-Path: <john@hlin.zia.io>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 815B87A183
	for <gnats-bugs@gnats.NetBSD.org>; Tue, 29 May 2018 21:14:03 +0000 (UTC)
Message-Id: <201805292113.w4TLDlNx002232@hlin.zia.io>
Date: Tue, 29 May 2018 21:13:47 GMT
From: john@ziaspace.com
Reply-To: john@ziaspace.com
To: gnats-bugs@NetBSD.org
Subject: lang/nodejs fails to build on NetBSD/evbarm
X-Send-Pr-Version: 3.95

>Number:         53331
>Category:       pkg
>Synopsis:       lang/nodejs fails to build on NetBSD/evbarm
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          feedback
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue May 29 21:15:00 +0000 2018
>Closed-Date:    
>Last-Modified:  Wed May 27 19:39:57 +0000 2020
>Originator:     John Klos
>Release:        NetBSD 8.0_BETA
>Organization:

>Environment:


System: NetBSD hlin.zia.io 8.0_BETA NetBSD 8.0_BETA (HLIN) #0: Mon Jan 29 15:54:47 UTC 2018 john@hlin.zia.io:/usr/obj-evbarm/sys/arch/evbarm/compile/HLIN evbarm
Architecture: earmv7hf
Machine: evbarm
>Description:

Attempting to build lang/nodejs from today's pkgsrc on NetBSD-8 running
on evbarm results in this failure:

  gcc '-DOPENSSL_NO_HW' '-DDSO_DLFCN' '-DHAVE_DLFCN_H' '-DNDEBUG' '-DOPENSSL_THREADS' 
'-DOPENSSL_NO_DYNAMIC_ENGINE' '-DOPENSSL_PIC' '-DOPENSSL_IA32_SSE2' '-DOPENSSL_BN_ASM_MONT' 
'-DOPENSSL_BN_ASM_MONT5' '-DOPENSSL_BN_ASM_GF2m' '-DSHA1_ASM' '-DSHA256_ASM' '-DSHA512_ASM' 
'-DRC4_ASM' '-DMD5_ASM' '-DAES_ASM' '-DVPAES_ASM' '-DBSAES_ASM' '-DGHASH_ASM' 
'-DECP_NISTZ256_ASM' '-DPADLOCK_ASM' '-DPOLY1305_ASM' '-DOPENSSLDIR="/etc/ssl"' 
'-DENGINESDIR="/dev/null"' '-DTERMIOS' -I/usr/local/include -I../deps/openssl/openssl 
-I../deps/openssl/openssl/include -I../deps/openssl/openssl/crypto 
-I../deps/openssl/openssl/crypto/include -I../deps/openssl/openssl/crypto/modes 
-I../deps/openssl/config -I../deps/openssl/config/archs/linux-x86_64/asm 
-I../deps/openssl/config/archs/linux-x86_64/asm/include 
-I../deps/openssl/config/archs/linux-x86_64/asm/crypto 
-I../deps/openssl/config/archs/linux-x86_64/asm/crypto/include/internal  -pthread -Wall 
-Wextra -Wno-unused-parameter -Wall -O3 -pthread -m64 -DL_ENDIAN 
-Wno-missing-field-initializers -Wno-old-style-declaration -O3 -fno-omit-frame-pointer  -MMD 
-MF 
/usr/pkgsrc/lang/nodejs/work/node-v10.2.1/out/Release/.deps//usr/pkgsrc/lang/nodejs/work/node-v10.2.1/out/Release/obj.target/openssl/deps/openssl/openssl/ssl/bio_ssl.o.d.raw 
-I/usr/include -I/usr/local/include -O2 -D_FORTIFY_SOURCE=2 -pthread -I/usr/include 
-I/usr/local/include -c -o 
/usr/pkgsrc/lang/nodejs/work/node-v10.2.1/out/Release/obj.target/openssl/deps/openssl/openssl/ssl/bio_ssl.o 
../deps/openssl/openssl/ssl/bio_ssl.c
gcc: error: unrecognized command line option '-m64'
deps/openssl/openssl.target.mk:807: recipe for target 
'/usr/pkgsrc/lang/nodejs/work/node-v10.2.1/out/Release/obj.target/openssl/deps/openssl/openssl/ssl/bio_ssl.o' 
failed

>How-To-Repeat:

>Fix:


>Release-Note:

>Audit-Trail:

Responsible-Changed-From-To: pkg-manager->filip
Responsible-Changed-By: bsiegert@NetBSD.org
Responsible-Changed-When: Sun, 08 Jul 2018 10:27:57 +0000
Responsible-Changed-Why:
Over to maintainer.


Responsible-Changed-From-To: filip->fhajny
Responsible-Changed-By: maya@NetBSD.org
Responsible-Changed-When: Tue, 10 Jul 2018 20:22:03 +0000
Responsible-Changed-Why:
correct maintainer.


State-Changed-From-To: open->feedback
State-Changed-By: tsutsui@NetBSD.org
State-Changed-When: Sat, 23 Mar 2019 12:57:03 +0000
State-Changed-Why:
Could you try HEAD after the following changes?
http://mail-index.netbsd.org/pkgsrc-changes/2019/02/24/msg187991.html


From: John Klos <john.d@deadoralive.com>
To: gnats-bugs@netbsd.org
Cc: fhajny@netbsd.org, pkgsrc-bugs@netbsd.org, gnats-admin@netbsd.org,
        tsutsui@NetBSD.org
Subject: Re: pkg/53331 (lang/nodejs fails to build on NetBSD/evbarm)
Date: Sun, 24 Mar 2019 15:14:39 +0000 (UTC)

 > Synopsis: lang/nodejs fails to build on NetBSD/evbarm
 > http://mail-index.netbsd.org/pkgsrc-changes/2019/02/24/msg187991.html

 That works fine on aarch64 and on earmv7hf, but on sparc64, alpha (also 
 gives "unrecognized -m32") and powerpc, it fails with:


 /usr/local/bin/gmake -C out BUILDTYPE=Release V=1
    c++ -o 
 /usr/pkgsrc/lang/nodejs/work/node-v10.15.3/out/Release/obj.host/v8_libbase/deps/v8/src/base/bits.o 
 ../deps/v8/src/base/bits.cc '-DV8_GYP_BUILD' 
 '-DV8_TYPED_ARRAY_MAX_SIZE_IN_HEAP=0' '-DV8_TARGET_ARCH_IA32' 
 '-DV8_EMBEDDER_STRING="-node.51"' '-DENABLE_DISASSEMBLER' 
 '-DV8_PROMISE_INTERNAL_FIELD_COUNT=1' '-DV8_INTL_SUPPORT' 
 '-DV8_CONCURRENT_MARKING' '-DDISABLE_UNTRUSTED_CODE_MITIGATIONS' 
 -I/usr/local/include -I../deps/v8  -pthread -Wall -Wextra 
 -Wno-unused-parameter -m32 -msse2 -mfpmath=sse -mmmx -fno-strict-aliasing 
 -I/usr/pkg/include -m32 -fdata-sections -ffunction-sections -O3 -O3 
 -fno-omit-frame-pointer -fno-rtti -fno-exceptions -std=gnu++1y -MMD -MF 
 /usr/pkgsrc/lang/nodejs/work/node-v10.15.3/out/Release/.deps//usr/pkgsrc/lang/nodejs/work/node-v10.15.3/out/Release/obj.host/v8_libbase/deps/v8/src/base/bits.o.d.raw   -c
 g++: error: unrecognized command line option '-msse2'
 g++: error: unrecognized command line option '-mfpmath=sse'
 g++: error: unrecognized command line option '-mmmx'
 gmake[1]: *** [deps/v8/gypfiles/v8_libbase.host.mk:137: 
 /usr/pkgsrc/lang/nodejs/work/node-v10.15.3/out/Release/obj.host/v8_libbase/deps/v8/src/base/bits.o] 
 Error 1
 gmake: *** [Makefile:99: node] Error 2
 *** Error code 2


 mips64eb gives:

 In file included from ../deps/v8/src/base/format-macros.h:27:0,
                   from ../deps/v8/src/base/macros.h:11,
                   from ../deps/v8/src/base/bits.h:12,
                   from ../deps/v8/src/base/bits.cc:5:
 ../deps/v8/src/base/build_config.h:155:2: error: #error Target 
 architecture mips is only supported on mips and ia32 host
   #error Target architecture mips is only supported on mips and ia32 host
    ^
 gmake[1]: *** [deps/v8/gypfiles/v8_libbase.host.mk:137: 
 /usr/pkgsrc/lang/nodejs/work/node-v10.15.3/out/Release/obj.host/v8_libbase/deps/v8/src/base/bits.o] 
 Error 1




 On earm, it fails with:

 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:12:0,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./ANTLRErrorListener.h:52:57: 
 error: 'std::exception_ptr' has not been declared
                              const std::string& msg, std::exception_ptr e) 
 = 0;
                                                           ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:13:0,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./ANTLRErrorStrategy.h:69:49: 
 error: 'std::exception_ptr' has not been declared
     virtual void recover(Parser* recognizer, std::exception_ptr e) = 0;
                                                   ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./BailErrorStrategy.h:8:0,
                   from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:16,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./DefaultErrorStrategy.h:113:49: 
 error: 'std::exception_ptr' has not been declared
     virtual void recover(Parser* recognizer, std::exception_ptr e) 
 override;
                                                   ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:16:0,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./BailErrorStrategy.h:48:49: 
 error: 'std::exception_ptr' has not been declared
     virtual void recover(Parser* recognizer, std::exception_ptr e) 
 override;
                                                   ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:17:0,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./BaseErrorListener.h:25:33: 
 error: 'std::exception_ptr' has not been declared
                              std::exception_ptr e) override;
                                   ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:23:0,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./ConsoleErrorListener.h:34:33: 
 error: 'std::exception_ptr' has not been declared
                              std::exception_ptr e) override;
                                   ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./ParserRuleContext.h:9:0,
                   from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./InterpreterRuleContext.h:8,
                   from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:30,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./support/CPPUtils.h:68:18: 
 error: 'exception_ptr' is not a member of 'std'
   std::string what(std::exception_ptr eptr = std::current_exception());
                    ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./InterpreterRuleContext.h:8:0,
                   from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:30,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./ParserRuleContext.h:66:8: 
 error: 'exception_ptr' in namespace 'std' does not name a type
     std::exception_ptr exception;
          ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./Recognizer.h:8:0,
                   from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./Lexer.h:9,
                   from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:31,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./ProxyErrorListener.h:27:25: 
 error: 'std::exception_ptr' has not been declared
                      std::exception_ptr e) override;
                           ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:36:0,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./Parser.h:258:42: 
 error: 'std::exception_ptr' has not been declared
                                       std::exception_ptr e);
                                            ^
 In file included from 
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./antlr4-runtime.h:158:0,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.h:11,
                   from ../deps/v8/src/torque/TorqueBaseVisitor.cpp:7:
 ../deps/v8/third_party/antlr4/runtime/Cpp/runtime/src/./tree/xpath/XPathLexerErrorListener.h:19:33: 
 error: 'std::exception_ptr' has not been declared
                              std::exception_ptr e) override;
                                   ^
 gmake[1]: *** [deps/v8/gypfiles/torque.host.mk:283: 
 /usr/pkgsrc/lang/nodejs/work/node-v10.15.3/out/Release/obj.host/torque/deps/v8/src/torque/TorqueBaseVisitor.o] 
 Error 1
 gmake: *** [Makefile:99: node] Error 2
 *** Error code 2

 Stop.
 make[1]: stopped in /usr/pkgsrc/lang/nodejs
 *** Error code 1

 Stop.
 make: stopped in /usr/pkgsrc/lang/nodejs


 John Klos

From: Izumi Tsutsui <tsutsui@ceres.dti.ne.jp>
To: john.d@deadoralive.com
Cc: gnats-bugs@netbsd.org, tsutsui@ceres.dti.ne.jp
Subject: Re: pkg/53331 (lang/nodejs fails to build on NetBSD/evbarm)
Date: Sun, 7 Apr 2019 12:24:43 +0900

 This PR is for evbarm so if it works this can be closed.
 (or earm for evbarm is still broken?)

 There is no support other architectures (sparc, mips etc.)
 in nodejs code and it will be handled in PR pkg/53702.

 ---
 Izumi Tsutsui

Responsible-Changed-From-To: fhajny->pkg-manager
Responsible-Changed-By: wiz@NetBSD.org
Responsible-Changed-When: Wed, 27 May 2020 19:39:57 +0000
Responsible-Changed-Why:
Maintainer was reset


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.46 2020/01/03 16:35:01 leot Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2020 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.