NetBSD Problem Report #55056

From bjjl@chaos.lorenz.place  Sat Mar  7 18:12:28 2020
Return-Path: <bjjl@chaos.lorenz.place>
Received: from mail.netbsd.org (mail.netbsd.org [199.233.217.200])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client CN "mail.NetBSD.org", Issuer "mail.NetBSD.org CA" (not verified))
	by mollari.NetBSD.org (Postfix) with ESMTPS id 45D691A9217
	for <gnats-bugs@gnats.NetBSD.org>; Sat,  7 Mar 2020 18:12:28 +0000 (UTC)
Message-Id: <20200307181225.5E8544107AF@chaos.lorenz.place>
Date: Sat,  7 Mar 2020 19:12:25 +0100 (CET)
From: ben@pocket.services
To: gnats-bugs@NetBSD.org
Subject: editors/poedit
X-Send-Pr-Version: 3.95

>Number:         55056
>Category:       pkg
>Synopsis:       missing dependency editors/poedit in -current
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          feedback
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Mar 07 18:15:00 +0000 2020
>Closed-Date:    
>Last-Modified:  Sat Mar 07 20:05:14 +0000 2020
>Originator:     Benjamin Lorenz
>Release:        NetBSD 9.0
>Organization:

>Environment:


System: NetBSD chaos.lorenz.place 9.0 NetBSD 9.0 (GENERIC) #0: Sun Feb 23 00:32:42 CET 2020 bjjl@chaos.lorenz.place:/home/bjjl/9.0/obj/sys/arch/amd64/compile/GENERIC amd64
Architecture: x86_64
Machine: amd64
>Description:
===> Patching for poedit-2.2.3nb4
=> Applying pkgsrc patches for poedit-2.2.3nb4
===> Creating toolchain wrappers for poedit-2.2.3nb4
/bin/mkdir -p /home/bjjl/current/pkgsrc/editors/poedit/work/.buildlink/lib/pkgconfig
cd /home/bjjl/current/pkgsrc/editors/poedit/work/.buildlink/lib/pkgconfig && /bin/ln -sf enchant-2.pc enchant.pc
ERROR: wayland>=1.9.90 is not installed; can't buildlink files.
*** Error code 1


>How-To-Repeat:

>Fix:


>Release-Note:

>Audit-Trail:

State-Changed-From-To: open->feedback
State-Changed-By: wiz@NetBSD.org
State-Changed-When: Sat, 07 Mar 2020 20:05:14 +0000
State-Changed-Why:
a) I just updated poedit to 2.3.0
b) but that won't fix it because wayland is not a direct dependency,
   nor should it be. Please reinstall gtk{2,3} that might fix it.


>Unformatted:

NetBSD Home
NetBSD PR Database Search

(Contact us) $NetBSD: query-full-pr,v 1.46 2020/01/03 16:35:01 leot Exp $
$NetBSD: gnats_config.sh,v 1.9 2014/08/02 14:16:04 spz Exp $
Copyright © 1994-2020 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.